Benchmark window slows the system and degrades graphics resources

Bug #254561 reported by eld1e6o on 2008-08-04
2
Affects Status Importance Assigned to Milestone
Compiz Benchmark Plugin
Low
Daniel van Vugt
Compiz Core
Low
Daniel van Vugt
compiz (Ubuntu)
Low
Daniel van Vugt
compiz-plugins-extra (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

Frecuently, when I have the compiz benchmark activated, the
sistem slows and use a lot of processor (about 16%, the normal is about 1,3 or
2 whit any programs oppened), freezing gently the sistem, and showing 33 fps
whitouth doing anything (in this case the normal in my machine is 250 fps), but
when i disable this window (super + f12) it runs better but slowest than the
first case mentioned (when the window is enabled and it is working fine). I
can't show now this window (benchmark) because when i move any window the
animations are very slow.

It happens whit the version of compiz in the repositories.

------------------------------------------------------------------------

Now, whit the launchpad version (0.7.6) I have other problems (I don't test if it happens whit the previous version):
reported in http://bugs.opencompositing.org/show_bug.cgi?id=1019

FIRST: When I move any window, wobbly plugin works very slow, but when the
compiz benchmark window is displayed (super + f12), the wobbly plugin works
very fast and fine!

Also, when the compiz benchmark window is displayed, if I open a new window,
the animation effects (confirmed: "Lámpara Mágica" or magic lamp effect and
"Doblado con curvas" or doubled whth curves, I suppose that is known in
English) works faster and better!

I thought they were hardware limitations but apparently are not and they can
run better and faster (i have an nvidia fx 5200 with 128 mb of video memory)

The Cube Reflection And Deformation plugin have the same problem (It run
extremely better when i'm displaing the compiz benchmark plugin!)

I'm using the version 0.7.6 and I can't test now but I thing this problem
exists in the previous version

SECOND: Also, frecuently, when I have the compiz benchmark activated, the
sistem slows and use a lot of processor (about 16%, the normal is about 1,3 or
2 whit any programs oppened), freezing gently the sistem, and showing 33 fps
whitouth doing anything (in this case the normal in my machine is 250 fps), but
when i disable this window (super + f12) it runs better but slowest than the
first case mentioned (when the window is enabled and it is working fine). I
can't show now this window (benchmark) because when i move any window the
animations are very slow

In the previous version of compiz, i had the same problem!

Sorry if my english isn't very good, I'm from argentina. Good work,
congratulations!

Greetings!

Related branches

Changed in compiz:
assignee: nobody → compiz
importance: Undecided → Low
status: New → Triaged
Changed in compiz:
status: Unknown → New
Travis Watkins (amaranth) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Karmic Koala. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/. Thanks again and we appreciate your help.

Changed in compiz (Ubuntu):
status: Triaged → Incomplete
eld1e6o (eld1e6o) wrote :

Hello, I had problems with my internet connection, so I delayed.
I have this problems in the beta of Ubuntu Karmic, I'm testing this bug in a notebook with a nvidia geforce go 6150 whit the processor in mode Ondemand, If I'm haven't active the benchmark plugin (enabled or not) the processor works normal, at 800 Mhz and it's used normally, but when I active the benchmark, the processor turns on mode 1,8 Ghz and it's used at maximum possible (about 80~90% by the task /usr/bin/compiz.real and the processor is totally used by the system)

Greetings!

eld1e6o (eld1e6o) on 2009-10-12
Changed in compiz (Ubuntu):
status: Incomplete → Confirmed
Daniel van Vugt (vanvugt) wrote :

This bug appears to be a combination of bug 898548 and the compiz timing issues I have proposed fixes for recently:
https://code.launchpad.net/~vanvugt/compiz-core/fix-880707.2

Changed in compiz (Ubuntu):
assignee: compiz packagers (compiz) → Daniel van Vugt (vanvugt)
status: Confirmed → Fix Committed
Changed in compiz-core:
status: New → Fix Committed
importance: Undecided → Low
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in compiz-bench-plugin:
assignee: nobody → Daniel van Vugt (vanvugt)
importance: Undecided → Low
status: New → Fix Committed
Changed in compiz-core:
milestone: none → 0.9.7
summary: - Benchmark window freezes gently the sistem and degrade resurces of video
- card
+ Benchmark window slows the system and degrades graphics resources
Launchpad Janitor (janitor) wrote :
Download full text (6.6 KiB)

This bug was fixed in the package compiz - 1:0.9.7.0~bzr2995-0ubuntu1

---------------
compiz (1:0.9.7.0~bzr2995-0ubuntu1) precise; urgency=low

  [ Didier Roche ]
  * New upstream snapshot:
    - Fix slow/stuttering display with fglrx (LP: #763005)
    - Don't dynamically link to compiz_core
    - Fix build failures with glib 2.30 (oneiric) (LP: #921406)
    - Fix uninitialized variable warnings in valgrind (LP: #921451)
    - Fixes up a bunch of boost::variant edge cases
    - Fixes a race condition where the xig restart test would fail spuriously
    - Incorrect (low/stuttering) refresh rate with NVIDIA driver (LP: #92599)
    - Benchmark window slows the system and degrades graphics resources
      (LP: #254561)
    - Windows that hide themselves when closed don't appear in any
      "this workspace" switcher (LP: #684731)
    - hang in g_spawn_sync and select() (LP: #690239)
    - word misspelled - bunding (LP: #694169)
    - sometimes, restored window placed too high. (LP: #716521)
    - Compiz clears the root window in the installer session (LP: #720679)
    - unity-window-decorator: When switching between windows, Orca does
      not speak the title of the focused window. (LP: #724093)
    - Cannot open a window that starts iconified (LP: #732997)
    - Minimize animation flickr when for maximized apps (LP: #737125)
    - Pixmap memory leak in gtk-window-decorator (LP: #740258)
    - Windows should not automatically be focused when opened if the
      focus is on another application (LP: #748840)
    - [sandybridge] Graphics tearing when playing video (LP: #755841)
    - Compiz's "Sync to Vblank" makes display stutter/slow with fglrx
      (LP: #763005)
    - [regression] Moving windows lags behind the mouse by 1-2 seconds;
      appear to freeze when dragging. (LP: #764330)
    - Launcher - Spread should not affect the state of window (LP: #764673)
    - Clicking on a tweet/message link sometimes does not work (LP: #790565)
    - scrolling on top of a close animation switches viewports (LP: #795065)
    - unity video tearing when moving windows in oneiric with
      nvidia-current (LP: #798868)
    - dialogs really slow to be displayed since the compiz update (LP: #812711)
    - It is possible to stack windows relative to windows that are
      destroyed (LP: #837252
    - Should keep list of windows last sent to server and last recv
      from server (LP: #841727)
    - compiz and X can disagree on the stacking order (LP: #845719)
    - A minimized window 'remains' behind on the desktop if
      /apps/compiz-1/plugins/unityshell/screen0/options/
      show_minimized_windows is set to true (LP: #847967)
    - maximized windows fail to update their input extents when
      undecorated (LP: #853734)
    - resizing bugs with xterm (LP: #854725)
    - crash on closing a window (LP: #856015)
    - Java application windows cut-off/truncated/not displayed properly
      (LP: #857201)
    - compiz crashed with SIGSEGV in CompScreen::insertServerWindow()
      (LP: #857487)
    - compiz crashed with SIGABRT in raise() (LP: #857738)
    - Applications which create multiple windows that are transients of
      each other...

Read more...

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :

Fix released in:
compiz (1:0.9.7.0~bzr2995-0ubuntu1) precise; urgency=low
compiz-plugins-extra (0.9.7.0~bzr9-0ubuntu1) precise; urgency=low

Changed in compiz-plugins-extra (Ubuntu):
status: New → Fix Released
Changed in compiz-core:
status: Fix Committed → Fix Released
Changed in compiz-bench-plugin:
status: Fix Committed → Fix Released
no longer affects: compiz
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.