Too easy to accidentally enter zoom mode (meta-R)

Bug #220939 reported by Morris Johns on 2008-04-23
4
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Wishlist
Unassigned

Bug Description

As a newbie I hit win-R by mistake and didn't know what I had done or how to get out of the zoomed mode... hitting win-R again doesn't go back to unzoomed... Even worse, if I had hit it by mistake without realising, rebboting would have been the only option to fix the "problem".

So I started trying to find an 'unzoom' button, and I hit win-L which locks the mouse panning. This key is also a dangerous key for a newbie because desktops appear locked up, but you wouldn't realise that immediately so wouldn't make the connection between keypress and feature.

Finally I had two other problems with these features:
a) win-R and win-L together is stuffed (mouse positioning doesn't match screen any more - hover over a button and it doesn't work - you need to hover over where the button was before the win-R zooming)
b) win-L disables win-R/zoom etc. (again not so obvious until you have learned the feature)
a) I tried to find where to disable those keybindings but had no luck (they don't appear to show in the Keyboard Shortcuts).

I am using Heron Beta updated to Apr 24 with default compiz (appearance | visual effects | NORMAL)

I think keyboard shortcuts that cause modal changes to the UI are dangerous to the new user - because if they hit they keys by mistake then they don't udnerstand why Ubuntu is "locked up" or "acting wierd" and can only resort to a reboot to fix the "bug".

Morris Johns (morris-johns) wrote :

Found the culprit... I installed the CompizConfig Settings Manager, and found that these are features of the "Enhanced Zoom Desktop" under "Accessibility". I am pretty sure I never enabled accessibility features. And an inadvertant super-L or super-R makes the desktop inaccessible.

Perhaps disable accessibility features unless the user enables them????!

It was somewhat unobvious to me that I needed to install another program to configure the "normal" appearance.

Daniel T Chen (crimsun) on 2008-12-15
Changed in compiz:
importance: Undecided → Wishlist

 Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

Changed in compiz:
status: New → Incomplete
Morris Johns (morris-johns) wrote :

Unfortunately I am not currently planning on changing from 8.04 LTS. It shouldn't be hard to repeat.

1) Are accessability features enabled by default? If not, then no problem and close this fault. If so, then that seems dumb because of the dangerous unobvious keystroke combinations making radical changes (I would guess if Ubuntu had decided to make it default then it wouldn't be considered a bug!)

2) If accessability features enabled by default (or if you care about accessability features working properly), then open a smallish window with a couple of buttons and give it the focus, do super-L then do super-R. If you can't click buttons then you have reproduced the fault. If you can click buttons then this bug can be closed.

Changed in compiz (Ubuntu):
status: Incomplete → Triaged
summary: - accessibility functions clash with sane defaults in UI (win-L or win-R)
+ Easy to accidentally enter zoom mode (meta-R)
summary: - Easy to accidentally enter zoom mode (meta-R)
+ Too easy to accidentally enter zoom mode (meta-R)
Travis Watkins (amaranth) wrote :

Super-L was already disabled, Super-R is disabled in our bzr packaging repo. Will be in the next upload.

Changed in compiz (Ubuntu):
status: Triaged → Fix Committed
Xyverz (xyverz) wrote :

Nope, still a problem in 9.10 beta

Xyverz (xyverz) wrote :

I have to say, the fact that you have to install compizconfig-settings-manager to TURN THIS OFF is REALLY not a good thing. Is it possible to set "Enable Enhanced Zoom Desktop" to off altogether, or have compizconfig-settings-manager installed by default so that people can at least find out how to turn this off?

Travis Watkins (amaranth) wrote :

Notice I said it'll be fixed in the next upload. That hasn't happened yet.

Travis Watkins (amaranth) wrote :

compiz-fusion-plugins-main (0.8.3+git20091006-0ubuntu1) karmic; urgency=low

  [ Robert Ancell ]
  * Pre-Release of the upcomming 0.8.4 bugfix release: (LP: #446931)
    - compiz.real crashed with SIGSEGV in handleEvent() (LP: #430518)
    - Shift switcher (Super-Tab) shows wrong behaviour on 'escape' (LP: #154371)
    - Compiz shift-switcher should not scale icons for minimized windows
      (LP: #136336)

  [ Travis Watkins ]
  * debian/patches/03_default_options.patch:
    - disable ezoom fit_to_window key (LP: #220939)

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers