compiz stuck at 100% cpu when firefox pop-up appears

Bug #218726 reported by Nick Barcet on 2008-04-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Compiz
Fix Released
Unknown
compiz (Ubuntu)
Medium
Michael Vogt
compiz-fusion-plugins-main (Ubuntu)
Medium
Michael Vogt

Bug Description

Binary package hint: compiz

When a google calendar pop up alert from firefox arrive in the background, compiz.real gets stuck at 100% cpu.

Killing the compiz.real process only work with -9 signal.

dpkg -l | grep compiz
ii compiz 1:0.7.4-0ubuntu5 OpenGL window and compositing manager
ii compiz-core 1:0.7.4-0ubuntu5 OpenGL window and compositing manager
ii compiz-fusion-plugins-extra 0.7.4-0ubuntu1 Collection of extra plugins from OpenComposi
ii compiz-fusion-plugins-main 0.7.4-0ubuntu3 Collection of plugins from OpenCompositing f
ii compiz-gnome 1:0.7.4-0ubuntu5 OpenGL window and compositing manager - GNOM
ii compiz-plugins 1:0.7.4-0ubuntu5 OpenGL window and compositing manager - plug
ii compizconfig-backend-gconf 0.7.4-0ubuntu1 Settings library for plugins - OpenCompositi
ii compizconfig-settings-manager 0.7.4-0ubuntu2 Compiz configuration settings manager
ii libcompizconfig0 0.7.4-0ubuntu1 Settings library for plugins - OpenCompositi
ii python-compizconfig 0.7.4-0ubuntu1 Compiz configuration system bindings

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

This might be http://bugs.freedesktop.org/show_bug.cgi?id=15424

Please let us know (with ccsm) which of the following plugins you have loaded: animation/cube/3d

Changed in compiz:
status: New → Incomplete
Nick Barcet (nijaba) wrote :

Only animation is loaded. I am going to unload it and tell you if it reproduces.

Changed in compiz:
status: Incomplete → New
Michael Vogt (mvo) wrote :

I suspect its https://bugs.freedesktop.org/show_bug.cgi?id=15424 and that the animation plugin is causing this.

Nick Barcet (nijaba) wrote :

I can confirm that the bug does not reproduce when animation is unloaded.
As a side note, it is interesting that unloading animation also fixes the focus issue described in bug #150336.

Nick Barcet (nijaba) wrote :

Reverting compiz-fusion-plugins-main to 0.7.2 using a custom version built by mvo fixes the issue. Reverting to official 0.7.4 brings it back (x restart required in between).

Nick Barcet (nijaba) wrote :

Attaching a profile with which I am able to reproduce the problem

Michael Vogt (mvo) on 2008-04-21
Changed in compiz:
assignee: nobody → mvo
importance: Undecided → Medium
milestone: none → ubuntu-8.04
status: New → Confirmed
Changed in compiz:
status: Unknown → Fix Released
Nick Barcet (nijaba) wrote :

I confirm that I cannot reproduce the issue with compiz-fusion-plugins-main - 0.7.4-0ubuntu4

Thanks Michael :)

Michael Vogt (mvo) wrote :

Thanks for confirming the fix. It works fine for me too.

This bug most likely has a lot of duplicates (probably all of the recent "compiz hangs/compiz uses 100% cpu) so the fix is pretty important IMO.

Changed in compiz:
status: Confirmed → In Progress
Steve Langasek (vorlon) on 2008-04-21
Changed in compiz-fusion-plugins-main:
assignee: nobody → mvo
importance: Undecided → Medium
milestone: none → ubuntu-8.04
status: New → In Progress
Steve Langasek (vorlon) on 2008-04-21
Changed in compiz:
milestone: ubuntu-8.04 → none
status: In Progress → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz-fusion-plugins-main - 0.7.4-0ubuntu4

---------------
compiz-fusion-plugins-main (0.7.4-0ubuntu4) hardy; urgency=low

  * debian/patches/05_from_git_fix_ring_crash.patch:
    - fix crash in ring switcher (LP: #217592), from git
      commit bb3427df3854f8338ba4bcb8d9e62bcd2c27cdb2
  * debian/patches/06_from_git_fix_hang_in_animation.patch:
    - fix hang in animation plugin (LP: #218726), from git
      commit b9239c36365c57eec7961a8f24aaa0faa3a0f784

 -- Michael Vogt <email address hidden> Mon, 21 Apr 2008 11:04:48 +0200

Changed in compiz-fusion-plugins-main:
status: In Progress → Fix Released
neil king (neil-neilking) wrote :

If you are using the trailfocus saturation option keep both saturation values at 100. Anything other that that keeps one of my cpu cores at 100% on Ubuntu 11.10 (Oneiric).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.