Freeze exception for 0.7.4

Bug #213511 reported by Michael Vogt on 2008-04-07
2
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Wishlist
Michael Vogt

Bug Description

Binary package hint: compiz

Compiz and compiz-fusion 0.7.4 got release at the end of last week. I would like to ask for a freeze exception for it for hardy. Here are the NEWS:
 + Configurable handling of overlapping output devices.
 + Enhanced focus stealing prevention with configurable amount of focus
     stealing prevention.
 + Added configurable, optional delay for edge actions to prevent
    accidential invocation.
 + Generalized vertex system to improve plugin compatibility.
 + Optimized gaussian blur shaders to support more hardware.
 + Improved unredirection of fullscreen windows.
 + Several bugfixes.
 + Translation updates.

Especially the overlapping output device and fixes in the handling of unredirected fullscreen apps are pretty interessting for us, but the other bugfixes are good too and the risk of regressions shouldn't be too high.

We need to update the rest of the compiz-fusion stack too to get the full benefits of the update, the NEWS:
 plugins-main:
 * Expo has a new transformation mode: "Curve"
 * Bug fixes in several plugins

 plugins-extra:
 * New plugin: bicubic, which adds shader based bicubic filtering to improve
   the quality of scaled textures
 * Bug fixes

 libcompizconfig:
 * Minor bug fixes

Configuration manager changes:
 ccsm:
 * Improved look of edge and button selector widgets
 * Fixed automatically resolving conflicts
 * Fixed a few bugs in the Profiles page
 * Unified list settings with regular settings
 * Fixed resolution of svg icons => sharp plugin icons
 * Lots of smaller code cleanups
 * Advanced Search rewrite

 simple-ccsm:
 * Added expo plugin to effects page
 * Added widget to configure global edge settings
 * Added 'mag' plugin as 'area zoom' to zoom page
 * Minor code cleanups

The full upgrade was prepared in my PPA at "deb http://ppas.launchpad.net/mvo/ubuntu hardy main"

Michael Vogt (mvo) wrote :
Michael Vogt (mvo) wrote :
Michael Vogt (mvo) wrote :
Michael Vogt (mvo) wrote :
Michael Vogt (mvo) wrote :
Michael Vogt (mvo) wrote :
Michael Vogt (mvo) wrote :
Michael Vogt (mvo) wrote :

I have not included build logs here, but they can be found in http://launchpad.net/~mvo/+archive

Some user feedback is available in the mvogt.wordpress.com comments page and in the forums. Some glitches apparently, but mostly good. Note that some of the issues (e.g. firefox menu oddness) are there with 0.7.2 too because the new firefox (beta5) has different window resource names then beta4 for menus.

Roberto Cássio Jr. (rcsdnj) wrote :

I have frequently some problems on current Hardy's Compiz release when running some full-screen 3D programs, like the Mupen emulator, and also ZSNES. I didn't report as a bug because I didn't have time yet to identify exactly how to reproduce the problem (some times it happens, some times not). The program keeps alternating between window and full screen mode, while it becomes unresponsive. Very annoying. I guess this is probably a bug on "Unredirect full screen" function, and, if 0.7.4 fixes this problem, it would be surely a great addition to Hardy's stability :)

Changed in compiz:
importance: Undecided → Wishlist
Steve Langasek (vorlon) wrote :

FFe ack, please upload ASAP.

Changed in compiz:
status: New → Confirmed
Michael Vogt (mvo) wrote :

Thanks for the review (and to everybody how tested).

I uploaded the 0.7.4 packages to main now (peding a FFe from universe for the config tools).

Changed in compiz:
assignee: nobody → mvo
status: Confirmed → Fix Committed
Michael Vogt (mvo) on 2008-04-21
Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.