No window-decorations in compiz with GeForce MX 460 and Hardy [while Fedora 8 worked]

Bug #213025 reported by mb on 2008-04-06
4
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

Hello,

in recently installed ubuntu 8.04 on a PC with a GeForce 4 MX 460. Desktop-Effects are enabled after install process by default. But there are no window decorations. Switching desktop effects to "none" will give me window-decorations back but will remove desktop effects. A few month ago i tried Fedora 8 where compiz worked out of the box on the same machine (with window decorations).

regards

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in compiz.

Pedro Villavicencio (pedro) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please add your ~/.xsession-errors, /var/log/Xorg.0.log and the output of lspci -vvnn to your bug report as separate attachments? Thanks in advance.

Changed in compiz:
status: New → Incomplete
Pat Double (patdouble) wrote :

I am having this same problem. I installed via Ubuntu Hardy Beta CD. I enabled the restricted ATI driver through "Hardware Drivers" (jockey). Update Manager updated compiz and replaced some packages. The reason this is broken is that I do not have /usr/bin/gtk-window-decorator. I believe this file is part of compiz-gnome. The only packages I've installed manually are postgresql-8.2 and powertop. I think there is something missing in the Ubuntu UI to include compiz-gnome.

Pat Double (patdouble) wrote :

I need to add that compiz-gnome was originally installed by the Hardy Beta CD. It was removed in a subsequent update by Update Manager. See attached log from "grep compiz /var/log/dpkg.log".

mb (maxbloemer) wrote :
mb (maxbloemer) wrote :
mb (maxbloemer) wrote :
Travis Watkins (amaranth) wrote :

Maximilian: Your problem can be fixed by running 'sudo nvidia-xconfig --add-argb-glx-visuals' and restarting X.

Pat: Your bug was a temporary upgrade hiccup that is now fixed.

Changed in compiz:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers