New windows won't maximize with Compiz enabled

Bug #210022 reported by DanielRoesler on 2008-04-01
2
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Low
Unassigned

Bug Description

When CompizFusion is enabled, new windows created that should be maximized, aren't. The new window is just the maximum size of the screen, but not maximized (see screenshot). You can still drag the windows around by clicking the title bar. The most common place to experience this bug is with Firefox (since you can be opening new windows often). This used to be reproducible sometimes, but on the Hardy Heron 8.04 beta LiveCD, I have been able to reproduce it most of the time. I have the Desktop Cube and Wobbly Windows enabled, but I think this happens with the default Desktop Wall, too.

Steps to reproduce:
1) Open a Firefox window.
2) Maximize the window.
3) Right-click on a link and "Open Link in New Window"
4) The new window should be maximized, but it's just a large non-maximized window (see screenshot).

Reason why this is annoying:
1) This is very non-intuitive for the user. When creating an new window from a maximized window, the new window should have the same properties of the old window (i.e. maximized). It requires an extra click to create expected result.
2) The large non-maximized window created is one or two pixels off from where it should be. This partially hides the right scroll bar and window close button. It's not much, but it is still visually annoying that part of your window is missing. It requires an extra click to maximize the window or a click and drag to pull the window back a few pixels.
3) With the sweet, sweet eye candy of CompizFusion, you can't stretch and bend windows unless they are maximized. So, it requires an extra click to maximize the window to take advantage of the extra features.
4) If you move the top gnome panel to the bottom (if the user likes gnome but also likes to mimic KDE's panel, say), you can throw your mouse to the top right corner to close a maximized window. You don't even have to look. However, since the new large non-maximized window is a few pixels off, the throw-the-mouse-to-the-top-right technique is no longer effective.

Desktop real estate can be very valuable for small screens, so maximizing is often favored. This bug requires extra clicks to create that situation.

The attached screenshot shows how the new window is the same size of the screen, but not maximized.

DanielRoesler (diafygi) wrote :

After playing around with the Hardy beta LiveCD, the probability of this bug occurring is about 50%. To reproduce, just "Open Link in New Window" about a bunch of times (maybe 10+). One of the times, the window won't be maximized. Maybe it has something to do with cpu load, although I can't see why.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Thanks in advance.

Changed in compiz:
importance: Undecided → Low
status: New → Incomplete
DanielRoesler (diafygi) wrote :

I've been trying to pay attention for the last few days, and I don't see this happening anymore. So I would call this bug fixed, but I don't know when it happened. I'll be sure to post here again if I start to notice it again. Thanks!

Jonathan Thomas (echidnaman) wrote :

That's good. :)
I'm going to close this as fixed for now. If you experience the bug again you can reopen it by clicking on the status and setting it back to "New".

Changed in compiz:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers