Thunderbird has no window decorations

Bug #209848 reported by Simon Sprünker on 2008-03-31
This bug report is a duplicate of:  Bug #197820: No window decorations. Edit Remove
6
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

With Visual Effects set to "None" Thunderbird looks normal, but when Visual Effects are set to "Normal" or "Extra" Thunderbird does not have any window decorations (see attached screenshot). This behaviour does not change when I disable the Lightning plugin.

Also newly opened windows, like after clicking on "Write", are not opened in the foreground but behind the main Thunderbird window.

Description: Ubuntu hardy (development branch)
Release: 8.04

thunderbird:
  Installed: 2.0.0.12+nobinonly-0ubuntu1
  Candidate: 2.0.0.12+nobinonly-0ubuntu1
  Version table:
 *** 2.0.0.12+nobinonly-0ubuntu1 0
        500 http://de.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)

Pedro Villavicencio (pedro) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please add your ~/.xsession-errors, /var/log/Xorg.0.log and the output of lspci -vvnn to your bug report as separate attachments? Thanks in advance.

Changed in compiz:
status: New → Incomplete

Thanks for looking into this. If you need anything else, just let me know.

The latest batch of updates (including compiz) have fixed this issue for me. I don't know if "invalid" is the right status for this bug, feel free to change.

Changed in compiz:
status: Incomplete → Invalid
jurjen (jurjen-jurjen) wrote :

for me updates didn't fix it. I still have the exact same problem as Simon Sprunker originally had. As attachments my xsessions-errors, log and the output of lspci. Thanks for looking at it!

jurjen (jurjen-jurjen) wrote :
jurjen (jurjen-jurjen) wrote :

ps. i have the same version of thunderbird installed (2.0.0.12+nobinonly-0ubuntu1), but downloaded from the dutch (=nl) repository, it is the english version btw (in case it makes any difference, wich i doubt).

jurjen (jurjen-jurjen) wrote :

changed from 'invalid'. It did seem the bug was already changed by a new update. For me it didn't, so it might be a valid bug? I don't know if 'in progress' is the right status, so again; feel free to change!

Changed in compiz:
status: Invalid → In Progress

I can confirm this bug.

This only happens with thunderbird, and when I call the old firefox2.

The effect is that on my laptop (Asus A8JS) the thunderbird window is shown on the left display (I have a monitor attached right of the laptop, so left is the laptop screen) in fullscreen, with no borders. Im not able to move or resize it in any way.
When it happens, then every child window (e.g. reply) has the same effect. When it doesn't happen, (because it is temporarily fixed by the workaround below) every child works except that sometimes when writing a reply the window borders flash to full transparency and back with every keystroke :)

A temporary workaround can be found in this post:
http://forum.compiz-fusion.org/showpost.php?p=59083&postcount=13

It states:
--- SNIP ---
Located in your ~/.mozilla-thunderbird directory is your default profile directory. There is a file in there called localstore.rdf that specifies settings in XML. Edit the file and check out the tag that starts with:
<RDF:Description RDF:about="chrome://messenger/content/messenger.xul#messengerWindow"
You should see values for screenX and screenY (that are the coordinates of the upper left corner of the Tbird window). Set them to something like 5 and set width="800" and height="600". Save the file and restart Tbird and see if that doesn't fix things.
--- SNIP ---

But usually after about 2 or 3 starts of thunderbird the problem is back. Couldn't find a pattern here yet.

The logs you requested from Simon:

My .xsession-errors

Since about two months now, this didn't occur to me anymore.

Although I am not 100% sure I think it still occurred a few times after updating to Ubuntu 8.10 (intrepid), but was gone soon after.

I think, for me, it's safe to say that this was fixed in the meantime.

Robert Schaffar-Taurok wrote:
> I think, for me, it's safe to say that this was fixed in the meantime.
>
Same here. I was using the desktop effeects with 8.10 and did not see
this problem at all.

This bug went away for me once I nuked my TB profile and created a new
profile.

Robert Schaffar-Taurok wrote:
> Since about two months now, this didn't occur to me anymore.
>
> Although I am not 100% sure I think it still occurred a few times after
> updating to Ubuntu 8.10 (intrepid), but was gone soon after.
>
> I think, for me, it's safe to say that this was fixed in the meantime.
>
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers