compiz.real crashed with SIGSEGV in updateWindowAttributes()

Bug #206866 reported by Ludovico Cavedon on 2008-03-25
74
Affects Status Importance Assigned to Milestone
Compiz
Invalid
Unknown
compiz (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: compiz

compiz crashed switching window with Alt-tab

cavedon@cavedon-pc:~$ lsb_release -rd
Description: Ubuntu hardy (development branch)
Release: 8.04

cavedon@cavedon-pc:~$ apt-cache policy compiz
compiz:
  Installed: 1:0.7.2-0ubuntu2
  Candidate: 1:0.7.2-0ubuntu2
  Version table:
 *** 1:0.7.2-0ubuntu2 0
        500 http://it.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

ProblemType: Crash
Architecture: amd64
CrashCounter: 1
Date: Wed Mar 26 00:09:30 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/compiz.real
Package: compiz-core 1:0.7.2-0ubuntu2
PackageArchitecture: amd64
ProcCmdline: /usr/bin/compiz.real --ignore-desktop-hints --replace --indirect-rendering --sm-client-id default0 ccp
ProcEnviron:
 LC_TIME=en_IE.UTF-8
 PATH=/home/username/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: compiz
StacktraceTop:
 updateWindowAttributes ()
 ?? () from /usr/lib/compiz/libmove.so
 handleEvent ()
 ?? () from /usr/lib/compiz/libvideo.so
 ?? () from /usr/lib/compiz/libworkarounds.so
Title: compiz.real crashed with SIGSEGV in updateWindowAttributes()
Uname: Linux 2.6.24.3 x86_64
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin netdev plugdev powerdev sambashare scanner src video

Related branches

Ludovico Cavedon (cavedon) wrote :

StacktraceTop:moveInitiate (d=<value optimized out>, action=0x983230,
handleEvent (d=0x64e260, event=0x7fff7008a000) at ../../src/event.c:304
videoHandleEvent (d=0x64e260, event=0x7fff7008a000) at ../../plugins/video.c:974
workaroundsHandleEvent (d=0x64e260, event=0x7fff7008a000) at workarounds.c:565
vpswitchHandleEvent (d=0x64e260, event=0x7fff7008a000) at vpswitch.c:357

Changed in compiz:
importance: Undecided → Medium
Basilio Kublik (sourcercito) wrote :

Hi there
do you still experience this issue with the latest updates in Hardy Heron and/or under a new user account?, could you please provide the steps to trigger this bug.

Thanks in advance

Changed in compiz:
assignee: nobody → sourcercito
status: New → Incomplete
Kjell Braden (afflux) wrote :

Setting to confirmed because of the duplicates and because the package they're using is up to date. I'm going to report the bug to upstream now.

Changed in compiz:
assignee: sourcercito → afflux
status: Incomplete → Confirmed
Kjell Braden (afflux) wrote :

This bug has been reported to the developers of the software. You can track it and make comments here: http://bugs.opencompositing.org/show_bug.cgi?id=882.

Changed in compiz:
assignee: afflux → nobody
status: Confirmed → Triaged
Changed in compiz:
status: Unknown → Invalid
Changed in compiz:
status: Triaged → Fix Committed
Michael Vogt (mvo) wrote :

This got fixed by Travis (thanks!) and the fix is in my bzr repository.

Michael Vogt (mvo) wrote :

"my bzr repository" -> the compiz packagers repository of course.

Anyway, I uploaded it now and it waits approval because we are in the freeze. I also uploaded it to the 0.7.4 PPA

Bálint Magyar (balintm) wrote :

Thank you Travis and Michael! Here's to hoping this makes Hardy final.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.7.2-0ubuntu3

---------------
compiz (1:0.7.2-0ubuntu3) hardy; urgency=low

  [ Travis Watkins ]
  * debian/patches/037_fullscreen_stacking_fixes.patch:
    - check for valid window (LP: #206866)

 -- Michael Vogt <email address hidden> Sun, 10 Apr 2008 23:13:37 +0200

Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.