compiz segfault during normal window operations

Bug #206642 reported by jloretz on 2008-03-25
6
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Low
Basilio Kublik

Bug Description

After applying the updates from 03/24/2008 during the BETA, compiz began exiting with a segfault during normal windowing operations: rotating cube, opening new windows, and using the ALT-TAB window changing method. The following was produced from the command line using dmesg:

[105102.279658] compiz.real[6323]: segfault at 0098007d eip b7eebfff esp bfd6ccf0 error 6

/var/log/messages:

Mar 25 12:34:56 wally kernel: [105102.279658] compiz.real[6323]: segfault at 0098007d eip b7eebfff esp bfd6ccf0 error 6

During this time, the Xwindow session would become un-responsive for 15-30 seconds and then revert to the non-compiz enabled windowing environment. This happened both on a Sony laptop (nvidia) and Dell desktop (fglrx). When re-enabling the compiz option in the "System->Preferences->Appearance" tool, it turns back on without restoring the settings from the previous configuration.

Other information about the system:

Description: Ubuntu hardy (development branch)
Release: 8.04

jloretz (jloretz) wrote :
jloretz (jloretz) wrote :
jloretz (jloretz) wrote :
Basilio Kublik (sourcercito) wrote :

Hi there
do you still experience this issue with the latest updates in Hardy Heron?

Thanks in advance

Changed in compiz:
assignee: nobody → sourcercito
importance: Undecided → Low
status: New → Incomplete
jloretz (jloretz) wrote :

it appears to be corrected with the new updates that have been coming out. i do have problems with the new date/weather calendar occasionally freezing making the gnome-panel useless and kill -HUP seems to resolve that. but i am sure that is not a compiz issue.

thanks

Werner Kuballa (wkuballa) wrote :

I experience the same problem with the released 8.04. It happened three or four times so far, but I can't tell what triggered it. It is hardly noticeable at the time it happened. I usually notice it later when I want to rotate to another workspace. I also noticed that all windows from all workspaces are placed into the current workspace (since I work with "auto-hiding" I don't notice it at the time it happens). My line in /var/log/messages is:

May 1 11:22:09 wkuballa-710 kernel: [70391.207304] compiz.real[24402]: segfault at 0000035d eip b73d4530 esp bf996e1c error 4

uname -r
2.6.24-16-generic

Regards
Werner

zdenek.zikan (zdenek-zikan) wrote :

The same for me. Ubuntu 8.04 with all updates.

compiz.real[18311]: segfault at 01f10086 eip 080658a8 esp bfee22e0 error 4

$ dpkg --status compiz xorg | grep Version
Version: 1:0.7.4-0ubuntu7
Version: 1:7.3+10ubuntu10.2

We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

I am using 8.10 and it is no longer an issue for me in that release.

Thanks,
Jason

On Thu, Jan 29, 2009 at 02:23:11PM -0000, Martin Mai wrote:
> We were wondering if this is still an issue for you. Can you try with
> the latest Ubuntu release? Thanks in advance.
>
> --
> compiz segfault during normal window operations
> https://bugs.launchpad.net/bugs/206642
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in ???compiz??? source package in Ubuntu: Incomplete
>
> Bug description:
> After applying the updates from 03/24/2008 during the BETA, compiz began exiting with a segfault during normal windowing operations: rotating cube, opening new windows, and using the ALT-TAB window changing method. The following was produced from the command line using dmesg:
>
> [105102.279658] compiz.real[6323]: segfault at 0098007d eip b7eebfff esp bfd6ccf0 error 6
>
> /var/log/messages:
>
> Mar 25 12:34:56 wally kernel: [105102.279658] compiz.real[6323]: segfault at 0098007d eip b7eebfff esp bfd6ccf0 error 6
>
> During this time, the Xwindow session would become un-responsive for 15-30 seconds and then revert to the non-compiz enabled windowing environment. This happened both on a Sony laptop (nvidia) and Dell desktop (fglrx). When re-enabling the compiz option in the "System->Preferences->Appearance" tool, it turns back on without restoring the settings from the previous configuration.
>
> Other information about the system:
>
> Description: Ubuntu hardy (development branch)
> Release: 8.04

Thank you, jloretz. Therefore closing the bug.

Changed in compiz:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers