compiz.real crashed with signal 7

Bug #205356 reported by dirk on 2008-03-22
This bug report is a duplicate of:  Bug #131679: Crash inside doPoll(). Edit Remove
272
This bug affects 17 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: compiz

?

ProblemType: Crash
Architecture: amd64
Date: Sun Mar 23 00:48:35 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/compiz.real
NonfreeKernelModules: fglrx
Package: compiz-core 1:0.7.2-0ubuntu2
PackageArchitecture: amd64
ProcCmdline: /usr/bin/compiz.real --ignore-desktop-hints --replace --indirect-rendering --sm-client-id default0 ccp
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
Signal: 7
SourcePackage: compiz
Stacktrace: #0 0x000000000040feb0 in ?? ()
StacktraceTop: ?? ()
ThreadStacktrace:

Title: compiz.real crashed with signal 7
Uname: Linux 2.6.24-12-generic x86_64
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev video

dirk (dirkmeissner72) wrote :

StacktraceTop:

Changed in compiz:
importance: Undecided → Medium
Basilio Kublik (sourcercito) wrote :

Hi there
is this reproducible with the latest updates in Hardy Heron?

Thanks in advance

Changed in compiz:
assignee: nobody → sourcercito
status: New → Incomplete
Changed in compiz:
assignee: sourcercito → nobody
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!.

Changed in compiz:
status: Incomplete → Invalid
hakinchen (hakinchen) wrote :

The problem ist, that the bug appear when gnome ist starting up. And I don't now how it is reproducible.

best wishes
    hakinchen

Julio Lajara (ju2wheels) wrote :

I can confirm this in Intrepid Alpha 6 64bit. It crashed right after booting up. I went to the Sounds panel to disable some sounds, I played one sound to listen to it and then it crashed and wouldnt play another one.

ktp420 (ktp420) wrote :

It happened to me too right after reboot

Camille Appert (bibinou) wrote :

Reopening

Changed in compiz:
status: Invalid → New
Vladimer Sichinava (alinux) wrote :

Today

Marcel (marcel-vd-berg) wrote :

Confirmed on 8.10 alpha6 64bit.

Today the boot process stalled just before the login and i had to use "Last successful boot" option.
While examining the system log viewer, compiz.real crashed.

Bernhard (b.a.koenig) wrote :

Can confirm this and I think it's more than "Medium". I know it's still in alpha but compiz is constantly crashing so I cannot use awn-dock nor emerald because they require compositing.

Changed in compiz:
status: New → Confirmed
Richard Ayotte (rich-ayotte) wrote :

Confirmed on 8.10 beta 64bit

Bernhard (b.a.koenig) wrote :

I would like to add the following to this compiz crash:

I think it happens mostly right after login: compiz crashes and the system switches to metacity. But I can do "compiz --replace" and compiz will run stable for quite a while. So what I'm saying is that there is something funny happening right after login.

I'm running on Compiz without any troubles since quite a long time. The bug has been solved for me about 3 weeks ago I think... may be more. Intrepid AMD64, up-to-date, nvidia 177.

Greetings, Felipe.

Marcel (marcel-vd-berg) wrote :

Like Felipe, I did not encounter the crash anymore.

Bernhard (b.a.koenig) wrote :

There's still lots of duplicates, but I have to admit that compiz is more stable after the most recent updates. Fingers crossed....

jhaiduce (jhaiduce) wrote :

I'm one of those duplicates. I experienced a crash shortly after selecting a new icon theme (the particular theme was missing some key icons, perhaps related to the cause of my crash). I did not experience a crash on login.

Kai Arne (kaiarne5) wrote :

It happened to me too right after reboot

thyams (t-hyams) wrote :

I am a linux newbie but I will try and determine changes in my setup that caused it after a fresh install of 8.10 (Beta):

Installed Proprietary Drivers 177 for Nvidia. Everything worked great.
Other Software Installed was all updates (all updates were installed from the last 18 hours.)
Frostwire
ia32-java5.0-bin
ia32-java6-bin

Compiz.real crashed with signal 7 on reboot, adjusted my xserver settings with nvidia, rebooted, same crash, changed drivers for nvidia to the 173 ones. Still getting the crash.

My gnome settings are on NewHuman and Appearance/Visual Effects changed from Normal to High.
The reason I increased the settings was due to people talking about the unstability from the 2d Driver from nvidia. I figured if the GPU is using more Core processor, I would get rid of the slugish performance that comes out afterwords.

After running top command after last reboot, any program loading, any program moving, any typing raises Xorg command from 20% cpu load to 101%. This is bad, even typing now appears to fill the memory buffer after three words. (The CPU in my system is Intel Core 2 Duo (2.00GHz per core.) It shouldn't be that high.

I do know, that with just the drivers installed with the basic updates installed, I did not have this problem. Although there were some updates installed late last night about 10 PM EST.

Kevin (kevinshlee) wrote :

I upgraded from 8.04 to 8.10 beta and now have this problem.

Olivier Cortès (olive) wrote :

Hi,

confirmed on latest Intrepid, AMD64 and Intel GMA X4500MHD (full HW info @ http://deep-ocean.net/files/sony/ ). This crash happens at EVERY login.
  * I run XFCE
  * with xfwm4 package uninstalled
  * and a symlink from /usr/bin/compiz to /usr/bin/xfwm
At login, session starts normally, then compiz crashes. If I open a terminal and type "compiz --replace", compiz is stable until next reboot : If I just logout then login, compiz works flawlessly.
It could be because I've got an xrandr call in my session scripts, because of bug https://bugs.launchpad.net/ubuntu/+source/xbacklight/+bug/176888

→ when my session is GNOME, compiz works flawlessly and never crashes. It's been crashing at login 100% of the time only since I use Xfce, but I can't seem to find the reason of the crash.

Olivier Cortès (olive) wrote :

Sorry, I think I screwed up myself when posting my last comment. It should have go to bug #191365, and i've put it there. BTW, these bugs look like duplicates for me.

Sef (jo-ker) wrote :

Still exists in AMD 64-bit beta.

kni (kni) wrote :

Confirm it on fresh install of x86_64 Ubuntu 8.10 beta (daily build CD from 18.10.2008)

Bernhard (b.a.koenig) wrote :

I think the current version in the repos is more stable. These reports will probably get less if you update the Live CD download version on ubuntu.com.

Charles Tryon (charles-tryon) wrote :

I am actually running the Beta 8.10 release. (AMD64 on a Core2 Duo.) I JUST pulled down an update of a major number of packages, and after the reboot, I got this error. I have NOT seen any Compiz crashes before this latest update, but then I've only been running this release for a couple of days. I do get warnings that the "welcome sound crashed unexpectedly", though funny enough, that did not happen this time.

Charles Tryon (charles-tryon) wrote :

OK, the crash is not consistent. I rebooted again, and everything (including the welcome sound) seemed to come up cleanly. Go figure....

(I am also running the proprietary ATI drivers loaded through the normal means.)

ludefork (ludefork) wrote :

Crash reported after updating Intrepid Beta, re-booting and opening an Opera browser. But computer still works fine. Using 64 bit machine.

Samuel Buffet (samuel-buffet) wrote :

Same Here 64b c2d on an updated Itrepid beta

dreamsayer (dreamsayer) wrote :

Crash reported after updating Intrepid Beta, re-booting and opening a Firefox browser. Computer still works fine. Using 64 bit machine.

gnuckx (gnuckx) wrote :

compiz.real crashed with signal 7

Just updated to kernel 2.26.27-7

Sebastian (seb19) wrote :

compiz.real crashed with signal 7 after Reboot.

same crash here using Jaunty fully updated

max (mikhmv) wrote :

I can confirm this on ubuntu 9.04 Jaunty Alpha 3

Efraim Karsh (efraimkarsh) wrote :

Samo samo on Intel Core Quad Q8200 with Jaunty Alpha 3.
Seems related to opening opera or firefox, but I'm not sure.

Efraim Karsh (efraimkarsh) wrote :

Crashed again, and during boot (after yesterday updates), without opening opera and/or firefox.
This time had to kill compiz from a tty in order to be able to finish the graphical boot.
Very annoying.
Cold it be related to the nvidia settings?
I'm using a 173 driver (and not 180), on a GEforce 9500GS.
Should I try to change to 180?

> Crashed again, and during boot (after yesterday updates), without opening opera and/or firefox.
> This time had to kill compiz from a tty in order to be able to finish the graphical boot.
> Very annoying.

I can confirm this since yesterday, too. Starting first time this
morning, I had to do the same tty stuff.

> Cold it be related to the nvidia settings?
> I'm using a 173 driver (and not 180), on a GEforce 9500GS.

I am using the 180.x driver, so my guess: It has nothing to do with 173.x

Martin Olsson (mnemo) wrote :

I just got signal 7 in compiz.real as well (x64 box with intel G45 and intel HDA sound with ALC889A codec). Using jaunty with latest updates as of today.

My apport logs etc is available in this bug (which I assume which get marked a duplicate once the apport retracer does its thing):
https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/327283

Martin Olsson (mnemo) wrote :

Happened again just now, seems like it crashes once per 3-4 reboots or so.

PsYcHoK9 (psychok9) wrote :

Crash at boot.

aus (aus.) wrote :

This happens to me as well with the latest jaunty version.
Compiz version 1:0.7.9+git20090211-0ubuntu5 on x64 with the intel G33 chipset (and intel driver).

electhor (electhor) wrote :

This crash has occurred on jaunty alpha 5 - I knew about it as a result of the the crash report icon appearing in upper panel.
Please ask if you need any more information.

Andy Duffell (andy-duffell) wrote :

Also still present in Jaunty Alpha 6

tags: added: compiz-crash
Mike.lifeguard (mikelifeguard) wrote :

This crashes me out immediately upon login 100% of time time on up-to-date 8.10.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers