kde-window-decorator crashes when turning on/off KDE's "GUI Effects" setting

Bug #205233 reported by SteBo on 2008-03-22
This bug report is a duplicate of:  Bug #129801: kde-window-decorator crashes in gutsy. Edit Remove
14
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Low
Basilio Kublik

Bug Description

Binary package hint: compiz-kde

Using Hardy upgraded today.

The kde-window-decorator crashes for me 100% reproducible when doing the following steps:

1. In a KDE session with compiz enabled, start kcmshell style
2. Go to the "Effects" tab.
3. Enable or disable "Enable GUI effects" or e.g. "Menu drop shadow"
4. Click "Apply"

Backtrace:
[KCrash handler]
#6 0x08059abe in ?? ()
#7 0x0805be98 in ?? ()
#8 0xb7efee72 in KDecoration::setMask () from /usr/lib/libkdecorations.so.1
#9 0xb6b705f9 in CrystalClient::updateMask ()
   from /usr/lib/kde3/kwin3_crystal.so
#10 0xb6b76544 in CrystalClient::init () from /usr/lib/kde3/kwin3_crystal.so
#11 0x0805b951 in ?? ()
#12 0x0805549f in ?? ()
#13 0x080520e1 in ?? ()
#14 0xb772173c in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#15 0xb7722221 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#16 0xb7d8b0ec in KApplication::appearanceChanged ()
   from /usr/lib/libkdecore.so.4
#17 0xb7dffd9b in KApplication::kdisplaySetPalette ()
   from /usr/lib/libkdecore.so.4
#18 0xb7e5fad4 in KApplication::applyGUIStyle () from /usr/lib/libkdecore.so.4
#19 0xb7e5fbeb in KApplication::kdisplaySetStyle ()
   from /usr/lib/libkdecore.so.4
#20 0xb7e73d2f in KApplication::x11EventFilter ()
   from /usr/lib/libkdecore.so.4
#21 0x080561e2 in ?? ()
#22 0xb7632480 in ?? () from /usr/lib/libqt-mt.so.3
#23 0x0806d0f8 in ?? ()
#24 0xbfefb8f8 in ?? ()
#25 0x00000000 in ?? ()

This is on a Dell XPS M1330 Notebook with the following graphics hardware:

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c) (prog-if 00 [VGA controller])
        Subsystem: Dell Unknown device 0209
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at fea00000 (64-bit, non-prefetchable) [size=1M]
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at eff8 [size=8]
        Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
        Capabilities: [d0] Power Management version 3

00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
        Subsystem: Dell Unknown device 0209
        Flags: bus master, fast devsel, latency 0
        Memory at feb00000 (64-bit, non-prefetchable) [size=1M]
        Capabilities: [d0] Power Management version 3

My xorg.conf:

Section "Files"
EndSection

Section "InputDevice"
 Identifier "Generic Keyboard"
 Driver "kbd"
 Option "CoreKeyboard"
 Option "XkbRules" "xorg"
 Option "XkbModel" "pc105"
 Option "XkbLayout" "de"
EndSection

Section "InputDevice"
 Identifier "Configured Mouse"
 Driver "mouse"
 Option "CorePointer"
 Option "Device" "/dev/input/mice"
 Option "Protocol" "ImPS/2"
 Option "ZAxisMapping" "4 5"
 Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
 Identifier "Synaptics Touchpad"
 Driver "synaptics"
 Option "SendCoreEvents" "true"
 Option "Device" "/dev/psaux"
 Option "Protocol" "auto-dev"
 Option "HorizEdgeScroll" "0"
EndSection

Section "InputDevice"
 Driver "wacom"
 Identifier "stylus"
 Option "Device" "/dev/input/wacom"
 Option "Type" "stylus"
 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
 Driver "wacom"
 Identifier "eraser"
 Option "Device" "/dev/input/wacom"
 Option "Type" "eraser"
 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
 Driver "wacom"
 Identifier "cursor"
 Option "Device" "/dev/input/wacom"
 Option "Type" "cursor"
 Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
 Identifier "Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller"
 Driver "intel"
 BusID "PCI:0:2:0"
EndSection

Section "Monitor"
 Identifier "Generic Monitor"
 Option "DPMS"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Device "Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller"
 Monitor "Generic Monitor"
 DefaultDepth 24
 SubSection "Display"
  Modes "1280x800"
 EndSubSection
EndSection

Section "ServerLayout"
 Identifier "Default Layout"
 Screen "Default Screen"
 InputDevice "Generic Keyboard"
 InputDevice "Configured Mouse"

# Uncomment if you have a wacom tablet
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
 InputDevice "Synaptics Touchpad"
EndSection

Basilio Kublik (sourcercito) wrote :

Hi Stefan
do you still experience this issue with the latest updates in Hardy Heron and/or using a new user account?

Thanks in advance

Changed in compiz:
assignee: nobody → sourcercito
importance: Undecided → Low
status: New → Incomplete
SteBo (stebo) wrote :

Yes, this bug still happens with the current Hardy Heron (just updated) with my old user account and with an user account added with adduser after applying today's updates.

Paulus (donmatteo) wrote :

I can confirm this bug. kde-window-decorator crashes as described, on my box, and also when doing lots of assorted compiz-related things, like changing various "desktop effects" settings in ccsm.

This is on RC, or on a up-to-date system. I think importance "low" is considerably too low, as it makes kde+compiz a pain to use. Please try to fix before the release!

Paulus (donmatteo) wrote :

I should add that I'm using the nvidia closed drivers, so it's probably not intel-related.

karthik (ponkarthik) wrote :

It happens for me as well. I am using latest ATI catalyst driver 8.4 downloaded from ATI website

SteBo (stebo) on 2008-04-28
Changed in compiz:
status: Incomplete → Confirmed
przemkus (przemkus) wrote :

I have Kubuntu Hardy and Nvidia card (nvidia-glx-new)
Compiz crashes not only when I enable/disable GUI Efects, but any change in Style properties/settings and pressing Apply make compiz crash also.
Every change in general settings in compizconfig-settings-manager also crashes window decorations.
I noticed that compiz in Hardy is very unstable, window decorations disappear very often, without reason.
Before I installed Hardy, I tried to install desktop-effects-kde package on Gutsy and it worked well. I didn't notice on Gutsy any of those problems.
Defnitely the importance of this bug is not "Low".

Travis Watkins (amaranth) wrote :

It is marked as low as I only care for GNOME problems (I don't have time for KDE problems) and it keeps it off my radar. If upstream fixes it then awesome but don't expect me to spend any time on it.

markb (mark-blakeney) wrote :

I'm on a new hardy kubuntu install with a 8600GT card and using nvidia-glx-new. kde-window-decorator crashes very frequently for me when changing various settings in ccsm. As a new user experimenting with compiz, this means it crashes many times a day (since there seems no other way to understand compiz settings other to stuff around for hours!). So this is my number one annoying bug.

The comment from Travis Watkins above is disheartening. So kubuntu really is a poor cousin? Didn't Mr. Shuttleworth say this http://www.kubuntu.org/announcements/kde-commitment.php ?

Travis Watkins (amaranth) wrote :

I'm a community developer.

PandaMine (pandamine) wrote :

I can also confirm the same thing, any changes made in KDE window decorator (kwin) crashes compiz, forcing you to restart it again with the compiz command. Is compiz at least looking into the issue, since it's an issue with the compiz window manager?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers