Panels are visible in fullscreen mode

Bug #199503 reported by Christoph Langner on 2008-03-07
2
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Low
Basilio Kublik

Bug Description

Binary package hint: totem

I'm running a up to date hardy here with totem-gstreamer. I own a Nvidia GeForce 7600 GS and two monitors which works good with twinview. The problem with totem is that the gnome panels come into the foreground as soone as I open a movie and view it in fullscreen while working on my other screen.

1) Open a movie and maximize it to fullscreen on one monitor.
-> Monitor1: My applications, Monitor2: Movie in fullscreen with menu bars or panels
-> totem_1.png

2) Move the mouse
-> Monitor1: My applications, Monitor2: Movie in fullscreen with Totem GUI
-> totem_2.png

3) Click somewhere inside an application on Monitor1
-> Monitor1: My applications, Monitor2: Movie in fullscreen with GNOME panels in the foreground
-> totem_3.png

The panels shouldn't be visible

$ lspci | grep VGA
07:00.0 VGA compatible controller: nVidia Corporation G70 [GeForce 7600 GS] (rev a1)

$ dpkg -l totem*
ii totem 2.21.95-0ubuntu1 A simple media player for the Gnome desktop (dummy packa
ii totem-common 2.21.95-0ubuntu1 Data files for the Totem media player
ii totem-gstreamer 2.21.95-0ubuntu1 A simple media player for the Gnome desktop based on gst
un totem-gstreamer-fire <keine> (keine Beschreibung vorhanden)
ii totem-mozilla 2.21.95-0ubuntu1 Totem Mozilla plugin
ii totem-plugins 2.21.95-0ubuntu1 Plugins for the Totem media player
un totem-xine <keine> (keine Beschreibung vorhanden)
un totem-xine-firefox-p <keine> (keine Beschreibung vorhanden)

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"

ProblemType: Bug
Architecture: amd64
Date: Fri Mar 7 16:19:37 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/totem-gstreamer
NonfreeKernelModules: nvidia
Package: totem-gstreamer 2.21.95-0ubuntu1
PackageArchitecture: amd64
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: totem
Uname: Linux 2.6.24-11-generic x86_64

Christoph Langner (chrissss) wrote :
Christoph Langner (chrissss) wrote :
Christoph Langner (chrissss) wrote :
Christoph Langner (chrissss) wrote :
Pedro Villavicencio (pedro) wrote :

to be confirmed by someone with a similar setup, thanks for your report.

Changed in totem:
importance: Undecided → Low
Christoph Langner (chrissss) wrote :

The last updates fixed this bug.

Changed in totem:
status: New → Fix Released
Christoph Langner (chrissss) wrote :

I figured out that this problem is related to compiz. When i use metacity as windows manager totem behaves correct. But with desktop effects enables the panels are in the foreground, when totem is inside fullscreen mode.

Changed in totem:
status: Fix Released → New
Basilio Kublik (sourcercito) wrote :

Hi Christoph
is this fixed or the problem re-apears, i'm asking because of your last comment give me some doubts.

Thanks in advance

Changed in compiz:
assignee: nobody → sourcercito
status: New → Incomplete
Christoph Langner (chrissss) wrote :

The problem is still there.

Dualscreen + Compiz + applications in fullscreen screen like totem or tvtime => Panel stays ontop

Changed in compiz:
status: Incomplete → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers