[radeon] Blinking screen

Bug #1961561 reported by Dash
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Incomplete
Undecided
Unassigned
mesa (Ubuntu)
Incomplete
Undecided
Unassigned

Bug Description

Binking screen with radeon after upgrade 18.04 to 20.04 - Console OK

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: xorg 1:7.7+19ubuntu14
ProcVersionSignature: Ubuntu 5.13.0-30.33~20.04.1-generic 5.13.19
Uname: Linux 5.13.0-30-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.21
Architecture: amd64
CasperMD5CheckResult: skip
Date: Mon Feb 21 10:13:34 2022
DistUpgraded: 2021-03-08 13:38:14,332 DEBUG package 'libcpanel-json-xs-perl' produces an unwanted removal 'gnome-software-plugin-snap', skipping
DistroCodename: focal
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard:
 Advanced Micro Devices, Inc. [AMD/ATI] RS482/RS485 [Radeon Xpress 1100/1150] [1002:5974] (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company DC5750 Microtower [103c:280a]
   Subsystem: Hewlett-Packard Company RS480 [Radeon Xpress 1150] (Secondary) [103c:280b]
InstallationDate: Installed on 2015-11-26 (2278 days ago)
InstallationMedia: Ubuntu 14.04.3 LTS "Trusty Tahr" - Beta amd64 (20150805)
MachineType: Hewlett-Packard HP Compaq dc5750 Small Form Factor
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.13.0-30-generic root=UUID=681c938b-c95d-48de-886f-bc784bb57787 ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
Title: Xorg freeze
UpgradeStatus: Upgraded to focal on 2021-03-08 (349 days ago)
dmi.bios.date: 01/25/2007
dmi.bios.release: 2.10
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 786E3 v02.10
dmi.board.name: 0A64h
dmi.board.vendor: Hewlett-Packard
dmi.chassis.asset.tag: CZC8061JND
dmi.chassis.type: 4
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr786E3v02.10:bd01/25/2007:br2.10:svnHewlett-Packard:pnHPCompaqdc5750SmallFormFactor:pvr:rvnHewlett-Packard:rn0A64h:rvr:cvnHewlett-Packard:ct4:cvr:skuEW318AV:
dmi.product.family: 103C_53307F
dmi.product.name: HP Compaq dc5750 Small Form Factor
dmi.product.sku: EW318AV
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.14.1+20.04.20200211-0ubuntu1
version.libdrm2: libdrm2 2.4.107-8ubuntu1~20.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 21.2.6-0ubuntu0.1~20.04.1
version.libgl1-mesa-glx: libgl1-mesa-glx 21.2.6-0ubuntu0.1~20.04.1
version.xserver-xorg-core: xserver-xorg-core 2:1.20.13-1ubuntu1~20.04.2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.6-1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20200226-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1
xserver.bootTime: Mon Feb 21 10:00:44 2022
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.20.13-1ubuntu1~20.04.2
xserver.video_driver: radeon

Revision history for this message
Dash (devel-tootai) wrote :
description: updated
Revision history for this message
Daniel van Vugt (vanvugt) wrote (last edit ):

Thanks for the bug report. It appears the blinking is compiz repeatedly crashing in the Mesa radeon driver:

[ 2322.696000] compiz[18685]: segfault at 39 ip 00007f6398e0511b sp 00007ffcfb66d320 error 4 in r300_dri.so[7f639879d000+10ab000]
[ 2322.696026] Code: b6 40 2d eb ef 66 2e 0f 1f 84 00 00 00 00 00 f3 0f 1e fa 31 f6 e9 95 a2 f9 ff 0f 1f 44 00 00 41 54 48 8d 15 97 b8 b2 00 55 53 <0f> b6 47 39 48 89 f3 48 63 04 82 48 01 d0 3e ff e0 0f 1f 40 00 bd
[ 2325.310971] compiz[18793]: segfault at 39 ip 00007f413ac7311b sp 00007fffd7f9e870 error 4 in r300_dri.so[7f413a60b000+10ab000]
[ 2325.310997] Code: b6 40 2d eb ef 66 2e 0f 1f 84 00 00 00 00 00 f3 0f 1e fa 31 f6 e9 95 a2 f9 ff 0f 1f 44 00 00 41 54 48 8d 15 97 b8 b2 00 55 53 <0f> b6 47 39 48 89 f3 48 63 04 82 48 01 d0 3e ff e0 0f 1f 40 00 bd
[ 2327.567322] compiz[18833]: segfault at 39 ip 00007f969a22311b sp 00007fff2653c300 error 4 in r300_dri.so[7f9699bbb000+10ab000]
[ 2327.567347] Code: b6 40 2d eb ef 66 2e 0f 1f 84 00 00 00 00 00 f3 0f 1e fa 31 f6 e9 95 a2 f9 ff 0f 1f 44 00 00 41 54 48 8d 15 97 b8 b2 00 55 53 <0f> b6 47 39 48 89 f3 48 63 04 82 48 01 d0 3e ff e0 0f 1f 40 00 bd

Please try using GNOME instead.

tags: added: radeon
summary: - Xorg freeze
+ [radeon] Blinking screen
affects: xorg (Ubuntu) → compiz (Ubuntu)
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It sounds like some part of the system has crashed. To help us find the cause of the crash please follow these steps:

1. Look in /var/crash for crash files and if found run:
    ubuntu-bug YOURFILE.crash
Then tell us the ID of the newly-created bug.

2. If step 1 failed then look at https://errors.ubuntu.com/user/ID where ID is the content of file /var/lib/whoopsie/whoopsie-id on the machine. Do you find any links to recent problems on that page? If so then please send the links to us.

3. If step 2 also failed then apply the workaround from bug 994921, reboot, reproduce the crash, and retry step 1.

Please take care to avoid attaching .crash files to bugs as we are unable to process them as file attachments. It would also be a security risk for yourself.

Changed in compiz (Ubuntu):
status: New → Incomplete
Changed in mesa (Ubuntu):
status: New → Incomplete
Revision history for this message
Dash (devel-tootai) wrote :

I uninstalled compiz and installed mate-desktop. I use lightdm. Still unable to get connect, login window being OK. I send the crash file with ubuntu-bug _usr_bin_mate-session.1000.crash from /var/crash, problem is I never the new bug number :(

Revision history for this message
Dash (devel-tootai) wrote :

Send the crash file as attachment

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Please report crash files using the 'ubuntu-bug' or 'apport-cli' commands. We can't handle them here.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Also the crash in comment #5 is different to the original problem here. Please follow all the steps in comment #3.

Revision history for this message
Dash (devel-tootai) wrote :

As told, the file was send from the computer but it doesn't show any new bug-number, crash file should be somewhere in the bug queue. I send it twice. Will restart the procedure.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

That's just step 1, so try step 2.

Revision history for this message
Dash (devel-tootai) wrote :

How can I connect to https://errors.ubuntu.com/user/ID if I have no access to the web browser *FROM* the machine ? I only have console which is usable.

Revision history for this message
Dash (devel-tootai) wrote :
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Thanks. The only crash report from your machine that looks like this bug is now in bug 1961857. But that is so rare it's only ever been reported twice.

Most likely it will be resolved (or already has been) in a newer version of Mesa.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers