Tibia behaves strange with "Window Decoration" plugin in Compiz

Bug #189746 reported by Fred on 2008-02-06
8
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Low
Basilio Kublik

Bug Description

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"

compiz 1:0.6.99+git20080204-0ubuntu1

The MMORPG game Tibia 8.1 (http://www.tibia.com/ - http://download.tibia.com/tibia810.tgz) does;
* Work perfect without Compiz in fullscreen mode.
* Work perfect without Compiz in windowed mode.
* Work perfect with Compiz in fullscreen mode.
* Work strange with Compiz in windowed mode.

I have noticed the problem seems to be the "Window Decoration" plugin in Compiz. Since when I disable it in "CompizConfig Settings Manager" and restart Tibia, it works perfect in windowed mode too. But if I have "Window Decoration" plugin enabled and run Tibia, then it behaves strange.

The strange behavior in the game (when "Window Decoration" plugin is enabled, and game is running in windowed-mode) is that;
* You cannot open containers on the ground (such as bags, backpacks, etc) by right-clicking on the item and selecting "Open" in the context menu.
* You cannot follow players by right-clicking on them in the battle menu and selecting "Follow" in the context menu.

This seems to some kind incompatibility issue or bug in the "Window Decoration" plugin for Compiz. Maybe the game is too strange.

Fred (eldmannen+launchpad) wrote :

I also get this problem with Ubuntu 7.10 "Gutsy Gibbon" and the Compiz that ships with it, and earlier versions of Tibia such as 8.0
So it is not only a problem of 8.04 Alpha4 "Hardy Heron", or the latest version of Compiz or the latest version of Tibia.

SK (stephantom) wrote :

Thank you for taking the time to report this issue and helping to improve Ubuntu!
This report was not reported against a specific package. I have assigned the compiz package now as Tibia is not packaged for Ubuntu. Please try to file future bug reports against the right packages. You can learn to find the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage
Feel free to report any other issues you might find!

Basilio Kublik (sourcercito) wrote :

Hi there
you report this issue some time ago and hasn't been any activity since then, i was wondering if this is still an issue for you with the latest upgrades in Hardy Heron.

Thanks in advance

Changed in compiz:
assignee: nobody → sourcercito
importance: Undecided → Low
status: New → Incomplete
Fred (eldmannen+launchpad) wrote :

Basilio Kublik,
Yes, I do still have this issue.

As a workaround, I change the "Decoration windows" settings in "Window Decorator" plugin from "any" to "(any) & !(title=Tibia Player Linux)".
Then it works, but then I have to live without window decoration (application bar, title bar, close button, etc), which is less than optimal.

braweheart (braweheart) wrote :

I can confirm this bug, not personally but a user in the swedish ubuntu-forum had the same issue. After installing fusion-icon he turns off Compiz when playing Tibia and he says it works fine.

RickardJ (rickardj) wrote :

Confirmed, it seems that when selecting something from the game menu (that you get when right clicking), it just doesn't click the option.

As I experience it, when the menu pop-up and you click an option it clicks "under" the menu-pop-up instead. For example, making you walk to that spot in game.

When turning off "Window decoration", it works properly.

Ubuntu 8.10
Linux 2.6.27-11-generic

Tibia Client 8.41

RickardJ (rickardj) wrote :

This problem seem to have been corrected in Ubuntu 9.04. Atleast after a quick check it seem to work properly since I made the update.

Fred (eldmannen+launchpad) wrote :

RickardJ seems to be right.
I am now running 9.04 and I do not seem to experience this bug anymore.

Robert Ancell (robert-ancell) wrote :

This bug report is being closed due to your last comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status . Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in compiz (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers