Background window is focused to the front when closing or minimizing; should close/minimize without getting attention.

Bug #189329 reported by mannheim on 2008-02-05
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Wishlist
Basilio Kublik

Bug Description

Binary package hint: compiz

Compiz behaves slightly differently than metacity in the following situation:

1. Open a window (e.g. gnome-terminal).
2. Open a second window.
3. Make sure the second window has focus and that the close-button of the first window is visible.
4. Click on the close button on the title bar of the first (un-focused) window.

Actual results: The un-focused window comes into focus in response to the click before closing. Example: https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/189329/+attachment/2136516/+files/screencast1.ogv

Expected results: The un-focused window quietly closes, remaining behind the second, focused window. Example: https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/189329/+attachment/2136517/+files/foo2.ogv

The latter behavior is what metacity does, and it looks much cleaner. The same thing happens with the minimize button. I imagine there may be difficulties making compiz behave this way if wants to use animations for "close" and "minimize": one would want the animations to occur behind the focused window.

I am using Ubuntu 7.10 with a pretty-much default (?) installation of compiz and compiz-fusion-plugins.

Changed in compiz:
importance: Undecided → Wishlist
Basilio Kublik (sourcercito) wrote :

Hi there
you report this issue some time ago and hasn't been any activity since then, i was wondering if this is still an issue for you with the latest upgrades in Hardy Heron.

Thanks in advance

Changed in compiz:
assignee: nobody → sourcercito
status: New → Incomplete
mannheim (kronheim) wrote :

The behavior reported in the bug is still there. I think compiz may be a little faster now (on my machine), so that the back-and-forth switch of focus is less noticeable; but it still happens every time, as far as I can see.

As I said in the first report, the difficulty with "fixing" this bug is the question of the compiz animations: if there is an elaborate animation for the minimize effect, one would want that animation to occur for the window being minimized, *behind* the frontmost window (which remains focused). I know nothing about it, but I imagine this might be difficult.

Michele Mangili (mangilimic) wrote :

Hi mannheim!

I'm running Ubuntu 8.10 with compiz 1:0.7.8-0ubuntu4.1 but I cannot reproduce this bug. It works exactly like you expected:
a window being minimized is not focused while the frontmost window remains focused!

For this reason I'm closing this bug report! You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status . Thank you again for taking the time to report this bug and helping to make Ubuntu better. Feel free to submit any future bugs you may find.

Changed in compiz:
status: Incomplete → Invalid
Carl Simpson (cwd-simpson) wrote :

I was just about to report this very issue for Ubuntu 9.10, and have to chip in that the above is patently incorrect with compiz 1:0.8.4-0ubuntu2.1.

A minimised or closed window pulls focus in order to minimise or close, and only when this is done does the window behind regain focus. The behaviour is rather weird and jarring.

mannheim (kronheim) wrote :

The bug really does exist, at least in 10.04. The screencast shows what is happening. The animation for "focus" in the compiz animation plugin is set to "Dodge" to make the behavior more apparent. When the rear window is closed using its close button, the front window "Dodges" and the back window gets focus before closing.

mannheim (kronheim) wrote :

By contrast, this second screencast shows how it really should behave. This is the good behavior which you get when you close the rear window using the contextual menu in the task bar. The rear window is not give focus. Instead it quietly disappears, using the correct "close" animation, while remaining behind the front window.

Changed in compiz (Ubuntu):
status: Invalid → New
Changed in compiz (Ubuntu):
status: New → Confirmed
summary: - Undesirable focus while closing or minimizing
+ Background window is focused to the front when closing or minimizing;
+ should close/minimize without getting attention.
description: updated
Changed in compiz (Ubuntu):
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers