Reducing number of workspaces leaves windows inaccessible

Bug #189259 reported by Ioannis Ramfos on 2008-02-05
6
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-panel

When having a window placed on workspace X and reduce the number of workspaces (from the preferences of workspace switcher), the window becomes inaccessible, when using compiz (it remains on the same --inaccessible-- workspace). To access the window, one must increase the number of workspaces again to show it.

When not using compiz, the above procedure makes the window move to one of the available workspaces, which I think is the correct behaviour.

Happens with gutsy and hardy-alpha4.

ProblemType: Bug
Architecture: i386
Date: Tue Feb 5 16:36:36 2008
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/gnome-panel
NonfreeKernelModules: vmnet vmmon
Package: gnome-panel 1:2.20.1-0ubuntu1
PackageArchitecture: i386
ProcCmdline: gnome-panel --sm-client-id default1
ProcCwd: /home/isr
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-panel
Uname: Linux stella-desktop 2.6.22-14-generic #1 SMP Tue Dec 18 08:02:57 UTC 2007 i686 GNU/Linux

Ioannis Ramfos (isr81) wrote :
Brian Murray (brian-murray) wrote :

When trying to recreate this bug report I found that after I reduced the number of workspaces the application seemed to disappear but I was able to get it back without increasing the number of workspaces. Steps to recreate follow:

1) increase number of workspaces to 3 rows and 1 column from 2 rows and 1 column
2) launch application on workspace 3
3) move to workspace 1
4) reduce workspaces to 2 rows and 1 column
5) switch to workspace 2 via ctrl+alt+right
6) notice application from closed workspace 3 show up when switching
7) switch back to workspace 1 and see "missing" application there

I was using Hardy Heron with compiz version 1:0.7.0-0ubuntu1 and 2.21.91-0ubuntu1.

Changed in compiz:
importance: Undecided → Low
status: New → Confirmed
Bill Gjestvang (bgjestvang) wrote :

This still exists in Jaunty rc1. I am unable to repeat the workaround that Brian Murray used. When I have one column and multiple rows, ctrl-alt-right does nothing. Even if I‌ use ctrl-alt-down, or multiple columns and one row with ctrl-alt-right, I never see the missing application show up.

Bill Gjestvang (bgjestvang) wrote :

OK, I can't reproduce Brian's method until right after I post a comment saying I can't. OK, yeah, switch to a different workspace and then back to 1, and the missing app is on 1. I don't "notice application from closed workspace 3 show up when switching", though. But it's there when I switch back.

summary: - Changing number of workspaces using compiz can make windows inaccessible
+ Reducing number of workspaces leaves windows unaccessible
Changed in compiz (Ubuntu):
status: Confirmed → Triaged
summary: - Reducing number of workspaces leaves windows unaccessible
+ Reducing number of workspaces leaves windows inaccessible
Erkin Bahceci (cornelius1) wrote :
Changed in compiz (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.8.3+git20091005-0ubuntu5

---------------
compiz (1:0.8.3+git20091005-0ubuntu5) karmic; urgency=low

  * New snapshot from upstream stable git:
     - compiz.real crashed with SIGSEGV in blurDrawWindow()
       (LP: #353236)
     - Windows disappear if resolution is changed to something smaller
       than window size (LP: #414134)
     - compiz.real crashed with SIGSEGV in handleEvent() (LP: #430518)
     - Windows that span screen width or height cannot be resized
       in that dimension (LP: #137134)
     - Reducing number of workspaces leaves windows inaccessible
       (LP: #189259)
     - "Snap Inverted" in Wobbly Windows compiz plugin broken
       (LP: #366822)
     - Problem when resizing and the Panels
       (LP: #408030)
  * debian/control:
    - make compiz package depend on compiz-gnome | compiz-kde (LP: #172385)
  * debian/patches/015_draw_dock_shadows_on_desktop.patch:
    - fix clock/calendar shadow not going away (LP: #428783)
      thanks to Erkin Bahceci
  * debian/patches/029_default_options:
    - add a focus prevention match to allow polkit windows to steal focus
      otherwise they never get focus (LP: #436852)
  * debian/compiz-gnome.gconf-defaults:
    - change /apps/gwd/blur_type to all since it only does anything if blur
      is enabled and is usually what is wanted (LP: #158376)
    - turn constrain_y back on (LP: #82654)
  * debian/rules:
    - add commands plugin to default active_plugins (LP: #355018)

 -- Travis Watkins <email address hidden> Mon, 05 Oct 2009 15:42:00 +0200

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers