Compiz do not render window borders / decorations on Ubuntu MATE 20.04 LTS

Bug #1864218 reported by Norbert
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Invalid
Low
Unassigned
ubuntu-mate-settings (Ubuntu)
Fix Released
Low
Martin Wimpress 

Bug Description

Steps to reproduce:

1. Install Ubuntu MATE 20.04 LTS
2. Install Compiz with `sudo apt install compiz compiz-core compiz-mate compiz-plugins compiz-plugins-default`
3. Reboot
4. Login and select Compiz window manager in the MATE Tweak

Expected results:

* Compiz is selected, windows have borders / decorations

Actual results:

* Compiz is selected, windows do not have borders / decorations.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: compiz-mate 1:0.9.14.1+20.04.20200211-0ubuntu1
ProcVersionSignature: Ubuntu 5.4.0-14.17-generic 5.4.18
Uname: Linux 5.4.0-14-generic x86_64
ApportVersion: 2.20.11-0ubuntu16
Architecture: amd64
CompositorRunning: None
Date: Fri Feb 21 20:04:06 2020
DistUpgraded: Fresh install
DistroCodename: focal
DistroVariant: ubuntu
DkmsStatus: virtualbox-guest, 6.1.2, 5.4.0-14-generic, x86_64: installed (WARNING! Diff between built and installed module!) (WARNING! Diff between built and installed module!)
GraphicsCard: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter [80ee:beef] (prog-if 00 [VGA controller])
GsettingsChanges:

InstallationDate: Installed on 2020-02-19 (1 days ago)
InstallationMedia: Ubuntu-MATE 20.04 LTS "Focal Fossa" - Alpha amd64 (20200219)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 002: ID 80ee:0021 VirtualBox USB Tablet
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Lsusb-t:
 /: Bus 02.Port 1: Dev 1, Class=root_hub, Driver=ohci-pci/12p, 12M
     |__ Port 1: Dev 2, If 0, Class=Human Interface Device, Driver=usbhid, 12M
 /: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/12p, 480M
MachineType: innotek GmbH VirtualBox
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-14-generic root=UUID=24ce0d8d-7d83-4ed9-9350-c4b1fe36eaaf ro quiet splash
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.board.name: VirtualBox
dmi.board.vendor: Oracle Corporation
dmi.board.version: 1.2
dmi.chassis.type: 1
dmi.chassis.vendor: Oracle Corporation
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:rvnOracleCorporation:rnVirtualBox:rvr1.2:cvnOracleCorporation:ct1:cvr:
dmi.product.family: Virtual Machine
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH
version.compiz: compiz 1:0.9.14.1+20.04.20200211-0ubuntu1
version.libdrm2: libdrm2 2.4.100-4
version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.0-1ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.7-2ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20190815-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

Revision history for this message
Norbert (nrbrtx) wrote :
Revision history for this message
Norbert (nrbrtx) wrote :
Revision history for this message
Norbert (nrbrtx) wrote :

Also happens on real hardware with Intel GPU.

tags: added: compiz-0.9
Revision history for this message
Alberts Muktupāvels (muktupavels) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Revision history for this message
Norbert (nrbrtx) wrote :

Still a problem, tested 20200321 ISO.

Changed in compiz (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Martin Wimpress (flexiondotorg)
importance: Undecided → Low
no longer affects: ubuntu-mate
Changed in compiz (Ubuntu):
status: In Progress → Fix Committed
Changed in ubuntu-mate-settings (Ubuntu):
status: New → Fix Committed
importance: Undecided → Low
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in compiz (Ubuntu):
status: Fix Committed → Invalid
assignee: Martin Wimpress (flexiondotorg) → nobody
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-mate-settings - 20.04.3

---------------
ubuntu-mate-settings (20.04.3) focal; urgency=medium

  * Add Compiz configuration for MATE. (LP: #1864218)

 -- Martin Wimpress <email address hidden> Thu, 02 Apr 2020 22:46:21 +0100

Changed in ubuntu-mate-settings (Ubuntu):
status: Fix Committed → Fix Released
Norbert (nrbrtx)
tags: removed: focal
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers