Compiz-fusion makes the desktop freeze

Bug #186058 reported by Pyry on 2008-01-25
This bug report is a duplicate of:  Bug #176589: compiz randomly freezes X. Edit Remove
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: compiz

And after you read the topic, I immediatly want to acknowledge the fact that yes, I'm a dork for upgrading my system too early.... and now I'm paying the price.

[CODE]$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu hardy (development branch)
Release: 8.10
Codename: hardy[/CODE]

I installed compiz-fusion to my workstation and then started having weird freezes. Freeze usually happened when I was about to switch desktop, everythings just froze in place. If I had a movie or an song going, the sounds would still continue, but everything else where frozen.

Luckily, I am able to restart kdm by connection to my desktop by ssh.

So I started to search for solution:
[LIST=1]
[*]Switched from KDE to Gnome, no luck, still freezes from time to time
[*]Removed compiz-fusion from my desktop, no freezes on the workstation after that.
[*]Updated my laptop to Ubuntu hardy and installed compiz-fusion and the same freezeouts started also with the laptop
[*]Re-installed Ubuntu Gutsy to my laptop and compiz-fusion. This worked for my laptop as I have been using it for few weeks without any freezes
[/LIST]

From this I came to the following conclusions that Hardy's compiz must have some hard to find problems which cause random freezes. Needless to say (but lets say it anyway), that the problem is not related to xorg configuration or graphics drivers as the same freeze effects occured in two different machines (with completely different hw).

Any similar experiences? Any ideas how to get the beautiful compiz working on my desktop? (I miss my rotating cube) If not, then the question remains that is there any other way to downgrade to Gutsy without reinstalling the os? Or do I just have to wait until Hardy becomes stable and live with 2d desktop until then (whine)

Also, any advice on how to provide extra info with this bug report? Taking point of the fact that the desktop freezes completely but I'm still able to connect with ssh.

Pedro Villavicencio (pedro) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please add your ~/.xsession-errors, /var/log/Xorg.0.log and the output of lspci -vvnn to your bug report as separate attachments? Thanks in advance.

Changed in compiz:
importance: Undecided → Medium
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!.

Changed in compiz:
status: Incomplete → Invalid
MountainX (dave-mountain) wrote :

I have been experiencing the exact same things in Hardy beta with all updates applied.

MountainX (dave-mountain) wrote :

xsession errors

MountainX (dave-mountain) wrote :

lspci

MountainX (dave-mountain) wrote :

Xorg.0.log

MountainX (dave-mountain) wrote :

how do I reopen this bug report?

MountainX (dave-mountain) wrote :

btw, I am not the original reporter. My situation however, is the same.

Pyry (pyry) wrote :

Sorry for the lack of info but in my machine the bug dissapeared when the kernel was updated. I have not experienced the same bug since.

MountainX (dave-mountain) wrote :

my kernel info:
2.6.24-14-generic
i386 Hardy beta

Pyry - what is your kernel now?

MountainX (dave-mountain) wrote :

I have attached the missing info that the original reporter did not attach. With that I am reopening the bug. Hope that is OK.

Changed in compiz:
status: Invalid → New
MountainX (dave-mountain) wrote :

When compiz.real is the process consuming 99-100% CPU, how do we get a backtrace? I see some info on backtracing for Xorg here:
https://wiki.ubuntu.com/DebuggingXorg

If someone tells me how to do it in the context of this (compiz-related?) bug, I will do it. Thanks.

Travis Watkins (amaranth) wrote :

If you have shell access you need to first make sure the compiz debug packages are installed then find the process id for compiz.real. Then run 'gdb -p <pid>' and in gdb run 'where'. It'll show you what is currently being run but I am 99% positive it'll show it getting stuck somewhere in X or in libGL since you have nvidia graphics.

Erkin Bahceci (cornelius1) wrote :

If you want, I have a script to get a compiz backtrace:
http://erkinbah.googlepages.com/gdb-compiz-backtrace.sh

When you want to get a backtrace, you can run it as follows (after switching to a TTY terminal with Ctrl-Alt-F1, or connecting from another machine via ssh):
bash gdb-compiz-backtrace.sh

MountainX (dave-mountain) wrote :

Does the script still require that I install the compiz debug packages? I assume it does, but I want to be sure.

http://erkinbah.googlepages.com/gdb-compiz-backtrace.sh

Erkin Bahceci (cornelius1) wrote :

Yes, you still need the compiz debug packages.

Pedro Villavicencio (pedro) wrote :

marking this as incomplete until a backtrace gets submitted, thanks.

Changed in compiz:
status: New → Incomplete
MountainX (dave-mountain) wrote :

I am not sure which debugging packages to install. (I'm running Hardy.) Do I need xserver-xorg-core-dbg? And which package is "compiz debugging"? Is is compiz-dev? (Synaptic doesn't list anything with compiz and debug both in the name.) Thanks.

Erkin Bahceci (cornelius1) wrote :

First, have a look at this to add the hardy repository for debug packages:
https://wiki.ubuntu.com/DebuggingProgramCrash

After adding the repository, in synaptic hit "reload", and search for "compiz". When you see the results, for each already installed package there, install the corresponding -dbgsym package if there is one.

Then restart compiz before getting a backtrace.

pittipatti (pittipatti) wrote :

I have the same problem with an Intel GM965/GL960 graphics card (using xserver-xorg-video-intel) in my laptop.
Should I open a new bug-report because of the different hardware?

Additional info I can bring in at this time:
- even the keyboard is inresponsive, so switching to a terminal is impossible (while connecting via lan still is possible)
- while searching the logfiles I found the following line 23 times in "dmesg" in a time-range of one second and I'm definitively sure not pressing MagicSysReq-Key

  > SysRq : HELP : loglevel0-8 reBoot Crashdump tErm Full kIll saK showMem Nice powerOff showPc show-all-timers(Q) unRaw Sync showTasks Unmount shoW-blocked-tasks

but I can't tell for sure if it came up when freezing, or when killing compiz.real

next (freeze-) time I'll debug though.

Gustavo A. Díaz (gdiaz) wrote :

Hi guys...

I've installed Kubuntu hardy RC (and latest upgrades) and i have same issue but my desktop only freeze when i active (with extra effects) desktop cube. After that i have:

6051 root 20 0 91824 59m 5704 R 99.9 11.9 0:42.28 Xorg

I am attaching Xorg and XSession logs.

Cheers.

Gustavo A. Díaz (gdiaz) wrote :
mosix (alh-ono) wrote :
Download full text (42.3 KiB)

Hello
i upgraded last monday from ubuntu 7.10 to ubuntu 8.04.
with 7.10 compiz worked perfectly, now everytime i rotate cube freezes, keyboard doesn't respond, sometimes this arise with animations like burn when i close a window or with expo. now i have disabled compiz effects. i tried fixes shown in bug #177492 but they didn't work.
i will attach debugging files when i learn how to do it.

thank you!

Linux xxx 2.6.24-16-generic #1 SMP Thu Apr 10 13:23:42 UTC 2008 i686 GNU/Linux

~$ lsb_release -rd
Description: Ubuntu 8.04
Release: 8.04

~$ apt-cache policy compiz
compiz:
  Instalados: 1:0.7.4-0ubuntu6
  Candidato: 1:0.7.4-0ubuntu6
  Tabla de versión:
 *** 1:0.7.4-0ubuntu6 0
        500 http://ftp.dateleco.es hardy/main Packages
        100 /var/lib/dpkg/status

xorg.conf
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
 Identifier "Generic Keyboard"
 Driver "kbd"
 Option "XkbRules" "xorg"
 Option "XkbModel" "pc105"
 Option "XkbLayout" "es"
EndSection

Section "InputDevice"
 Identifier "Configured Mouse"
 Driver "mouse"
 Option "CorePointer"
 Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
 Identifier "Synaptics Touchpad"
 Driver "synaptics"
 Option "SendCoreEvents" "true"
 Option "Device" "/dev/psaux"
 Option "Protocol" "auto-dev"
 Option "HorizEdgeScroll" "0"
EndSection

Section "Device"
 Identifier "Configured Video Device"
EndSection

Section "Monitor"
 Identifier "Configured Monitor"
EndSection

Section "Screen"
 Identifier "Default Screen"
 Monitor "Configured Monitor"
 Device "Configured Video Device"
EndSection

Section "ServerLayout"
 Identifier "Default Layout"
 Screen "Default Screen"
 InputDevice "Synaptics Touchpad"
EndSection

xorg.0.log

This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.

X.Org X Server 1.4.0.90
Release Date: 5 September 2007
X Protocol Version 11, Revision 0
Build Operating System: Linux Ubuntu (xorg-server 2:1.4.1~git20080131-1ubuntu9)
Current Operating System: Linux moshiba 2.6.24-16-generic #1 SMP Thu Apr 10 13:23:42 UTC 2008 i686
Build Date: 15 April 2008 05:26:17PM

 Before reporting problems, check http://wiki.x.org
 to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (=...

mosix (alh-ono) wrote :
mosix (alh-ono) wrote :
mosix (alh-ono) wrote :

Hello

I've fixed compiz for HH on my laptop, i show how hoping it serves for someone.

1.- compiz worked fine on my laptop with ubuntu 7.10, it started to freeze when i upgrade to 8.04
2.- once it freezes i had to shutdown with Alt-Prnt+RSEIUB. switch to console or restart X was impossible.
3.- if it freezes once, it was more 'likely' tp freeze again until it hang every time i rotated cube or even with screen saver (it's 3D)

point 3 improved if i deleted .compiz in folders /home and /.config and then ctrl-alt-bcksp, however it freezed 1 out of 3 or 4.
at last i realized that the ubuntu logo and the progress bar at start up had disappeared too, so i fix it with startup manager and put screen resolution at 1024x768, 16 bits, because it was at 640xsomething. i don't know why or how but since then (3 days ago) i've had no problem, although i've tested compiz effects trying to provoke a freeze.

deksaplay (imandanislam) on 2009-01-07
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers