Workspace switching doesn't work

Bug #182424 reported by Matt Zimmerman on 2008-01-12
4
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: compiz

I upgraded a laptop from Gutsy to Hardy today (it never ran anything older that Gutsy). At one point during Gutsy, it was using compiz, but it was running metacity as of the 7.10 release due to its (intel) graphics device being blacklisted.

After the upgrade, my workspace switching shortcuts do not work. The workspace switcher on the panel shows two workspaces (where previously I had 6), and the shortcuts do nothing.

Matt Zimmerman (mdz) wrote :
Matt Zimmerman (mdz) wrote :
Changed in compiz:
importance: Undecided → Medium
Steffen Neumann (sneumann) wrote :

I have a related issue with workspace switching, so if should open another
bug please drop a note. I have a fresh install of hardy as of mid-january,
and closely followed updates until current beta(-1?). The problem was always present.

I have configured 4 workspaces in "workspace switcher 2.22.0"
and can use all of them. In System->prefs->GL-desktop I have
4 viewports. Cube effect is enabled, but same problem in "Plane and slide".

If I use ctrl-alt-left or ctrl-alt-right _two_ workspaces are cycled,
i.e. 1->3->1->3 ... or 4->2->4->... Interestingly, rollover is correct:
1->4(but then ->2->4->...) or 4->1 (but then 1->3->1->...

I created a new user to try fresh gconf settings, with the same problem.

Yours,
Steffen

Josha Foust (josha-foust) wrote :

I would like to add a me too to Steffen's problem. In addition, you can see the problem with dragging windows to other workspaces. Only 1 <-> 4 works correctly.

I am using an upgrade from Gutsy to Hardy beta.

Steffen Neumann (sneumann) wrote :

I would like to add some more observations:

1) If I use Expose (Windows/Super-E) then I can
move with the cursor keys from left to right and back,
as expected.

2) If I use Ctrl-Alt-Down compiz zooms out and presents
three desktops next to each other (not sure about the name
of this function). Here I have the same problem as with the
cube rotation, going left/right skips a workspace.

3) If I start System->Prefs->GL Desktop the configuration screen
starts with "Type mismatch: Expected list, got string",
which has been described in #210162.

Yours,
Steffen

Steffen Neumann (sneumann) wrote :

OK, I followed the guid using ccsm on
http://www.uluga.ubuntuforums.org/showthread.php?t=563003
and resetting to defaults + the right set of plugins did the trick,
workspaces are now switching in the right order.

The "Type mismatch: Expected list, got string" is still there, though.

Steffen

Andres Herrera (andresh) wrote :

Hi, unable to reproduce the bug (I have a clean installation Hardy), maybe you could make the same clean installation and then comment on how it lines up. Thanks

Changed in compiz:
status: New → Incomplete
Matt Zimmerman (mdz) wrote :

I haven't seen this problem in a clean installation. The next time I'm in front of that machine, I'll try resetting to the defaults in ccsm and see if that helps. If it doesn't, I'll reopen.

Changed in compiz:
status: Incomplete → Invalid
Matt Zimmerman (mdz) wrote :

My problem was resolved by changing the configuration backend back to "gconf" (it had changed on its own to 'flat file'). I'm told there is already a bug open about the fact that this happens; the original issue has been resolved for a while now.

Changed in compiz:
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers