Window switchers do not display contents of minimized windows

Bug #181394 reported by fuku on 2008-01-09
46
This bug affects 5 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: compiz

When there is a minimized window on the screen and i use for instance shift switcher via super + tab the content of the minimized windows is not displayed.
This is very annoying, because it does not fit and you have to read the title of the window (if you have display titles disabled and you have several minimized windows you can only guess)
Here an example:
http://img100.imageshack.us/img100/6241/shiftwindowminimizebugng1.png

The same issue is experienced with the other compiz windows shifters.

Travis Watkins (amaranth) wrote :

It's not possible to show minimized windows. When you minimize a window it ceases to exist.

Changed in compiz:
status: New → Invalid
fuku (eckel-max) wrote :

i do not talk about implementation issues here.
it is a logical failure
you as a user expect the windows to be visible to you when you switch through them

Travis Watkins (amaranth) wrote :

It's not just 'implementation issues', it's more like 'we would have to redesign the way X11 works to fix this' issues.

fuku (eckel-max) wrote :

hm
just a suggestion, (unfortunately i am not familiar with the technical background) but would it be possible to recreate the minimized window while the user is in the shift switcher mode and minimized (e.g. exit) it when the mode is left?

I really do not want to be unkindly or pushy, but i think this is a annoying bug which makes the pretty and effective plugin more or less useless

gcb (descartavel1) wrote :

Solution: use latest screen shot with a universally reckognizable icon overlay meaning it's a still image. so that the user knows that it's a still taken before, not the real time things

ideas for the icon overlay are:
- pause "||" icon (not very good, might give the wrong impression that the app is halted)
- a white border and some small 15 degree inclination, meaning it's a picture taken somewhere in the past (as all photographs)

Motin (motin) wrote :

I second a solution based on a stale image from just before it was minimized + an overlay.

This is a major usability issue, and since we cannot wait for X11 to be redesigned, we need to work with what we have so that Compiz windows shifters are as usable as possible.

Changed in compiz (Ubuntu):
status: Invalid → Confirmed
description: updated
summary: - Shift Switcher does not display minimized windows
+ Compiz windows switchers does not display minimized windows
Motin (motin) on 2009-04-19
summary: - Compiz windows switchers does not display minimized windows
+ Compiz windows switchers does not display contents of minimized windows
summary: - Compiz windows switchers does not display contents of minimized windows
+ Window switchers do not display contents of minimized windows
Changed in compiz (Ubuntu):
importance: Undecided → Wishlist
status: Confirmed → Triaged
Robert Ancell (robert-ancell) wrote :

As noted in bug 192110 this is different behaviour to Metacity (which shows the last state of the window before being minimised)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers