Hardy Alpha 2 - Compiz does not show window borders

Bug #180716 reported by pablo_g on 2008-01-06
30
Affects Status Importance Assigned to Milestone
Compiz
Invalid
Unknown
compiz (Ubuntu)
Medium
Michael Vogt

Bug Description

Binary package hint: compiz

Compiz does not show window borders

pablo_g (pablogastonbodnar) wrote :

The boarders seems to be there in some way, in fact, I see the minimize, maximize , and close button, if i move the mouse to the right top position, and the space where the borders should be are invisible.

Michael Vogt (mvo) on 2008-01-07
Changed in compiz:
importance: Undecided → Medium
status: New → Confirmed
Michael Vogt (mvo) wrote :

It looks like it is possible to workaround the issue by setting the gconf key /apps/gwd/metacity_theme_shade_opacity to false.

Changed in compiz:
assignee: nobody → mvo
milestone: none → hardy-alpha-3
Michael Vogt (mvo) wrote :

This problem seems to be only happening with the nvidia driver.

Michael Vogt (mvo) wrote :

I added the workaround for this to the packages.

Changed in compiz:
status: Confirmed → Fix Released
pablo_g (pablogastonbodnar) wrote :

Sorry, but i really did not understand. Do you mean this is fixed just setting the gconf key /apps/gwd/metacity_theme_shade_opacity to false ? How do i do that ? Do i wait for new packages ? I did not see some path like that in my system. Could you explain me ? Thanks in advance.

Changed in compiz:
status: Unknown → Confirmed
Michael Vogt (mvo) wrote :

 @pablo_g: Sorry for not being more verbose. A new version of the compiz package was uploaded with a workaround for this issue. With that update it should be no longer visibile (also its not really fixed yet, it looks like a problem with the latest nvidia driver).

Tux (peter-hoogkamer) wrote :
Download full text (11.8 KiB)

I can confirm this bug on a Dell Inspiron 6400 Dual Core 2 laptop with a ATI Mobility X1300 graphics card. Updated until 9 januari 2008.
I cannot enable Desktop Effects. It results in the error "Desktop Effects could not be enabled". When using the Compiz-fusion icon choosing for Compiz there are no window borders.
Kernel version 2.6.24-3-generic
Compiz version 1:0.6.99+git20080102-0ubuntu3
Fglrx version 1:1.7.0-7-11+2.6.24-3.10

Added my xorg.conf as attachement.

My .xsession-errors :
No nvidia hardware available
Checking for Xgl: not present.
Detected PCI ID for VGA: 01:00.0 0300: 1002:7149 (prog-if 00 [VGA controller])
Checking for texture_from_pixmap: not present.
Trying again with indirect rendering:
Checking for texture_from_pixmap: not present.
SKIP_CHECKS is yes, so continuing despite problems.
Checking for nVidia: not present.
Checking for FBConfig: present.
Checking for Xgl: not present.
Starting gtk-window-decorator
/usr/bin/compiz.real (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
/usr/bin/compiz.real (core) - Error: Failed to manage screen: 0
/usr/bin/compiz.real (core) - Fatal: No manageable screens found on display :0.0
compiz.real (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
compiz.real (core) - Error: Failed to manage screen: 0
compiz.real (core) - Fatal: No manageable screens found on display :0.0
compiz.real (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
compiz.real (core) - Error: Failed to manage screen: 0
compiz.real (core) - Fatal: No manageable screens found on display :0.0
compiz.real (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
compiz.real (core) - Error: Failed to manage screen: 0
compiz.real (core) - Fatal: No manageable screens found on display :0.0

fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon X1300
OpenGL version string: 2.1.7059 Release

compiz --replace
Checking for Xgl: not present.
Detected PCI ID for VGA: 01:00.0 0300: 1002:7149 (prog-if 00 [VGA controller])
Checking for texture_from_pixmap: not present.
Trying again with indirect rendering:
Checking for texture_from_pixmap: not present.
SKIP_CHECKS is yes, so continuing despite problems.
Checking for nVidia: not present.
Checking for FBConfig: present.
Checking for Xgl: not present.
Starting gtk-window-decorator
/usr/bin/compiz.real (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
/usr/bin/compiz.real (core) - Error: Failed to manage screen: 0
/usr/bin/compiz.real (core) - Fatal: No manageable screens found on display :0.0

glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_mem...

Travis Watkins (amaranth) wrote :

That's a different problem. Your driver is broken.

How can this be, when this is a alpha 2 install which is barely a
month old? And what do you suggest to fix it? Should Desktop Effects
work in Hardy Alpha 2 on Ati x1300?

Peter

2008/1/10, Travis Watkins <email address hidden>:
> That's a different problem. Your driver is broken.
>
> --
> Hardy Alpha 2 - Compiz does not show window borders
> https://bugs.launchpad.net/bugs/180716
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Travis Watkins (amaranth) wrote :

The fglrx driver is broken, it has nothing to do with how new your install is.

Tux (peter-hoogkamer) wrote :

Ok. So, could it be an option to install the latest binary from ati?
Or is that one broken too?

2008/1/10, Travis Watkins <email address hidden>:
> The fglrx driver is broken, it has nothing to do with how new your
> install is.
>
> --
> Hardy Alpha 2 - Compiz does not show window borders
> https://bugs.launchpad.net/bugs/180716
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Luke (lukekuhn) wrote :

HOW TO MAKE COMPIZ WORK IN UBUNTU HARDY
  Pentium4/older NVIDIA card in test case
###########################################

  You need to have the proprietary driver for your video card installed, but restricted drivers manager does NOT work in Hardy as shipped because there is NO xorg.conf file by default! Therefore, you must invoke a program
which will generate this file. X11 will use it once written but no longer depends on it to boot. We are going to use "Screens and Graphics" from the
Admin menu for this purpose.

1: make SURE you have a root password enabled in case you have to boot
   into recovery mode. While the version of Hardy I have goes into recovery
   mode without a root password, I do not know if ALL versions will
   retain this feature, which compromises security for safety.

2: Install the proprietary driver packages for your video card.

3: go to "system" in the main menu

4: select Administration/Screens and Graphics

5: Stay on the screen tab(NOT the driver tab)

6: Change the screen resolution (to anything)and activate the "test" button-
   it will fail the configuration test,so don't close or shut down anything
   now!

7: Change your screen resolution back to where it was and test again-it will
   now pass the test-and /etc/X11/org.conf has now been generated for your
   default condition.

8: You can now use the restricted drivers manager in the normal way-enable
   the proprietary driver and restart your machine.

9: Go to appearances and enable desktop effects-Gandalf is back!

#############################################################################

   IF YOU SCREW UP AND YOUR MACHINE WON'T BOOT INTO X11:

 Boot into recovery mode(single) and delete /etc/X11/xorg.conf ! That's right-you can just DELETE this file, and Hardy's version of x11 will boot just fine, using your open-source drivers and allowing you to start over.

 Hardy Heron has a great new safety feature, though it is the reason for the driver/compiz problem as shipped-X11q no longer needs that x11.org.conf file to start! Still needs to to run prorietary driversa, but not to run open-source drivers.

With so many operating systems in older distros getting killed by screwed-up xorg.conf files that users don't know how to fix, getting a "default boot" from x11 without it is a key step towards making Ubuntu as end-user friendly as Windoze and those other corporate systems people learned on. Better to have trouble with Compiz and games than with the entire GUI!

###############################################################

 TODO:

  Whoever is managing the restricted drivers manager package needs to add code to automatically generate /etc/X11/xorg.conf when the program is first invoked, just as "screens and graphics" already does.

Hi @all,

This bug also appears for the kde-window-decorator!

Am I right, that this is only fixed for gtk-window-decorator? Or should it also work with kde, but simple doesn`t.

Can someone get the EEE PC hardware into the hardware database or at least an entry for an 800x480 monitor.

These changes have made a simple edit to xorg.conf extremely difficult. If ubuntu doesnt detect the hardware then you cant get the native screen resolution.

i get a choice of 800x600 too big or 640 by 480 to small

all because i turned off desktop effects so the web cam would work!

Ingo Gerth (igerth) wrote :

I want to report that this bug is still existent in Hardy Beta.
Hope that it'll be fixed out of box till the RC!

Dave Lozier (dave-lozier) wrote :

I'm getting this same problem with the latest beta, fully updated, on a HP nc8430 laptop with an ATI Mobility Radeon X1600 (version 2.1.7412 Release).

This is a standard install, nothing compiled or added in outside of the regular packages that are available.

Travis Watkins (amaranth) wrote :

Fully updated != has ubuntu-desktop installed. You probably blindly upgraded through the version that uninstalled compiz-gnome and haven't reinstalled it, the 'compiz' package, or the ubuntu-desktop package.

Dave Lozier (dave-lozier) wrote :

I installed the desktop version via latest cd download. I upgraded with apt-get upgrade, including apt-get dist-upgrade. I will search for compiz and install as needed. Thank you.

Changed in compiz:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.