Not all applications working with fixed window placement

Bug #180316 reported by charly4711 on 2008-01-04
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: compiz

I'm trying to get windows positionied explicitly through the "Windows Placement" plugin in compiz.
Opening a new window on a fixed viewport works for me, using fixed window dimensions, however, does not.

These are the packages I have installed:
compiz 1:0.6.2+git20071119-0ubuntu1~gutsy1
compiz-core 1:0.6.2+git20071119-0ubuntu1~gutsy1
compiz-fusion-plugins-extra 0.6.0+git20071121-0ubuntu1~gutsy1
compiz-fusion-plugins-main 0.5.2+git20070928-0ubuntu2
compiz-gnome 1:0.6.2+git20071119-0ubuntu1~gutsy1
compiz-plugins 1:0.6.2+git20071119-0ubuntu1~gutsy1
compizconfig-settings-manager 0.5.2+git20070912-0ubuntu1
libcompizconfig-backend-gconf 0.5.2+git20071010-0ubuntu1
libcompizconfig0 0.5.2+git20070919-0ubuntu3
python-compizconfig 0.5.2+git20070912-0ubuntu1

I'll attach my compiz config next.

charly4711 (karl-h-beckers) wrote :

my compiz config

description: updated
Changed in compiz:
importance: Undecided → Low
Basilio Kublik (sourcercito) wrote :

Hi there
you report this issue some time ago and hasn't been any activity since then, i was wondering if this is still an issue for you with the latest upgrades in Hardy Heron.

Thanks in advance

Changed in compiz:
assignee: nobody → sourcercito
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!.

Changed in compiz:
status: Incomplete → Invalid

In response to Basilio Kublik's comment, this is still an issue with me. Placement on specific viewports works terrific, but specific window positions do not. I am reopening this bug; please let me know any information needed to further confirm and help fix this bug.

Changed in compiz:
status: Invalid → New
Travis Watkins (amaranth) wrote :

I cannot reproduce, are you sure you're setting the match rule properly?

Changed in compiz:
status: New → Incomplete

Attached is a screenshot of my relevant compizconfig-settings-manager window. After a reboot, rhythmbox places incorrectly, gnome-terminal places correctly. If I exit rhythmbox and reopen it, it places correctly.

Travis Watkins (amaranth) wrote :

Do you have rhythmbox set to start on login? It might be starting before compiz.

I do not. Generally I start firefox, pidgin, and rhythmbox manually after logging in, and after compiz has started.

Daniel (dbbolton) wrote :

I am experiencing this same issue on Ubuntu 8.04.1. I have enabled "Place Windows". Under the "General" tab, "Workarounds" is enabled, and "Placement Mode" is set to "Smart". Then under the "Fixed Window Placement" tab, I added an entry for "class=Firefox", "x" and "y" both set to "200". Whenever I launch Firefox, it always starts out all the way in the upper left hand corner of the screen.

Changed in compiz (Ubuntu):
status: Incomplete → Triaged
summary: - fixed window placement not working
+ Not all applications working with fixed window placement

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version. When you test it and it is still an issue, kindly upload the updated logs by running apport-collect <bug #> and any other logs that are relevant for this particular issue.

Changed in compiz (Ubuntu):
status: Triaged → Incomplete
assignee: Basilio Kublik (sourcercito) → nobody
Launchpad Janitor (janitor) wrote :

[Expired for compiz (Ubuntu) because there has been no activity for 60 days.]

Changed in compiz (Ubuntu):
status: Incomplete → Expired
FuzzyQ (atomicfuzzyq) wrote :

Too bad there isn't more feedback on this one. I'm suffering the same bug, Rhythmbox seeming to be the only troublemaker. Strangely, Rhythmbox *sometimes* appears on the predestined workspace (x=2,y=2), but most of the time it does not.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers