[Hardy 8.04 alpha-2 compiz (or compiz-fusion) compizconfig-settings-manager] Extra level of effects does not work but Normal does, no Custom option, default Extra effects are not set, and some effect tooltips are useless.

Bug #178467 reported by Stanley Sokolow on 2007-12-24
8
Affects Status Importance Assigned to Milestone
compizconfig-settings-manager
Fix Released
Undecided
Unassigned
compiz (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: compiz

I enabled "Normal" visual effects (System>Preferences>Appearance>Visual_Effects) which worked ok. I tried to enable "Extra" effects, but after it executes this seems to turn off effects completely: scroll wheel does not change workspace and no shadows around windows. Reselected "Normal" and it gave normal effects again. (As I reported in bug #177141 https://bugs.launchpad.net/restricted-manager/+bug/177141/comments/4 , restricted-manager was not installed by default so I installed it with Synaptic.)

I went back to my 7.10 installation to compare. This made me aware that the System>Preferences>Advanced_Desktop_Effect_Settings item is missing from the 8.04 alpha-2 menu and that "Custom" option is missing from Appearance_Preferences>Visual_Effects tab. I installed package compizconfig-settings-manager using Synaptic. Now Custom was added to Visual Effects options and Advanced Desktop Effect Settings is in the System>Preferences menu. I selected it and noticed that all of the default settings are off except Shift Switcher. That's probably why the Extra effects selection didn't seem to be doing anything. It probably was active but almost everything is turned off by default. Extra effects should include a reasonable set of effects, as it did in Gutsy 7.10 release.

Working with the default effects as set by "Extra" visual effects selection, I notice that windows open without a title bar or other normal decorations, can't be moved or resized, etc. Some windows open under (behind) the top panel so that their top portion is not visible. After I activated custom selection to enable moving windows using alt key to grab them with the mouse, I noticed that windows wiggle when I move them but I didn't activate that feature. Returning to Normal settings, windows do open with title bar and controls.

One other comment: the tooltip hints that pop up when the mouse pointer dwells on a custom feature setting are not very instructive. For example, hovering on Shift Switcher pops up "Shift Switcher Plugin". Hovering on "Put" pops up "Put window". That's redundant and doesn't help the user decide whether he/she wants that effect. Each effect should have a reasonably clear description of what it does without repeated the title of the effect. This is a usability problem.

So it seems that these two packages (restricted-manager and compizconfig-settings-manager) which should be installed by default in 8.04 alpha-2 are not installed, and the compiz default settings are not set correctly.

description: updated
description: updated
description: updated
Jonathan Amir (jonathan-amir) wrote :

I can confirm this. With Hardy Alpha2, the extra desktop effects is broken. Windows have no decorations and no title bar, they can't be moved nor resized. Basically, this mode is now useless.

Brian Murray (brian-murray) wrote :

Reviewing this bug report and its comments it seems that multiple people are experiencing this problem. Subsequently, I am confirming this bug report. For future reference you can manage the status of bug reports by clicking on the current status in the yellow line and then choosing a new status in the drop down box. You can learn more about bug statuses at http://wiki.ubuntu.com/Bugs/Status .

Changed in compiz:
status: New → Confirmed
Changed in compiz:
importance: Undecided → Medium
Stanley Sokolow (overbyte) wrote :

I'm running Hardy alpha-3 with current up-to-date updates. Compiz is working okay. Appearance visual effects have reasonable settings. I'm changing status.

Changed in compizconfig-settings-manager:
status: New → Fix Released
Changed in compiz:
status: Confirmed → Fix Released
mike (ubuntu-holmesfamily) wrote :

I am completely in sync with Hardy and as of the updates about two days ago, if I set the desktop effects, all windows lose the ability to be moved, the boarders are gray and new applications are locked where they appear. I waited to see if further updates fixed the problem but they have not.
Switching back to no effects re enables the boarders.

Jonathan Amir (jonathan-amir) wrote :

I didn't have this problem with the alpha 4, but I installed it from scratch. Mike, is it possible that because you kept updating it then you have some broken settings that are left over from previous alphas?

mike (ubuntu-holmesfamily) wrote :

I have been starting from scratch from the CD for the last few evenings and the result is the same, after all the latest updates are installed, switching on effects causes the frames to have gray borders and the frames cannot be moved. I have had a great deal of trouble with the nvidia restricted driver too, there is some broken interaction there.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers