Various problems with Compiz on multi-head setup

Bug #178341 reported by jhansonxi on 2007-12-23
6
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

I'm using an Nvidia GeForce 6600 GT in a mult-head (non-Xinerama) configuration on Gutsy. With Compiz enabled there are a bunch of problems, mostly with the second head, that I think may be manifestations of the same unknown cause. The lack of obvious errors in my logs and the symptoms displayed lead me to believe there is a problem with the second desktop instance reading the Gnome or Compiz config files.

First, no window decorations are being loaded by gtk-window-decorator on the second head, ie, no window borders. I am certain the app is loaded to begin with as it shows up in the process list. All desktop effects seem to be active. If I do a "gtk-window-decorator --replace" the decorations are then displayed. Bug #172502 indicates there was a problem with gtk-window-decorator not being loaded that was fixed in Hardy but I am certain that it's being loaded in my case. I went through all the relevant bugs, forum threads, and mailing lists and tried everything that made sense including the xorg.conf fixes, CompizConfig window decorator settings, and deleting all Gnome and Compiz config files. References:

Bug #137660
http://forum.compiz-fusion.org/archive/index.php/t-151.html
http://ubuntuforums.org/showthread.php?t=575882

Second, the Quit button on the second desktop freezes the display instead of showing the logout/power window. This was reported in bug #150846 but I found that the window is active but invisible. ESC returns control to the desktop and Alt-L logs out.

Third, the long menu delay on every menu and pull-down really annoys me but with my setup it's only present on the primary head, not the secondary. Setting gtk-menu-popup-delay=0 doesn't affect it and messing around with the CompizConfig settings wouldn't fix it either. Regardless of the reason for the long default delay, I would expect them to be the same on both heads. Bug #175647 reports similar issues.

Fourth, changing the number of workspaces with the Workspace switcher on the second head only changes the primary head, not the secondary. It also doesn't seem to get along with the Compiz settings but that appears to be a known limitation.

Fifth, the only errors I see in the logs are from Nautilus complaining about "Can not calculate _NET_NUMBER_OF_DESKTOPS". There doesn't seem to be any obvious problem with Nautilus but it could be related. Another report of this error on Gutsy is here:
http://ubuntuforums.org/showthread.php?t=639683

jhansonxi (jhansonxi) wrote :
jhansonxi (jhansonxi) wrote :
riahmatic (riahmatic) wrote :

I'm running the same configuration with a Nvidia 8400M GS and can confirm the behaviors listed in points one, two , and three. I also tried setting gtk-menu-popup-delay=0 but the first head still has this delay. The second head also has no window borders and the Quit button behaves as described.

Setting the number of workspaces through the advanced Compiz configuration dialog worked for me. The Workspace switcher didn't show me the option.

Benson Margulies (bimargulies) wrote :

I'm seeing a far worse variation on the theme.

Dell M1330. That has an Nvidia 8400M GS.

Plugged into the DVI port, a Dell 2407WFP.

So, the two monitors have very different geometry.

I'm configured with Xinerama.

If I tell compiz to turn on, both screens go gray and stay that way until I blast out of X and edit the XML file (I use XFCE4) to turn off compiz again. Nothing is visible except the occasional flicker.

Benson Margulies (bimargulies) wrote :

Null comment so I can check the 'email' button.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers