Unable to exit fullscreen mode in rdesktop with compiz

Bug #176611 reported by JakeStevenson on 2007-12-15
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Low
Unassigned

Bug Description

When running rdesktop under compiz-fusion, pressing ctrl-alt-enter does not exit fullscreen mode. Some flickering occurs, but rdesktop remains fullscreen. This does not occur when running under metacity.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Hardy Heron. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in compiz:
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!.

Changed in compiz:
status: Incomplete → Invalid

I just attempted this with the Beta CD and am still unable to switch from fullscreen to windowed mode in rdesktop when using the "extra" visual effects mode.

Changed in compiz:
status: Invalid → New
Basilio Kublik (sourcercito) wrote :

Hi Jake
do you still experience this issue with the latest ugrades in Hardy?

Thanks

Changed in compiz:
importance: Undecided → Low
status: New → Incomplete

Yes, it is still occuring with an apt-get dist-upgrade as of 04/10/2008 at 8:00AM central time.

To reproduce it you only need to run "rdesktop -f somewindowsserver" from a terminal while also running compiz.

Derek Buranen (eburner) wrote :

It happens here too. I either have to ctrl+alt+backspace to quit X or do a "logoff" on the remote session. Works swimmingly in metacity though.

Mauro De Lucca (pcniatic) wrote :

I do have the same problem using the live cd of Hardy Heron. Exactly like Derek i must either ctrl-alt-backspace or logoff on the remote computer to exit fullscreen mode.

Tarnay Kálmán (tarnay-kalman) wrote :

Just start rdesktop with the -f option and you will see what we mean.

Changed in compiz:
status: Incomplete → Confirmed
Derek Buranen (eburner) wrote :

Fixed in Intrepid as of now.

Changed in compiz:
status: Confirmed → Fix Released
müzso (bit2) wrote :

Is this a compiz issue at all? Is it possible to test the fix with Hardy Heron? I mean can I just upgrade the compiz package from the Intrepid ("testing") repositories without being required to upgrade a thousand other packages too (or at most only the compiz-* ones)?
Is there a backport in sight some time in near future (in the hardy-backports repository)?

müzso (bit2) wrote :

Derek: could you reveal what was the issue and what fixed it? If it's a small fix, then maybe I could look it up in the sources (from the Intrepid repos) and build a new package for my Hardy setup. This is quite a painful issue for us (at my company), because we use compiz all the time and use rdesktop on a regular basis.

For now we can work around the issue by not using full screen mode, but using the "-g" switch to specify exact geometry for the rdesktop window (and by that making it cover the full screen). Combining this with the compiz "Scale" plugin (and using a "hot corner") we can even switch from rdesktop to other apps (without having to force rdesktop not to override the windows manager key bindings with the "-K" switch).

Thanks for your help in advance!

Derek Buranen (eburner) wrote :

I wish I knew. I don't think it was rdesktop 1.6 at least according to its release notes.
http://sourceforge.net/mailarchive/forum.php?thread_name=20080511065217.GA24455%40cse.unsw.EDU.AU&forum_name=rdesktop-announce

I assume it was the new git snapshot 0.7.7 of compiz in intrepid that fixed it. Sorry I'm not more help. Just take the plunge to Intrepid!

müzso (bit2) wrote :

Thanks for the answer. I assumed you know more about this bug, but it seems you just tested it on a PC running Intrepid, the problem did not occur and you reported this experience here. Upgrading a "production" server to an OS-branch that is heavily under development, is definitely not a good idea. I'll have to wait til the fix gets into Hardy too or til Intrepid is released (which will be sometime in October or November).

müzso (bit2) wrote :

Some additional info for the bug ...
Rdesktop _does_ exit fullscreen mode in the described case, only the window decorations (title bar) are not added to the window. If you set up the Scale plugin in Compiz and a hot corner for activation (eg. the upper-left corner), then start rdesktop in fullscreen mode, try to move the mouse to the upper-left corner (nothing should happen), press Ctrl+Alt+Enter (some flickering occurs on the screen, but it _looks_like_ rdesktop is still in fullscreen mode) and now move the mouse to the upper-left corner again. This time the Scale plugin is triggered and you can switch to another application.

So this might be an rdesktop bug after all. Sometime later I'll test the rdesktop version that is now in Intrepid and see if it fixes the problem.

Cosmin L (lcosmin) wrote :

Running on Intrepid here, I can confirm that the fix mentioned in the other bug works: disabling compiz's legacy full screen support from workarounds.

morts (kyrill-poole) wrote :

The way I got around the problem is by creating a shortcut to rdesktop (as an app, not a console app) and then putting in my arguments thus:

rdesktop -u myusername -g 1275x945 -a 15 -z myhost

By specifying the exact dimensions of the window I can happily have it fill up one of my desktops, not move thanks to snapping edges and be able to easily ctrl+alt+arrow out to another desktop.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers