throwing nautilus to other screen ends up under launcher

Bug #1759817 reported by Humphrey van Polanen Petel
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
New
Undecided
Unassigned

Bug Description

I am using two screens with the right one being the default which has the launcher.
When I throw nautilus from left to right with <Ctrl,Alt,X>, it ends up with the top-left corner in the top-left corner of the screen underneath the launcher.
When I then throw nautilus to the top with <Ctrl,Alt,Up>, it positions correctly.
When I then throw nautilus back to the left screen and again to the right screen, it positions correctly.
Other programs (e.g. firefox) appear to behave correctly.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: compiz 1:0.9.12.2+16.04.20160823-0ubuntu1
ProcVersionSignature: Ubuntu 4.13.0-37.42~16.04.1-generic 4.13.13
Uname: Linux 4.13.0-37-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
.proc.driver.nvidia.gpus.0000.01.00.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0000:01:00.0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 384.111 Tue Dec 19 23:51:45 PST 2017
 GCC version: gcc version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.9)
.proc.driver.nvidia.warnings.fbdev:
 Your system is not currently configured to drive a VGA console
 on the primary VGA device. The NVIDIA Linux graphics driver
 requires the use of a text-mode VGA console. Use of other console
 drivers including, but not limited to, vesafb, may result in
 corruption and stability problems, and is not supported.
.tmp.unity_support_test.0:

ApportVersion: 2.20.1-0ubuntu2.15
Architecture: amd64
BootLog:

CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Thu Mar 29 21:27:59 2018
DistUpgraded: Fresh install
DistroCodename: xenial
DistroVariant: ubuntu
GraphicsCard:
 NVIDIA Corporation GF108 [GeForce GT 620] [10de:0f01] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Gigabyte Technology Co., Ltd GF108 [GeForce GT 620] [1458:3547]
GsettingsChanges:
 b'org.compiz.core' b'outputs' b"['1280x1024+1280+0', '1280x1024+0+0']"
 b'org.compiz.core' b'hsize' b'2'
 b'org.compiz.core' b'active-plugins' b"['core', 'composite', 'opengl', 'imgpng', 'commands', 'wall', 'grid', 'compiztoolbox', 'put', 'mousepoll', 'regex', 'unitymtgrabhandles', 'snap', 'resize', 'place', 'copytex', 'vpswitch', 'move', 'animation', 'session', 'workarounds', 'expo', 'fade', 'scale', 'unityshell']"
 b'org.compiz.core' b'vsize' b'2'
InstallationDate: Installed on 2017-12-13 (105 days ago)
InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64 (20170801)
MachineType: Dell Inc. Vostro 420 Series
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.13.0-37-generic root=UUID=0f046c3c-8d46-4612-9d4b-a7e58c6afbad ro
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/22/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.3.0
dmi.board.name: 0N185P
dmi.board.vendor: Dell Inc.
dmi.board.version: A02
dmi.chassis.type: 3
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.3.0:bd06/22/2010:svnDellInc.:pnVostro420Series:pvr:rvnDellInc.:rn0N185P:rvrA02:cvnDellInc.:ct3:cvr:
dmi.product.name: Vostro 420 Series
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.12.2+16.04.20160823-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.83-1~16.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 17.2.8-0ubuntu0~16.04.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 17.2.8-0ubuntu0~16.04.1
version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
version.xserver-xorg-core: xserver-xorg-core N/A
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A
xserver.bootTime: Thu Mar 29 07:39:14 2018
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Power Button KEYBOARD, id 7
 input Microsoft Microsoft Basic Optical Mouse v2.0 MOUSE, id 8
 input AT Translated Set 2 keyboard KEYBOARD, id 9
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.19.5-0ubuntu2~16.04.1

Revision history for this message
Humphrey van Polanen Petel (hpvpp) wrote :
Revision history for this message
Humphrey van Polanen Petel (hpvpp) wrote :

happens with leafpad as well

Revision history for this message
Humphrey van Polanen Petel (hpvpp) wrote :

happens with boinc as well

Revision history for this message
Humphrey van Polanen Petel (hpvpp) wrote :

happens with terminal as well

Revision history for this message
Humphrey van Polanen Petel (hpvpp) wrote :

happens with LibreOffice as well

Revision history for this message
Humphrey van Polanen Petel (hpvpp) wrote :

some extra info

left screen is 19'', right screen is 17''

To post a comment you must log in.