Whole OS froze during boot because of compiz eating up 100% CPU forever

Bug #1743435 reported by teo1978
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

Note that the time it normally takes for Ubuntu to boot (on a pretty fast machine, a quad-core i7) is already absolutely ridiculous regardless of this (or any other) bug: every time you boot you have to wait for several minutes for the system to be usable, and often you start to wonder whether something is stuck or not.

Anyway, this time what happened was the following. Note that this is NOT reproducible at will, I have experienced it just once.

I was booting. I got to see the purple screen. I think I even got to see the user login prompt and entered my password, not entirely sure whether that's true because it took so fucking long I forgot.

AFTER that, the screen went black (as it usually does for a short while), but the white-arrow mouse cursor was visible and movable.
It stayed like that forever, and would never go on to show the desktop. I waited way longer than the time it usually takes for the system to completely boot. I tried Alt+Tab and other random key combinations and key strokes, but nothing happened. I even tried the key combination for switching screens (Fn+F6 on my laptop) but this would just turn the builtin screen off and on with no effect on the connected external screen, which had already turned on purple but was now off (I think off, or at least completely black).

There was barely any detectable disk activity, which was the clearest indication that most definitely it was not just the normal boot taking very long.

So I hit Ctrl+Alt+F1 and succesfully got a virtual terminal screen. First I tried to just go back with Ctrl+Alt+F7 but I didn't had any luck with that, so I went back to Ctrl+Alt+F1

In the virtual terminal screen, I logged in, ran "top" and found out that compiz was using 100% CPU.

I killed Compiz, then went back to Ctrl+Alt+F7 and almost immediately, the purple screen came up again and the system completed booting. I'm pretty sure this wasn't a coincidence; clearly it was killing Compiz (forcing it to restart, I guess) that unfroze the system.

I am now using the system normally and haven't rebooted since then.

This is Ubuntu.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: compiz 1:0.9.12.2+16.04.20160823-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-101.124-generic 4.4.95
Uname: Linux 4.4.0-101-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia
.proc.driver.nvidia.gpus.0000.01.00.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0000:01:00.0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 340.102 Mon Jan 16 13:06:29 PST 2017
 GCC version: gcc version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.5)
.tmp.unity_support_test.0:

ApportVersion: 2.20.1-0ubuntu2.13
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Mon Jan 15 18:36:09 2018
DistUpgraded: Fresh install
DistroCodename: xenial
DistroVariant: ubuntu
DpkgLog:

GraphicsCard:
 Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] 3rd Gen Core processor Graphics Controller [1025:0647]
 NVIDIA Corporation GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] [10de:1140] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] GeForce 710M [1025:0691]
GsettingsChanges:
 b'org.compiz.core' b'outputs' b"['1920x1080+0+0']"
 b'org.compiz.core' b'active-plugins' b"['core', 'composite', 'opengl', 'move', 'compiztoolbox', 'regex', 'workarounds', 'vpswitch', 'resize', 'snap', 'place', 'mousepoll', 'imgpng', 'expo', 'session', 'scale', 'unityshell']"
InstallationDate: Installed on 2013-10-11 (1557 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
LightdmLog:
 [+333.70s] DEBUG: Seat seat0 changes active session to c2
 [+333.70s] DEBUG: Session c2 is already active
MachineType: Acer Aspire V3-571G
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-101-generic.efi.signed root=UUID=5830b30e-69e8-4bb4-8a2b-bc2b43c7414a ro quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/15/2012
dmi.bios.vendor: Acer
dmi.bios.version: V2.07
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: VA50_HC_CR
dmi.board.vendor: Acer
dmi.board.version: Type2 - Board Version
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V2.07
dmi.modalias: dmi:bvnAcer:bvrV2.07:bd10/15/2012:svnAcer:pnAspireV3-571G:pvrV2.07:rvnAcer:rnVA50_HC_CR:rvrType2-BoardVersion:cvnAcer:ct10:cvrV2.07:
dmi.product.name: Aspire V3-571G
dmi.product.version: V2.07
dmi.sys.vendor: Acer
version.compiz: compiz 1:0.9.12.2+16.04.20160823-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.76-1~ubuntu16.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 17.0.7-0ubuntu0.16.04.2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 17.0.7-0ubuntu0.16.04.2
version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.18.4-0ubuntu0.7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1.2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2
xserver.bootTime: Mon Jan 15 16:56:08 2018
xserver.configfile: /etc/X11/xorg.conf
xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.18.4-0ubuntu0.7

Revision history for this message
teo1978 (teo8976) wrote :
Revision history for this message
teo1978 (teo8976) wrote :

This keeps happening pretty often.

The workaround of killing the 100%-cpu-consuming Compiz process in a ctrl+alt+f1 terminal always works, and systematically, after that, after the boot completes, the desktop will be empty.
To fix that too, I open a terminal, look for a Nautilus process running, kill it, and then open a normal nautilus window. At that point the desktop icons show up.

summary: - Whose OS froze during boot because of compiz eating up 100% CPU forever
+ Whole OS froze during boot because of compiz eating up 100% CPU forever
Changed in compiz (Ubuntu):
status: New → Confirmed
To post a comment you must log in.