File Chooser takes about 15s to resize itself if screen display scale = 2

Bug #1737155 reported by Bob Briscoe
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
New
Undecided
Unassigned

Bug Description

After opening the File Chooser from any application, it invariably decides to resize itself, moving the right-hand edge glacially slowly, which often takes 15s before you can use the dialogue in any way.

If you resize the window horizontally by dragging the handles round the window edge, it resizes itself back to where it was, again extremely slowly, before you are allowed to use the dialogue. The only way to resize the window horizontally is to alter the column widths within the file list. Then the window resizes itself, again extremely slowly, to accommodate the new widths. You cannot resize the window vertically at all.

I have been putting up with this. But today I happened to discover that, when I changed screen display scale to <2, the FileChooser dialogue doesn't decide to resize itself. Even if you resize it yourself, it stays where you put it. And the next time you open a file-chooser it has remembered the size you set it to last time. A novelty for me - an obedient UI!

I have to use System Settings>Screen Display>Scale = 2 cos I have a HiDPI screen, which you can't read otherwise. And any scaling even slightly lower than 2 is ignored (due to another bug).

Update: I thought this was repeatable. I've suffered this bug for 2 years. Yesterday when I set display scale <2 the bug went away. And when I set display scale = 2 it came back. But now the bug has mysteriously disappeared. I can't determine what event caused it to disappear and I can't get it back. I'm reporting it anyway, given I've written all this up.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: compiz 1:0.9.11.3+14.04.20160425-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-101.124~14.04.1-generic 4.4.95
Uname: Linux 4.4.0-101-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.14.1-0ubuntu3.27
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Fri Dec 8 11:44:36 2017
DistUpgraded: 2016-10-08 14:08:08,470 DEBUG enabling apt cron job
DistroCodename: trusty
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Broadwell-U Integrated Graphics [8086:161e] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:3906]
InstallationDate: Installed on 2015-07-14 (878 days ago)
InstallationMedia: Ubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64 (20150218.1)
MachineType: LENOVO 80HE
PackageArchitecture: all
PlymouthDebug: Error: [Errno 13] Permission denied: '/var/log/plymouth-debug.log'
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-101-generic.efi.signed root=UUID=688c1e74-ecc7-438b-83fd-0d3d67e209d0 ro splash quiet
SourcePackage: compiz
UpgradeStatus: Upgraded to trusty on 2016-10-08 (425 days ago)
dmi.bios.date: 12/08/2014
dmi.bios.vendor: LENOVO
dmi.bios.version: A6CN47WW
dmi.board.asset.tag: NO Asset Tag
dmi.board.name: VIUU4
dmi.board.vendor: LENOVO
dmi.board.version: 31900058 WIN
dmi.chassis.asset.tag: NO Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Lenovo YOGA 3 Pro-1370
dmi.modalias: dmi:bvnLENOVO:bvrA6CN47WW:bd12/08/2014:svnLENOVO:pn80HE:pvrLenovoYOGA3Pro-1370:rvnLENOVO:rnVIUU4:rvr31900058WIN:cvnLENOVO:ct10:cvrLenovoYOGA3Pro-1370:
dmi.product.name: 80HE
dmi.product.version: Lenovo YOGA 3 Pro-1370
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.11.3+14.04.20160425-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.67-1ubuntu0.14.04.2
version.libgl1-mesa-dri: libgl1-mesa-dri N/A
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.xserver-xorg-core: xserver-xorg-core N/A
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A
xserver.bootTime: Fri Dec 8 09:59:02 2017
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 17226
 vendor SDC
xserver.version: 2:1.18.3-1ubuntu2.3~trusty4

Revision history for this message
Bob Briscoe (m-bob-q) wrote :
Revision history for this message
Bob Briscoe (m-bob-q) wrote :

Thinking back, the event that possibly made this bug disappear could have been...:

While reading how to submit a bug, I discovered there's a system monitor app (I had always used top from the command line).

The first time I resized the system monitor window vertically, it resized itself glacially slowly back to the size it started at. I don't recall any other window than the File Chooser doing this before. When I tried to resize the system monitor window a second time, it stayed where I put it. Since then, the bug seems to have disappeared.

Revision history for this message
Bob Briscoe (m-bob-q) wrote :

Now I've been watching more carefully, this does not just apply to the file chooser window and the system monitor. It applies to many (all?) dialogue windows with a multi-column internal layout, e.g. print.

Just now, the first time I tried to re-size the print window, it resized itself glacially slowly back to its size when I opened it. But the second time, it stayed put.

From now on, I shall log the behaviour more carefully and report back here soon.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers