compiz assert failure: *** Error in `/usr/bin/compiz': double free or corruption (!prev): 0x000056024f13b390 ***

Bug #1629774 reported by Martin Vysny on 2016-10-03
60
This bug affects 13 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Medium
Unassigned

Bug Description

No idea what happened, I just tried to enable the dual monitor setup on nvidia and this happened.

ProblemType: Crash
DistroRelease: Ubuntu 16.10
Package: compiz-core 1:0.9.13.0+16.10.20160818.2-0ubuntu2
ProcVersionSignature: Ubuntu 4.8.0-17.19-generic 4.8.0-rc7
Uname: Linux 4.8.0-17-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
.proc.driver.nvidia.gpus.0000.01.00.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0000:01:00.0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 367.44 Wed Aug 17 22:24:07 PDT 2016
 GCC version: gcc version 6.2.0 20160914 (Ubuntu 6.2.0-3ubuntu15)
.proc.driver.nvidia.warnings.fbdev:
 Your system is not currently configured to drive a VGA console
 on the primary VGA device. The NVIDIA Linux graphics driver
 requires the use of a text-mode VGA console. Use of other console
 drivers including, but not limited to, vesafb, may result in
 corruption and stability problems, and is not supported.
.tmp.unity_support_test.0:

ApportVersion: 2.20.3-0ubuntu7
Architecture: amd64
AssertionMessage: *** Error in `/usr/bin/compiz': double free or corruption (!prev): 0x000056024f13b390 ***
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity:Unity7
Date: Mon Oct 3 09:23:51 2016
DistUpgraded: 2016-09-30 20:16:12,139 ERROR got error from PostInstallScript ./xorg_fix_proprietary.py (g-exec-error-quark: Failed to execute child process "./xorg_fix_proprietary.py" (No such file or directory) (8))
DistroCodename: yakkety
DistroVariant: ubuntu
DkmsStatus:
 bbswitch, 0.8, 4.4.0-38-generic, x86_64: installed
 bbswitch, 0.8, 4.8.0-17-generic, x86_64: installed
 nvidia-367, 367.44, 4.8.0-17-generic, x86_64: installed
ExecutablePath: /usr/bin/compiz
GraphicsCard:
 NVIDIA Corporation GM107GLM [Quadro M1000M] [10de:13b1] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: Lenovo GM107GLM [Quadro M1000M] [17aa:2230]
InstallationDate: Installed on 2016-09-05 (27 days ago)
InstallationMedia: Ubuntu-Server 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
MachineType: LENOVO 20EN0005MS
ProcCmdline: /usr/bin/compiz
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.8.0-17-generic root=/dev/mapper/vg0-lv1--root ro
Signal: 6
SourcePackage: compiz
StacktraceTop:
 __libc_message (do_abort=do_abort@entry=2, fmt=fmt@entry=0x7f3650c54358 "*** Error in `%s': %s: 0x%s ***\n") at ../sysdeps/posix/libc_fatal.c:175
 malloc_printerr (ar_ptr=<optimized out>, ptr=<optimized out>, str=0x7f3650c54488 "double free or corruption (!prev)", action=3) at malloc.c:5046
 _int_free (av=<optimized out>, p=<optimized out>, have_lock=<optimized out>) at malloc.c:3902
 __GI___libc_free (mem=<optimized out>) at malloc.c:2982
 XDestroyRegion () from /usr/lib/x86_64-linux-gnu/libX11.so.6
Title: compiz assert failure: *** Error in `/usr/bin/compiz': double free or corruption (!prev): 0x000056024f13b390 ***
UpgradeStatus: Upgraded to yakkety on 2016-09-30 (2 days ago)
UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
dmi.bios.date: 03/08/2016
dmi.bios.vendor: LENOVO
dmi.bios.version: N1EET47W (1.21 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20EN0005MS
dmi.board.vendor: LENOVO
dmi.board.version: SDK0J40705 WIN
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: None
dmi.modalias: dmi:bvnLENOVO:bvrN1EET47W(1.21):bd03/08/2016:svnLENOVO:pn20EN0005MS:pvrThinkPadP50:rvnLENOVO:rn20EN0005MS:rvrSDK0J40705WIN:cvnLENOVO:ct10:cvrNone:
dmi.product.name: 20EN0005MS
dmi.product.version: ThinkPad P50
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.13.0+16.10.20160818.2-0ubuntu2
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.70-1
version.libgl1-mesa-dri: libgl1-mesa-dri 12.0.3-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 12.0.3-1ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.18.4-1ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.1-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160706-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-2
xserver.bootTime: Mon Oct 3 09:26:30 2016
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.18.4-1ubuntu6

Martin Vysny (vyzivus) wrote :

StacktraceTop:
 __libc_message (do_abort=do_abort@entry=2, fmt=fmt@entry=0x7f3650c54358 "*** Error in `%s': %s: 0x%s ***\n") at ../sysdeps/posix/libc_fatal.c:175
 malloc_printerr (ar_ptr=<optimized out>, ptr=<optimized out>, str=0x7f3650c54488 "double free or corruption (!prev)", action=3) at malloc.c:5046
 _int_free (av=<optimized out>, p=<optimized out>, have_lock=<optimized out>) at malloc.c:3902
 __GI___libc_free (mem=<optimized out>) at malloc.c:2982
 XDestroyRegion (r=0x56024f13b360) at ../../src/Region.c:287

Changed in compiz (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Bryan Quigley (bryanquigley) wrote :

I've recently got the same error, and reviewed your data and it looks clean of any private data (lots of system info of course as expected) so I'm making this bug public.

information type: Private → Public
Damon Lynch (dlynch3) wrote :

At times (it's not constant) I experience serious problems with Compiz on my desktop machine with an Nvidia GTX 1070. Problems including Compiz crashing, or mouse clicks not registering.

dino99 (9d9) on 2017-03-09
tags: added: zesty
dino99 (9d9) wrote :

Get such crash with each cold boot on ZZ loged with unity7

dino99 (9d9) wrote :

nv117 crash

Mauro (brincam) wrote :

i've got this compiz crush bug just logged in, browsing unity desktop..
i've a dell precision m3800 with extra gpu nvidia Quadro K1100M.

dino99 (9d9) wrote :

Zesty is stable now; no more crash.

tags: removed: zesty
To post a comment you must log in.