compiz crashed with SIGSEGV in ccsObjectGetInterface_()

Bug #1599900 reported by Marc Deslauriers on 2016-07-07
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Medium
Unassigned

Bug Description

Happens after updating my yakkety vm today.

ProblemType: Crash
DistroRelease: Ubuntu 16.10
Package: compiz-core 1:0.9.13.0+16.10.20160705-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-30.49-generic 4.4.13
Uname: Linux 4.4.0-30-generic x86_64
.tmp.unity_support_test.1:

ApportVersion: 2.20.2-0ubuntu1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Thu Jul 7 11:19:19 2016
DistUpgraded: Fresh install
DistroCodename: yakkety
DistroVariant: ubuntu
ExecutablePath: /usr/bin/compiz
ExecutableTimestamp: 1467681130
GraphicsCard:
 VMware SVGA II Adapter [15ad:0405] (prog-if 00 [VGA controller])
   Subsystem: VMware SVGA II Adapter [15ad:0405]
InstallationDate: Installed on 2016-06-10 (27 days ago)
InstallationMedia: Ubuntu 16.10 "Yakkety Yak" - Alpha amd64 (20160610)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: QEMU Standard PC (i440FX + PIIX, 1996)
ProcCmdline: compiz
ProcCwd: /home/mdeslaur
ProcEnviron:
 PATH=(custom, no user)
 SHELL=/bin/bash
 LANG=en_CA.UTF-8
 LANGUAGE=en_CA
 XDG_RUNTIME_DIR=<set>
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-30-generic root=UUID=9f8b27fc-52af-4d15-9cb6-a634ec6ecdf0 ro quiet splash
Renderer: Software
SegvAnalysis:
 Segfault happened at: 0x7fe1c250ad64 <ccsObjectGetInterface_+4>: mov 0x18(%rdi),%ecx
 PC (0x7fe1c250ad64) ok
 source "0x18(%rdi)" (0x00000018) not located in a known VMA region (needed readable region)!
 destination "%ecx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: compiz
Title: compiz crashed with SIGSEGV in ccsObjectGetInterface_()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 04/01/2014
dmi.bios.vendor: SeaBIOS
dmi.bios.version: Ubuntu-1.8.2-1ubuntu1
dmi.chassis.type: 1
dmi.chassis.vendor: QEMU
dmi.chassis.version: pc-i440fx-wily
dmi.modalias: dmi:bvnSeaBIOS:bvrUbuntu-1.8.2-1ubuntu1:bd04/01/2014:svnQEMU:pnStandardPC(i440FX+PIIX,1996):pvrpc-i440fx-wily:cvnQEMU:ct1:cvrpc-i440fx-wily:
dmi.product.name: Standard PC (i440FX + PIIX, 1996)
dmi.product.version: pc-i440fx-wily
dmi.sys.vendor: QEMU
version.compiz: compiz 1:0.9.13.0+16.10.20160705-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.68-1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.2.1-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.2.1-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.18.3-1ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160706-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-2
xserver.bootTime: Thu Jul 7 11:18:49 2016
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input AT Translated Set 2 keyboard KEYBOARD, id 7
 input VirtualPS/2 VMware VMMouse MOUSE, id 8
 input VirtualPS/2 VMware VMMouse TOUCHSCREEN, id 9
xserver.errors:
 open /dev/dri/card0: No such file or directory
 open /dev/fb0: No such file or directory
 vmware(0): Failed to open drm.
 AIGLX: reverting to software rendering
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.18.3-1ubuntu7

Related branches

Marc Deslauriers (mdeslaur) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed

StacktraceTop:
 ccsObjectGetInterface_ () from /tmp/apport_sandbox_6cc10n/usr/lib/x86_64-linux-gnu/libcompizconfig.so.0
 ccsGSettingsWrapperGetPath () from /tmp/apport_sandbox_6cc10n/usr/lib/x86_64-linux-gnu/libcompizconfig_gsettings_backend.so
 updateSettingWithGSettingsKeyName () from /tmp/apport_sandbox_6cc10n/usr/lib/x86_64-linux-gnu/libcompizconfig_gsettings_backend.so
 ccsGSettingsValueChanged () from /tmp/apport_sandbox_6cc10n/usr/lib/x86_64-linux-gnu/libcompizconfig_gsettings_backend.so
 g_cclosure_marshal_VOID__STRINGv () from /tmp/apport_sandbox_6cc10n/usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0

Changed in compiz (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.13.0+16.10.20160714.2-0ubuntu1

---------------
compiz (1:0.9.13.0+16.10.20160714.2-0ubuntu1) yakkety; urgency=medium

  [ Eleni Maria Stea ]
  * Added a new option in show desktop plugin that skips the fade
    animation: useful when performance is more important than eyecandy.

  [ Marco Trevisan (Treviño) ]
  * ccsGSettingsBackend: don't try to update setting if wrapper is not
    found (LP: #1599900)
  * migration scripts: remove unsupported plugins for all the unity
    profiles

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Thu, 14 Jul 2016 15:52:00 +0000

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
Jason Gerard DeRose (jderose) wrote :

FYI, I seem to be hitting this same bug (under qemu) with the xenial daily ISO as well (which have xenial-proposed enabled by default).

Will this be fixed in Xenial also?

The daily image of Yakkety doesn't work for me in any VM.

I've tried today's LiveCD image in qemu, VMware and VirtualBox none of them would get to show Unity. They end up with black screen.

I can't tell if it is because of this bug or something else. Is this really fixed.

To post a comment you must log in.