gtk-window-decorator do not blur properly, window blur does not desaturate

Bug #158376 reported by Tessa on 2007-10-29
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: compiz

I'm running compiz on gutsy, amd64, with nvidia binary drivers. For some reason, the blur plugin doesn't always do what you'd expect:

- it correctly blurs my transparent terminal
- it correctly blurs based on focus

however, it does not:

- blur transparent window decorations based on transparency
- desaturate blurring based on ccms preference

Related branches

Tessa (unit3) wrote :

This screenshot demonstrating problems I'm seeing. Even though the plugin is only set to 50% saturation, you can see that icons through the terminal on the left, while blurred, are not desaturated.

As well, you can see that the icon visible through the window title bar on the right is very clear, no blurring is being applied even though it is a transparent section that should have blurring, and even though the window that is transparent is being correctly focus blurred.

Iulian Udrea (iulian) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release?

Thank you.

Changed in compiz:
status: New → Incomplete
Tessa (unit3) wrote :

I can verify this is still a problem on Gutsy. When I reduce the transparency of a window (alt-scrollwheel), the window contents correctly blur things underneath, but the window decorations show things crystal clear.

I'll try to test it with the latest Hardy alpha CD, but since the CD doesn't enable the NVidia binary drivers by default, I don't know how much luck I'm going to have.

Tessa (unit3) wrote :

Can't even get the binary drivers wizard thing to show up on the latest hardy alpha CD (alpha4) so I don't think I can test hardy at this moment.

Also, I discovered that if you enable decoration blurring using the emerald decoration manager instead of the default gnome one, it works fine. So decorations must be handled by a slightly different rendering chain than other transparency functions in compiz, and the decoration manager needs to explicitly tell it to blur the transparent portions.

This likely means that there won't be a "fix" for this issue in the gnome decoration manager anytime soon, but that users can use the emerald decoration manager to get this effect, which is a reasonable fix for the time being, IMO.

Changed in compiz:
importance: Undecided → Wishlist
Iulian Udrea (iulian) on 2008-02-24
Changed in compiz:
status: Incomplete → Confirmed
Tessa (unit3) wrote :

Interestingly, this all (including the desaturation!) seems to be working on Gutsy at the moment using the latest Hardy kernel, nvidia-glx-new package, and the emerald window decorator (instead of the default gnome-y one). So I think by hardy it'll either be fixed, or we can at least narrow it down to the gnome window decorator.

Christoph Langner (chrissss) wrote :

I can confirm this problem for hardy beta1.

Tessa (unit3) wrote :

Can you confirm using the Emerald decoration manager, though? And if so, what video card (and drivers) are you using?

Christopher Blay (blayde) wrote :

I'm confirming for Hardy final... I'd do Emerald but I like using the same decorator as Metacity

Here's some stuff from my glxinfo

OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce Go 6150/PCI/SSE2
OpenGL version string: 2.1.2 NVIDIA 169.12

Tessa (unit3) wrote :

Since problem seems to only be in the compiz-decorator, I'm altering the bug to reflect that binary package.

Tessa (unit3) wrote :

Confirming for Intrepid beta on amd64.

Here is a possible Workaround:
(found at http://wiki.compiz-fusion.org/Decorators/GTKWindowDecorator )

Start CompizConfigSettingsManager, activate BlurWindows,
Open gconf-editor, go to /apps/gwd/blur_type and set ist to "all"

screenshot attached.

Addition: you can set the "Blur Filter" Type in ccsm to "Gaussian" for better effects.

Tessa (unit3) wrote :

Thanks! I can confirm the problem still exists on Intrepid, but that tankdriver's gconf edit does fix the problem (at least for me). It looks like the "Blur Windows" plugin doesn't set this gconf key. I think to get expected behaviour, that plugin should set the key to "all" when it's enabled, and to "none" when it's disabled.

I have noticed, that the ccsm did not save the setting "Blur Windows" on my computer.
After rebooting and/or set/unset the desktop effects, the checkbox "Blur Windows" is empty, and I have to check it again.

Is there any benefit adding the package "compizconfig-settings-manager" to this bug?

Tessa (unit3) wrote :

tank: yeah, given this recent info, it may be more of an issue with the ccsm than with the decorator itself, so that makes sense to me.

summary: - compiz blur plugin doesn't blur correctly all the time
+ gtk-window-decorator do not blur properly, window blur does not
+ desaturate
Changed in compiz (Ubuntu):
importance: Wishlist → Low
status: Confirmed → Triaged
fubarbundy (launchpad-mailtic) wrote :

Actually, this is controlled by a gconf key:

http://wiki.compiz-fusion.org/Decorators/GTKWindowDecorator

Switching /apps/gwd/blur_type to all or titlebar results in transparency-based blurring, confirmed on Karmic Alpha 6 with Intel 4500MHD graphics.

fubarbundy (launchpad-mailtic) wrote :

Oops, only fixes blur issue, sorry, no fix for desaturation!

Travis Watkins (amaranth) wrote :

Compiz intentionally does not modify the decoration for some effects so it is still readable.

Changed in compiz (Ubuntu):
importance: Low → Wishlist
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.8.3+git20091005-0ubuntu5

---------------
compiz (1:0.8.3+git20091005-0ubuntu5) karmic; urgency=low

  * New snapshot from upstream stable git:
     - compiz.real crashed with SIGSEGV in blurDrawWindow()
       (LP: #353236)
     - Windows disappear if resolution is changed to something smaller
       than window size (LP: #414134)
     - compiz.real crashed with SIGSEGV in handleEvent() (LP: #430518)
     - Windows that span screen width or height cannot be resized
       in that dimension (LP: #137134)
     - Reducing number of workspaces leaves windows inaccessible
       (LP: #189259)
     - "Snap Inverted" in Wobbly Windows compiz plugin broken
       (LP: #366822)
     - Problem when resizing and the Panels
       (LP: #408030)
  * debian/control:
    - make compiz package depend on compiz-gnome | compiz-kde (LP: #172385)
  * debian/patches/015_draw_dock_shadows_on_desktop.patch:
    - fix clock/calendar shadow not going away (LP: #428783)
      thanks to Erkin Bahceci
  * debian/patches/029_default_options:
    - add a focus prevention match to allow polkit windows to steal focus
      otherwise they never get focus (LP: #436852)
  * debian/compiz-gnome.gconf-defaults:
    - change /apps/gwd/blur_type to all since it only does anything if blur
      is enabled and is usually what is wanted (LP: #158376)
    - turn constrain_y back on (LP: #82654)
  * debian/rules:
    - add commands plugin to default active_plugins (LP: #355018)

 -- Travis Watkins <email address hidden> Mon, 05 Oct 2009 15:42:00 +0200

Changed in compiz (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers