High load (compiz or xorg) and black screen instead of suspend - xenial 16.04

Bug #1574142 reported by Kamil on 2016-04-24
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
High
Unassigned

Bug Description

Ubuntu 16.04
Compiz 1:0.9.12.2+16.04.20160415-0ubuntu1
Xorg 1:7.7+13ubuntu3

Using Dell E6420

Problem is when I close a lid or manually try to suspend Ubuntu laptop is 100% CPU load with black screen. Its still working cause keyboard is highlighted and I can access by SSH.

Always first try to suspend is ok, but next one makes issue as i subscribed. Its doesn’t matters if I upgrade from 15.10 or just install fresh 16.04. Tried default 4.4.0-21-generic and 4.5.1 kernels.

As I said I can access by SSH so pls give me some tips what do you need, I will try to check and give you a report. As attachment is output from lspci -vvnn command..

btw I asked on Askubuntu what should I do with this problem when I discovered it on 16.04 beta1. One guy has same issue as me, he reported bug but I cant find it now.

Thx for help and I hope we can solve this problem. I'm waiting for further instructions :)

PS. sorry for my english :)

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: compiz 1:0.9.12.2+16.04.20160415-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic x86_64
.tmp.unity_support_test.0:

ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Sun Apr 24 03:20:53 2016
DistUpgraded: 2016-04-23 14:14:46,504 DEBUG icon theme changed, re-reading
DistroCodename: xenial
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Dell 2nd Generation Core Processor Family Integrated Graphics Controller [1028:0493]
GsettingsChanges:
 b'org.compiz.core' b'outputs' b"['1600x900+0+0']"
 b'org.compiz.core' b'hsize' b'2'
 b'org.compiz.core' b'active-plugins' b"['core', 'composite', 'opengl', 'vpswitch', 'resize', 'wall', 'imgpng', 'compiztoolbox', 'copytex', 'grid', 'commands', 'unitymtgrabhandles', 'regex', 'move', 'mousepoll', 'snap', 'place', 'animation', 'session', 'expo', 'fade', 'scale', 'ezoom', 'workarounds', 'unityshell']"
 b'org.compiz.core' b'vsize' b'2'
InstallationDate: Installed on 2016-04-06 (18 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
MachineType: Dell Inc. Latitude E6420
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic root=UUID=78e16f86-087c-4f77-8109-b8357d1bc709 ro quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: Upgraded to xenial on 2016-04-23 (0 days ago)
dmi.bios.date: 11/14/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A21
dmi.board.name: 0P6K8J
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA21:bd11/14/2013:svnDellInc.:pnLatitudeE6420:pvr01:rvnDellInc.:rn0P6K8J:rvrA00:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E6420
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.12.2+16.04.20160415-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.67-1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.2.0-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.2.0-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.18.3-1ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2
xserver.bootTime: Sun Apr 24 02:57:20 2016
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 12606
 vendor AUO
xserver.version: 2:1.18.3-1ubuntu2

Kamil (bonusso3) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Kamil (bonusso3) wrote :

Suspension works on linux kernels:
4.4.8-040408.201604200335
4.5.1-040501.201604121331
4.6.0-040600rc3.201604120934

If someone is impatient thats a walk-around for now ;)

Changed in compiz (Ubuntu):
importance: Undecided → High
To post a comment you must log in.