Fullscreen applications disapear from window list on workspace switch

Bug #156542 reported by Aigars Mahinovs on 2007-10-24
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: compiz

If compiz is enabled on a gutsy installation (upgraded from feisty) and a wine application is run in fullscreen mode (such as WoW), then the window of this application disappears from the window list when the workspace is switched using the Ctrl+Alt+Right/Left keyboard shortcut. The application is still running, according to top, but getting back to it is impossible as it does not show up on the workspace that it was on (or any other workspace) and does not show up in the global window list.

Could not reproduce on native OpenGL games as they apparently do not allow switching out of them (either with Alt-Tab or Ctrl-Alt-Right/Left).

Switching fullscreen workarounds and unredirect fulscreen windows options in compiz advanced preferences has no effect.

I have a similar bug - when switching a full-screen wine application to another window its still shown but when trying to switch it back it becomes black - it is needed to click the mouse button to get it working again. I have no problem with changing workspaces.

Federico Belvisi (armalite) wrote :

Same problem for me, using Wine + WoW.

Iulian Udrea (iulian) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you?

Thank you.

Changed in compiz:
assignee: nobody → iulian
status: New → Incomplete
Federico Belvisi (armalite) wrote :

Yes, using Gutsy I still have this behaviour. I'm running World Of Warcraft on Wine using OpenGL and Nvidia closed drivers. If i switch via alt+tab or via ctrl+f1..f4 (workspace shortcuts) the application disappear as reported above. Application is running and i can even listen the sounds but i'm unable to return in the application, because it is missing from any window list.

I haven't tried in Hardy, I'll hope to test it maybe in the next week.

Iulian Udrea (iulian) on 2008-02-15
Changed in compiz:
assignee: iulian → nobody
importance: Undecided → Low
status: Incomplete → New
Basilio Kublik (sourcercito) wrote :

Hi there
do you have the chance to test this under Hardy?

Changed in compiz:
status: New → Incomplete
Travis Watkins (amaranth) wrote :

I cannot reproduce with hardy, hopefully you'll have the same experience.

Federico Belvisi (armalite) wrote :

I just tried on hardy. Apart the wine segfault bug (resolved using 0.9.55 .deb from winehq repo, the same i use in gutsy), I tried with "allow the window manager to control the windows" unchecked in winecfg. With that option turned on, i had for some unknown (to me) reasons the gnome panel on top. With that option unchecked, i can't leave the game with alt+tab or ctrl+f2 to change workspace (i set up the correct hotkeys which are not enabled on default install).

I am quite sure I have enabled Alternative Plugin in compizconfig settings manager, to let full screen support. I have to investigate a little on panels appearing on top when "allow the window manager to control the windows" in winecfg is checked.

Travis Watkins (amaranth) wrote :

But do you still get this bug?

Federico Belvisi (armalite) wrote :

Short answer: i don't know.

Long answer: that's because i changed an option in winecfg that keeps the opengl application on top no matter alt+tab or ctrl+f2 that i can't tell you exactly if i get this bug or not. I am dual booting and a little busy so I think that I'll reboot this evening or tomorrow and i'll hope to fix this, so i will let you know.

Federico Belvisi (armalite) wrote :

Ok, I made another test: the problem i was referring to in my latest comment is bug #102807 (wine app behind panels). It has no solution, so i simply put "allow the window manager to control the windows" checked on winecfg just to have an equal setup as in gutsy and proceeded.

The bug (this bug, #156542) is still here in hardy: i changed a couple of times workspace with hotkeys (ctrl+f1..4) and wine app desappeared from window list. I had to kill -9 to stop the game.

I'm using hardy up-to-date with wine 0.9.56 from winehq.

Basilio Kublik (sourcercito) wrote :

Hi there
could you please try to reproduce this with the latest updates in hardy and report back.

Thanks

Pfanne (pfannenwender) wrote :

Hi
found a pretty simple workaround for this problem...
just make wine use a virtuall desktop with exactly the same size as your normal desktop...
maybe not the prettiest way to solve this, but this way you can use fullscreenwine applications!

falstaff (falstaff) wrote :

Hello,
I have a similar problem using Pokerstars. When I play a game I do often other things beside (like writting comments to bugs ;-)). The window pops up when its my turn to play... So I do something, and suddenly pokerstars pops up, and I do my choise and continuing working... When I work on the second desktop, the window disappears! I have to restart pokerstars, I cant find the window anywhere...

Steps to reproduce:
1. Download Pokerstars Client form www.pokerstars.com
2. Create an account and login
3. Play a game (i.e. Sit & Go, Play Money)
4. Wait until the game starts, select another window on the same desktop and wait. You will see, the window gets focused when its your turn...
5. Do your turn, and change to the second desktop... Wait a while. No Pokerstars window gets focused on the second desktop! When you change to the first desktop, there is no Table window...

Thanks

falstaff (falstaff) wrote :

And yes, working with hardy and latest updates....

Estarriol (estarriol87) wrote :

Hi!

I had the same problem while running Warcraft III on fullscreen mode. I've found an easy workaround using winecfg and ccsm:

In winecfg (Applications -> Wine -> Configure Wine) go to Graphics tab
In Windows Settings check Emulate a virtual desktop and input your screen resolution (or desired resolution).

In ccsm (System -> Preferences -> Advanced Desktop Effects Settings) go to "Window Decoration"
Modify "Decoration Windows" field: On default it is set to "(any)" (without quotation marks). Set it to "(any) & !(class=Wine)"
Modify "Shadow Windows" field in the same way.

I'm using Ubuntu 8.04, and it looks just as if I was using wine fullscreen mode :-)

Estarriol (estarriol87) wrote :

Just an update to what I've stated above:
You need to input a screen resolution you're using, not a desired one, unless you want to play in a window.
I usually set it only to certain applications to avoid making a new fullscreen desktop for winecfg.
I haven't investigated it yet but I had some problems with initialising some Wine apps while using xserver-xgl.

Hope that helps.

Aigars Mahinovs (aigarius) wrote :

With hardy, all updates and wine from hardy, the bug is still there. It may take a few times of changing the desktops or switching between apps, but the fullscreen Wine apps do still disappear from the window list.

Jayson Rowe (jayson.rowe) wrote :

Since it's been a very long time since any additional info was added to this bug, I'm just checking to see if this is still an issue, and find out what additional work should be done on this bug.

Nigel Ayen (nigel-ayen) wrote :

I have the same problem and its consistent. I run Lotus Notes 8.01 under Wine (1.0.1-0Ubuntu2) and it works fine if I don't switch desktops. My setup is Ubuntu Intrepid (with all current updates), ATI FGLRX graphics driver, Compiz and AWN Manager. I have a terminal running in the background so I know the application is still running but the Lotus Notes icon has disappeared from AWN and the Lotus Notes application has disappeared from the desktop. I usually have to kill the processes and restart the application. Any ideas?

hardke01 (hardke01) wrote :

I am also receiving this issue. Enabled Compiz and when switching between desktops i lose my full screen lotus notes application. Intel 945GM card using hardware acceleration, all effects and native windows appear to be working fine. just full screen apps in wine that go missing. The process is still running but the application cannot be found or focused on. Tried the fix a couple of posts above without success. Still the same missing window. Any suggestions/help appreciated.

Thanks

summary: - Fullscreen wine applications disapear from window list on workspace
- switch
+ Fullscreen applications disapear from window list on workspace switch
Changed in compiz (Ubuntu):
status: Incomplete → Triaged
pLatonet (wout-vdd) wrote :

Good solution Estarriol, the only problem than is that the tables don't popup. You don't know when it's your turn if you are on a other workspace..

Scott Carpenter (ressb820) wrote :

Using Ubuntu 9.10, all updates applied, running Lotus Notes 6.5.6 in WINE, this is still a problem, both running as a window, and running full screen. If it's running in a window, it disappears immediately on switching the desktop, if it's running full screen, it takes several flips back and forth to disappear, but it always disappears.

I know this is triaged, but I'm blazing the trail at my work for allowing Ubuntu on the network, and this kills 80% of my argument.

AbuMaia (scarabdrowner) wrote :

I just did a fresh install of 10.10, and I am now seeing this bug. It did not happen to me in 10.04 however. I have 5 workplaces, I set boincview.exe in the 5th workplace, then switch to another workplace, and boincview.exe disappears, yet the program icon remains in the task bar to indicate it's still running. Double-clicking the icon will bring the window back in whichever workplace I'm in at the time, until I switch workplaces again, then it disappears again.

Torsten Bronger (bronger) wrote :

I don't see this bug with Emacs or gnome-terminal in fullscreen mode, however, I cannot switch to the VirtualBox with Alt-Tab. Since Unity is now rolled out, this bug is getting more significant in my opinion.

Kevin (kupiakos) wrote :

I can confirm that this bug occurs with fullscreen MSOffice Applications running through Office. However, for me, it doesn't disappear from the window list - it just disappears from the preview that occurs while using Super-S or Ctrl-Alt-Left/Right/Down/Up. It does not occur if I unmaximize the Wine window.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments