compiz segfaulting on Parallels VM (MBP)

Bug #1546838 reported by Alexander List on 2016-02-18
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
High
Unassigned

Bug Description

compiz[2823]: segfault at 71 ip 00007f3fcee22173 sp 00007ffd67b0e8f0 error 4 in libprlcompiz_0_9_12_2.so[7f3fcee1b000+b000]

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: compiz 1:0.9.12.2+15.10.20151202-0ubuntu1
ProcVersionSignature: Ubuntu 4.2.0-27.32-generic 4.2.8-ckt1
Uname: Linux 4.2.0-27-generic x86_64
NonfreeKernelModules: prl_fs_freeze prl_fs prl_eth prl_tg
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
Date: Thu Feb 18 10:09:40 2016
DistUpgraded: Fresh install
DistroCodename: wily
DistroVariant: ubuntu
DkmsStatus: parallels-tools, 11.1.2.32408, 4.2.0-27-generic, x86_64: installed
GraphicsCard:
 Parallels, Inc. Accelerated Virtual Video Adapter [1ab8:4005] (prog-if 00 [VGA controller])
   Subsystem: Parallels, Inc. Device [1ab8:0400]
InstallationDate: Installed on 2015-11-07 (102 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
MachineType: Parallels Software International Inc. Parallels Virtual Platform
PackageArchitecture: all
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-27-generic root=UUID=a98c2de4-95b3-40f6-b269-d6c02f098915 ro quiet splash vt.handoff=7
SourcePackage: compiz
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/24/2015
dmi.bios.vendor: Parallels Software International Inc.
dmi.bios.version: 11.1.2 (32408)
dmi.board.name: Parallels Virtual Platform
dmi.board.vendor: Parallels Software International Inc.
dmi.board.version: None
dmi.chassis.type: 10
dmi.chassis.vendor: Parallels Software International Inc.
dmi.modalias: dmi:bvnParallelsSoftwareInternationalInc.:bvr11.1.2(32408):bd12/24/2015:svnParallelsSoftwareInternationalInc.:pnParallelsVirtualPlatform:pvrNone:rvnParallelsSoftwareInternationalInc.:rnParallelsVirtualPlatform:rvrNone:cvnParallelsSoftwareInternationalInc.:ct10:cvr:
dmi.product.name: Parallels Virtual Platform
dmi.product.version: None
dmi.sys.vendor: Parallels Software International Inc.
version.compiz: compiz 1:0.9.12.2+15.10.20151202-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.64-1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.0.2-1ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.0.2-1ubuntu4
version.xserver-xorg-core: xserver-xorg-core 2:1.17.2-1ubuntu9.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.5.0+git20150819-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20150808-0ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu3
xserver.bootTime: Thu Feb 18 10:00:31 2016
xserver.configfile: None
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Sleep Button KEYBOARD, id 7
 input AT Translated Set 2 keyboard KEYBOARD, id 8
 input ImExPS/2 Generic Explorer Mouse MOUSE, id 9
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.17.2-1ubuntu9.1
xserver.video_driver: prlvideo

Alexander List (alexlist) wrote :
summary: - compiz segfaulting
+ compiz segfaulting on Parallels VM (MBP)
tags: added: compiz-0.9
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in compiz (Ubuntu):
importance: Undecided → High

Any ideas of (partial) workarounds for this, such as disabling specific plugins or features to allow me to keep using the VM?

+1, compiz goes nuts on Parallel Tools installation.

For anyone else looking for a workaround:

From a thread on the Parallels forums, it looks like just removing the Parallels Tools' version of compiz is a partial workaround (it breaks coherence, but is otherwise seemingly usable)

https://forum.parallels.com/threads/ubuntu-15-10-no-side-and-menubar.331569/#post-784958

in short: sudo rm /usr/lib/compiz/libprlcompiz_0_*

Also this seems to indicate its an issue with Parallels' compiz, rather than compiz itself, so I don't know if this technically applies to the compiz package, or whether there's a prlcompiz package instead it should apply to?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers