Pointer disappeared or is a large X after Compiz update.

Bug #1544814 reported by Lisa on 2016-02-12
42
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
ubuntu-mate
High
Martin Wimpress
compiz (Ubuntu)
Critical
Unassigned
Nominated for Wily by Alberto Salvia Novella

Bug Description

I ran updates from the Software Updater and afterwards could not see my pointer, however I could hover over icons in my plank and see that the pointer was working, just not visible. I opened a browser and pointer was again visible, however it is a black "X" rather than normal red glass pointer, except when using app or browsing web.

Affects package/distro: ubuntu-mate

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: compiz 1:0.9.12.2+15.10.20151202-0ubuntu1
ProcVersionSignature: Ubuntu 4.2.0-27.32-generic 4.2.8-ckt1
Uname: Linux 4.2.0-27-generic x86_64
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CurrentDesktop: MATE
Date: Thu Feb 11 21:30:17 2016
InstallationDate: Installed on 2016-01-19 (23 days ago)
InstallationMedia: Ubuntu-MATE 15.10 "Wily Werewolf" - Release amd64 (20151021)
PackageArchitecture: all
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)

Lisa (lisallewis88) wrote :
tags: added: compiz-0.9
Lisa (lisallewis88) wrote :

Correction "from the Software Updater not Software Center

Luke Horwell (lah7) wrote :

As discussed in the Ubuntu MATE Community:
https://ubuntu-mate.community/t/mouse-pointer-misbehaving-after-update/3761/24

The update for Compiz to fix bug #1359211 has a regression where the cursor has been affected for some users. The issue is not present under Marco.

Before: 0.9.12.2+15.10.20151015-0ubuntu1
After: 0.9.12.2+15.10.20151202-0ubuntu1

This update didn't affect my system - where Compiz runs under an NVIDIA GTX 960 with proprietary drivers.

summary: - Pointer disappeared from view after Compiz update, however able to use
- with plank to open browser, then pointer was visable. Large X in place
- of cursor except with using application or browser. Affects
- package/distro: ubuntu-mate
+ Pointer disappeared or is a large X after Compiz update.
Luke Horwell (lah7) on 2016-02-12
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed

Are you getting this also in xenial?

Ah... Wait, I suspect this might be because gnome-settings-daemon (or whatever you use in mate) needs this fix to be backported as well lp:~seb128/unity-settings-daemon/xsettings-fixes-backport/+merge/273710?

Luke Horwell (lah7) wrote :

I'm using Xenial too, but haven't experienced this problem.

You may be right, Ubuntu MATE uses mate-settings-daemon.

Luke Horwell (lah7) wrote :

Whoops, sorry, got mixed up, I mean I haven't experienced this on Wily 15.10.

One user reported on the thread there were no problems on Xenial 16.04 (Alpha) though.

Martin Wimpress (flexiondotorg) wrote :

This upstream commit should solve the issue.

  * https://github.com/XRevan86/mate-settings-daemon/commit/779231b3f81a25c59561ef78a4d96495c68f2a3f

I'll test this and make a patched package in a PPA.

Changed in ubuntu-mate:
status: New → Triaged
Changed in compiz (Ubuntu):
importance: Undecided → Critical
Changed in compiz:
status: New → Confirmed
Changed in compiz (Ubuntu):
status: Confirmed → Triaged

This bug is not present in 16.04 Beta1 (Ubuntu Mate)

Changed in ubuntu-mate:
assignee: nobody → Martin Wimpress (flexiondotorg)
importance: Undecided → High
Changed in ubuntu-mate:
status: Triaged → Fix Committed
Changed in ubuntu-mate:
status: Fix Committed → Fix Released

Bug #1540157 can be a duplicate.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers