Shift switcher (Super-Tab) shows wrong behaviour on 'escape'

Bug #154371 reported by Philipp Kohlbecher on 2007-10-19
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: compiz

The compiz shift switcher does not behave correctly when I press the 'escape' key.

Steps to reproduce:
1. Press Super-Tab to activate the application switcher. Hold down the Super key.
2. Press Escape.

Expected result:
The application switcher should disappear, the window that was focused before Super-Tab was pressed should retain focus. (This is what metacity does.)

Actual result:
The application switcher disappears (as expected), but the window that was selected at the time Escape was pressed gets the focus.

This was produced with the gutsy live CD on a Samsung X20 XVM 1730 V laptop (Intel 915 graphics controller). "Extra" desktop effects were enabled.

Basilio Kublik (sourcercito) wrote :

Hi Phillipp
I follow your steps, and when i press Escape, the window that have the focus inside the switcher (when super key is still pressed), doesn't get the focus unless i loose the button before the switcher finish closing.
Could you re-check and just as an experiment could you please leave the Super key pressed for just one second more.

btw i also have the Extra effects enabled.

Changed in compiz:
status: New → Incomplete
positivek (anonyhole) wrote :

I believe this bug is very much related to or a result of bug 154369.

================
First bug:

1. Start one Terminal (or other window).
2. Maximize it.
3. Start another Terminal (or other window).
4. Make sure the second one is not maximized, but hovers somehow over
the first one.
5. Make sure maximized window is on top *and* that it has focus (see titlebar).
6. Begin holding down <Super> key.
7. Press <Tab> once, so the smaller window is selected within the
"Shift Switcher" tool.
8. Press <Escape>.
9. Continue holding <Super> key down until the windows have *completely* set into place and the shift switcher is all done.
10. Now, release <Super> key.
11. BUG: Smaller window is still floating on top, but it does not have focus.

Expected behavior: See original bug report. In this case, maximized window should be on top, with the focus, and with no change in the order of the windows'
z-order.

Actual behavior: Last-selected window in Shift Switcher is on the top in z-order (unexpected), but the focus remains on original window (as expected).

================
Alternate bug:

Steps 1-8 above are the same.
9. Release the <Super> key *after* having pressed <Escape> (above, in step 8).
10. BUG: Smaller window is on top, with focus.

Expected behavior: See original bug report. In this case, maximized window should be on top, with the focus, and with no change in the order of the windows'
z-order.

Actual behavior: Last-selected window in Shift Switcher is on the top in z-order (unexpected), and this window also has focus (also unexpected).

positivek (anonyhole) wrote :

This bug is still evident in 7.10. I added a comment in bug 154369. I want to mark this bug "confirmed"?

Some of my system info:
[fglrx] module loaded - xorg-driver-fglrx 7.1.0-8.37.6+2.6.22.4-14.10
Linux machname 2.6.22-14-generic #1 SMP Fri Feb 1 04:59:50 UTC 2008 i686 GNU/Linux
Ubuntu 7.10 Gutsy Gibbon
"Desktop Effects" enabled (Compiz)
xserver-xgl 1:1.1.99.1~git20070727-0ubuntu3
Gnome desktop

ii compiz 1:0.6.0+git20071008-0ubuntu1.1 OpenGL window and compositing manager
ii compiz-core 1:0.6.0+git20071008-0ubuntu1.1 OpenGL window and compositing manager
ii compiz-fusion-plugins-extra 0.5.2+git20070928-0ubuntu1 Collection of extra plugins from OpenComposi
ii compiz-fusion-plugins-main 0.5.2+git20070928-0ubuntu2 Collection of plugins from OpenCompositing f
ii compiz-gnome 1:0.6.0+git20071008-0ubuntu1.1 OpenGL window and compositing manager - GNOM
ii compiz-plugins 1:0.6.0+git20071008-0ubuntu1.1 OpenGL window and compositing manager - plug
ii compizconfig-settings-manager 0.5.2+git20070912-0ubuntu1 Compiz configuration settings manager

Helton Dória (helton-doria) wrote :

I tested this bug and it wasn't reproduceable as described by Phillipp. I followed the suggested steps and the application that was selected when escape was pressed came into first plane but the focus remained on the application that was selected when Super-Tab was pressed. This is the behavior reported in the bug https://bugs.launchpad.net/bugs/154369 as commented by positivek. It is better mark this as a duplicate of the bug 154369.

positivek (anonyhole) wrote :

I agree that it is a duplicate iff testing and fixing of bug 154369 absolutely includes testing and fixing of this one. I guess it's a matter of desired/useful bug granularity and knowledge of implementation (which I do not have).

Note that from a user's perspective, each of these bugs is a different Compiz plugin that can be enabled/disabled independently. I assume that the reporter (Philipp) filed each of these bugs at the same time, with similar wording, for the this reason (though the behaviors, in essence, are the same).

So, in short :-) : My opinion is that these should be worked on together, but are different bugs, but part of the same "task". Whatever is conventional for bug management here and most convenient for developers should preside, though.

Brian Murray (brian-murray) wrote :

I've unmarked this bug as a duplicate as this is about the "Shift Switcher" plugin which provides the <super>+tab key binding. While the other bug was about the "Application Switcher" plugin which provides the <alt>+tab key binding.

positivek (anonyhole) wrote :

Hello. I noticed that this bug is "expired" and made "incomplete". I disagree that this is an incomplete bug report. There is a clear method for reproducing the bug. Also, I notice that the _very similar_ bug 154369 has been marked "Fix Released". If that one was fixed, then I would suggest that those changes also be made to this bug that exhibits similar behavior. in any case, I disagree that this is an invalid bug.

Changed in compiz-fusion-plugins-main:
status: Incomplete → Confirmed
affects: compiz-fusion-plugins-main (Ubuntu) → compiz (Ubuntu)
Changed in compiz (Ubuntu):
importance: Undecided → Low
Travis Watkins (amaranth) wrote :

compiz-fusion-plugins-main (0.8.3+git20091006-0ubuntu1) karmic; urgency=low

  [ Robert Ancell ]
  * Pre-Release of the upcomming 0.8.4 bugfix release: (LP: #446931)
    - compiz.real crashed with SIGSEGV in handleEvent() (LP: #430518)
    - Shift switcher (Super-Tab) shows wrong behaviour on 'escape' (LP: #154371)
    - Compiz shift-switcher should not scale icons for minimized windows
      (LP: #136336)

  [ Travis Watkins ]
  * debian/patches/03_default_options.patch:
    - disable ezoom fit_to_window key (LP: #220939)

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers