Changing number of workspaces in workspace switcher does not update Keyboard Shortcut applet

Bug #150918 reported by John Cooper on 2007-10-09
76
This bug affects 1 person
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Low
Unassigned
Nominated for Hardy by Petr Dlouhý

Bug Description

Binary package hint: gnome-control-center

When I use desktop effects or compiz and adjust the number of workspaces this change is not reflected in the gnome-keybindings-settings.

For example. If I had four workspaces and using the preferences in the workplace shifter applet I increaced that to five. Now when I go to System->Preferences->Keyboard Shortcuts there is no option to set a keypress for "WindowManagement->Move window to workspace 5" but there are still options for 1-4. Similar if I reduce it to three there is still the option for sending to workspace 4 which should not be there.

Related branches

Tim Mann (mann) wrote :

I see this too. A temporary workaround: run gconf-editor and go to apps / metacity / global_keybindings. You can edit the keybindings for switch_to_workspace_N for N = 1 through 12.

Dave Tapley (dukedave) wrote :

Also see this, thanks for the workaround Tim.

I don't know if it is related but this workaround appears to not with with the move_to_workspace_N options under window_keybindings.

Changed in compiz:
importance: Undecided → Low

Desktops appear in shortkey editor if one sets the num_workspaces to correct number (in /apps/metacity/ ).

Basilio Kublik (sourcercito) wrote :

Hi John
you report this issue some time ago and i was wondering if is still an issue for you.

Thanks

Changed in compiz:
assignee: nobody → sourcercito
status: New → Incomplete
Changed in compiz:
assignee: sourcercito → nobody

Still present in Hardy:

1.) Right-click on the Workspace Switcher applet.
2.) Click the Preferences item.
3.) Change the number of workspaces; eg, set Columns to 5.
4.) Open the System -> Preferences -> Keyboard Shortcuts tool.
5.) Under the Window Management section, actions "Switch to workspace 1" and "Switch to workspace 2" are listed, but not actions for any of the newly-created workspaces (3, 4, and 5).

Changed in compiz:
status: Incomplete → Confirmed
Troy Unverdrss (troyunverdruss) wrote :

I have found an additional workaround in the default Ubuntu environment.

Go to System | Preferences | Appearance
Then select the Visual Effects tab, and choose None.
After doing this open System | Preferences | Keyboard Shortcuts
The Switch to Desktop N is now present for all of your desktops (at least on my system), set the shortcuts, then put your visual effects back to the original setting.

Malcolm Scott (malcscott) wrote :

This bug is still present in Intrepid Beta.

Andreas Simon (andreas-w-simon) wrote :

Update: Still present in current Jaunty.

Glenn Holmer (gholmer) wrote :

Also seeing it in Jaunty beta. Workaround to edit config file in apps / metacity / global_keybindings does not work for me.

Bram Avontuur (bram-avontuur) wrote :

Another report that it still works like this in Jaunty, although I didn't know it was due to compiz until now. This seems to be a generic compiz UI integration shortcoming, as shortcut settings seem to be all over the place after compiz has been enabled.

Chris Cheney (ccheney) on 2009-04-28
Changed in compiz (Ubuntu):
importance: Low → Medium
milestone: none → ubuntu-9.10
summary: - Setting the number of workspaces under compiz does not also set the
- keybindings
+ Changing number of workspaces in workspace switcher does not update
+ Keyboard Shortcut applet
Changed in compiz (Ubuntu):
importance: Medium → Low
status: Confirmed → Triaged
Travis Watkins (amaranth) wrote :

The keybinding preferences app needs to be updated to look at compiz settings too.

affects: compiz (Ubuntu) → gnome-control-center (Ubuntu)
Travis Watkins (amaranth) wrote :

No, I take it back, this is dependent on a file compiz ships. Except we just modify a copy of the metacity one and gnome-control-center isn't setup to deal with cols/rows but only one key that defines the number of workspaces/viewports.

affects: gnome-control-center (Ubuntu) → compiz (Ubuntu)
Travis Watkins (amaranth) wrote :

Fixed in bzr, will be in the next compiz upload.

Changed in compiz (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.8.3+git20090917-0ubuntu2

---------------
compiz (1:0.8.3+git20090917-0ubuntu2) karmic; urgency=low

  * debian/rules:
    - remove metacity num_workspaces check from keybinding file (LP: #150918)
  * debian/compiz-manager:
    - enable unredirect_fullscreen_windows if nvidia is detected
  * debian/patches/029_default_options:
    - turn off unredirect_fullscreen_windows by default again

 -- Travis Watkins <email address hidden> Mon, 21 Sep 2009 08:56:25 -0500

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments