loses workspaces when trying out desktop effects

Bug #145782 reported by James Troup on 2007-09-27
2
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-control-center

I upgraded a feisty laptop to gutsy beta today. It's an Intel laptop (945 I think) so unlikely to be blacklisted. desktop effects weren't turned on by default. Tried to enable them to show them to the user. Ran into the whole 'only 2 workspaces thing', and for various other reasons, wanted to go back to no effects. Selected that, but found that the users previous customized workspace setup (6 workspaces, with names) had been lost and the user only had 1 workspace.

Sebastien Bacher (seb128) wrote :

That's a compiz bug. The setting migration works fine correctly but it looks like it can be easily confused by exiting configurations, did you run compiz before on this installation?

Changed in gnome-control-center:
importance: Undecided → Medium
Mathieu Laurent (mla) wrote :

I have a problem like this after modify some settings in CompizConfig Settings Manager (trying to enable cube).

The workspace applet show 4 workspace and when I clicked on it, I saw only my wallpaper. No, icons on the desktop, no panels, ...

So, I should be go to tty1, and type killall gnome-panel and switch back to my X session to relaunch the display all all components.

I try this several times, when I click on "workspace applet", all gnome component disappears. But before click on it, I can change to different workspace with ctrl-alt-arrow and in this case it worked, but the workspace-applet didn't work , it cannot show the correct workspace.

Solution :

Launch compiz-settings-manager and reset all parameters :

From http://ubuntu1501.blogspot.com/2007/08/compiz-fusion-upgrade-problems-trevinos.html

"If you don't know where to find CompizConfig Settings Manager (System>Preferences) or don't have an entry in your menu you can launch it by firing up a terminal and typing in: ccsm"

1. Select the preference option
2. Select the Reset to Defaults option

Now Compiz Fusion will reset and everything will work again.

After that, I have only two desktop.

I switch to no visual effect, update the settings of workspace applet : 2 to 4 workspaces and enable desktop effect.

Now, workspace-applet and compiz work together.

Basilio Kublik (sourcercito) wrote :

Hi James
you report this some time ago and there hasn't been any activity for a while, so i was wondering if this is still an issue for you.

Thanks in advance

Changed in compiz:
assignee: nobody → sourcercito
status: New → Incomplete
Changed in compiz:
assignee: sourcercito → nobody
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!.

Changed in compiz:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers