logoff screen takes ages after clicking on the logoff button

Bug #144951 reported by Kim d'Audretsch on 2007-09-25
8
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Low
Unassigned

Bug Description

I am using gutsy. When I logoff in gnome with compiz support it takes ages to get the screen where you can select if you want to shutdown, logoff etc... If i press cancel and select it again it comes up immediately. I am not sure if it should be filed as a compiz-gnome bug. I don't get this problem under 386 gutsy with compiz enabled only under my amd64 version.

doitashimashite (saisei) wrote :

I have exactly the same problem on my Compaq nx7010 notebook running Feisty Fawn. Not using gutsy though.
The thing is, when I add a new user, I don't have this problem when logging off from this new user.
So I replicated this new user's home dir with permissions and all (knowing what I'm doing) without effect.

I don't have the time now to sort this out so I guess re-installing is the only way to go right now. If this happens again after re-installing, I will pay special attention to what I did just before the problem arose, in order to find a possible cause.

luis (useche-gmail) wrote :

I have the same problem. After I upgrade 7.04 to 7.10, the logoff window take a very long to to show up. My system is an inspiron 600m.

I saw this bug in 2 previous Ubuntu releases. I found out that there is a
workaround though: create another user, and move your data to the new home
directory. That helped for me.

> I have the same problem. After I upgrade 7.04 to 7.10, the logoff window
> take a very long to to show up. My system is an inspiron 600m.
>
> --
> logoff screen takes ages after clicking on the logoff button
> https://bugs.launchpad.net/bugs/144951
> You received this bug notification because you are a direct subscriber
> of the bug.
>
>

Michael Monreal (mimox) wrote :

I Am seeing this too on my sister's PC: Athlon XP (32 bit) around 2ghz and a GeForce4 graphics card. The logout screen takes about 30-60 seconds to show (only with compiz). I can also confirm that canceling the dialog and starting again opens it instanly.

What about this home moving trick? Are you also moving all your config files?

doitashimashite (saisei) wrote :

Yes you could do that, but always make sure you make a backup copy of them before you overwrite them. Creating a new user & moving data & config files to this new user is the easiest workaround I could find, so far.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Hardy Heron. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in compiz:
status: New → Incomplete

Pedro,

I put the gnome-power-manager back in the startup list in sessions which
solved the problems. I am running hardy heron now. I will test if this
problem also exists in Hardy. Will get back to you about this later.

Kim

On Thu, Feb 14, 2008 at 6:52 PM, Pedro Villavicencio <email address hidden>
wrote:

> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. The issue that you reported is one that should be
> reproducible with the live environment of the Desktop CD of the
> development release - Hardy Heron. It would help us greatly if you could
> test with it so we can work on getting it fixed in the next release of
> Ubuntu. You can find out more about the development release at
> http://www.ubuntu.com/testing/ . Thanks again and we appreciate your
> help.
>
> ** Changed in: compiz (Ubuntu)
> Status: New => Incomplete
>
> --
> logoff screen takes ages after clicking on the logoff button
> https://bugs.launchpad.net/bugs/144951
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Changed in compiz:
importance: Undecided → Low
Changed in compiz:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers