Ubuntu

Intel video card 8086:2a02 blacklisted, can't run compiz

Reported by Jose De la Rosa on 2007-09-20
16
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

On Gutsy tribe-5 with latest updates (as of 9/20/07)

$ compiz --replace &
[1] 6499
$ Checking for Xgl: not present.
Blacklisted PCIID '8086:2a02' found
aborting and using fallback: /usr/bin/metacity

$ lspci -nvvv -d 8086:2a02

00:02.0 0300: 8086:2a02 (rev 0c) (prog-if 00 [VGA])
 Subsystem: 1028:0209
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
 Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
 Latency: 0
 Interrupt: pin A routed to IRQ 16
 Region 0: Memory at fea00000 (64-bit, non-prefetchable) [size=1M]
 Region 2: Memory at e0000000 (64-bit, prefetchable) [size=256M]
 Region 4: I/O ports at eff8 [size=8]
 Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
  Address: 00000000 Data: 0000
 Capabilities: [d0] Power Management version 3
  Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
  Bridge: PM- B3+

Changed in dell:
importance: Undecided → High
status: New → Confirmed
Diwaker Gupta (diwaker) wrote :

I can reproduce this with Gutsy final on my HP Pavilion a1640n desktop.

$ lspci | grep 29a2
00:02.0 VGA compatible controller [0300]: Intel Corporation 82G965 Integrated Graphics Controller [8086:29a2] (rev 02)

The black listing is NOT required though. I manually modified /usr/bin/compiz and removed the black list and compiz works just fine for me.

jamesb2147 (jamesb2147) wrote :

Actually, fixing it breaks video playback, at least on my Inspiron 530 desktop. All you have to do to "fix" it though is change video output settings to X Window (no Xv) in gstreamer-properties. A workaround, at least!

Pietro Montini (pmontini) wrote :

I commented out the Intel 965 and i965 lines in the black list section. I get compiz-fusion!

I then tried jamesb2147 ¨fix¨ for video by changing to (no Xv) in gstreamer-properties, and (DVD) video does not work for me. Tried Totem, VLC, and LinDVD.

Hardware: HP dv9000 custom build with 17¨ 1680x1020 display with intel 965gm (X3100) video.

Pietro Montini (pmontini) wrote :

 I have read in other bug reports that mplayer will work if you change (no Xv). This also did not work for me. The video players open and when I select the file, or DVD to play, they close.

Will there be a fix for this in Gutsy? or should I upgrade to Hardy or downgrade to Feisty?

Is there more information that I can provide to help correct the problem? Other bug reports state it is the XAA and XEA (or something like that) in the video packages for gutsy.

DanielBachran (dbachran) wrote :

I can reproduce this bug on my Dell XMS M1330 which came w/ Gutsy pre-installed.

$ lspci -v -d 8086:2a02
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c) (prog-if 00 [VGA])
        Subsystem: Dell Unknown device 0209
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at fea00000 (64-bit, non-prefetchable) [size=1M]
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at eff8 [size=8]
        Capabilities: <access denied>

After enabling Compiz by adding SKIP_CHECKS="yes" to /etc/xdg/compiz/compiz-manager (as described here: http://linux.dell.com/wiki/index.php/Ubuntu_7.10/Issues/Compiz_Fusion_965GM_Incompatibility), Compiz runs just fine.

Video playback did not work initially. But after applying the workaround described above I get both Compiz and video:
- Run gstreamer-properties
- On the "Video" tab, change "Default Output" to Plugin: "X Window System (no Xv)"

Ve0 (veo-) wrote :

not working....

Changed in somerville:
importance: Undecided → High
status: New → Confirmed
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1305762

no longer affects: somerville
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers