[regression] "Remember Focus" does not play well with unity launcher so shouldn't be default enabled or better yet the rev should be reverted

Bug #1393020 reported by Doug McMahon
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Compiz
High
Brandon Schaefer
compiz (Ubuntu)
High
Brandon Schaefer

Bug Description

Test case:
enable workspaces
On ws1 open nautilus, a terminal, then firefox
Switch to ws2
click on nautilus icon in unity launcher
What happens: nautilus shows on top but focus remains on firefox
What users expect: nautilus on top with focus

So this option should not be default unless some means to disable is presented in for ex. SS > Appearance > Behavior

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: compiz 1:0.9.12.0+15.04.20141105-0ubuntu1
ProcVersionSignature: Ubuntu 3.16.0-24.32-generic 3.16.4
Uname: Linux 3.16.0-24-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.14.7-0ubuntu10
Architecture: amd64
CasperVersion: 1.346
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Sat Nov 15 15:26:36 2014
DistUpgraded: Fresh install
DistroCodename: vivid
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:3801]
 NVIDIA Corporation GK107M [GeForce GT 755M] [10de:0fcd] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:3801]
LiveMediaBuild: Ubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20141114)
MachineType: LENOVO 20217
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/username.seed boot=casper quiet splash --
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/18/2013
dmi.bios.vendor: LENOVO
dmi.bios.version: 74CN44WW(V3.05)
dmi.board.asset.tag: No Asset Tag
dmi.board.name: VIQY0Y1
dmi.board.vendor: LENOVO
dmi.board.version: 31900058STD
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Lenovo IdeaPad Y510P
dmi.modalias: dmi:bvnLENOVO:bvr74CN44WW(V3.05):bd09/18/2013:svnLENOVO:pn20217:pvrLenovoIdeaPadY510P:rvnLENOVO:rnVIQY0Y1:rvr31900058STD:cvnLENOVO:ct10:cvrLenovoIdeaPadY510P:
dmi.product.name: 20217
dmi.product.version: Lenovo IdeaPad Y510P
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.12.0+15.04.20141105-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.58-2
version.libgl1-mesa-dri: libgl1-mesa-dri 10.3.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.3.2-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.16.1.901-1ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.0-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.4.0-2ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.914-1~exp1ubuntu6
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu2
xserver.bootTime: Sat Nov 15 10:23:35 2014
xserver.configfile: default
xserver.errors:
 Failed to load module "nvidia" (module does not exist, 0)
 Failed to load module "nvidia" (module does not exist, 0)
 NOUVEAU(G0): Failed to initialise context object: 2D_NVC0 (0)
 NOUVEAU(G0): Error initialising acceleration. Falling back to NoAccel
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 729
 vendor LGD
xserver.version: 2:1.16.1.901-1ubuntu1

Related branches

Revision history for this message
Doug McMahon (mc3man) wrote :
description: updated
Revision history for this message
Stephen M. Webb (bregma) wrote :

I'm having trouble reproducing this on an upgrade Vivid install: when I click the Nautilus icon in the launcher I'm taken back to WS1 and the Nautilus window is in focus (all keyboard input is directed there).

Revision history for this message
Doug McMahon (mc3man) wrote :

Hmm, a short vid attached -
Starts with nautilus & a terminal open, focus on terminal. Switching to ws2 & clicking on nautilus icon returns view to ws1 with nautilus on top but focus remains on terminal.

Then putting focus on nautilus > go to ws2, clicking on terminal icon returns to ws1 with terminal on top but focus remains on nautilus.

I think the real point here is introducing an option that changes expected behavior with no user method to change other than thru ccsm

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Revision history for this message
Matthieu Baerts (matttbe) wrote :

I also have this kind of problem.

But I also note this other problem which is not reproducible each time but I guess this bug is related to this one:
* Open two maximised windows: one on the first workspace, the other on the second one.
* Switch between workspaces and the focus will not changed.
e.g. I have my text editor on workspace 1 and Firefox on the next workspace. My text editor's window has the focus and it keeps it even if I switch to the next workspace.

I didn't have this bug on Ubuntu 14.10.

Revision history for this message
Doug McMahon (mc3man) wrote :

As matttbe has mentioned there are other issues.
Have attached very short vid to demonstrate -
On ws1 there are 2l open windows, focus on nautilus, on ws2 there is a firefox window only

From ws1 clicking on FF icon goes to ws2 but focus remains on nautilus window on ws1
From ws2 clicking on the nautilus icon returns to ws1 but focus remains on FF on ws2
ect.

Actually one has to wonder what was the point of this change. No bug was mentioned in changelog, as a feature it has no value.
So it should either be fixed (to what purpose??) or instead of disabling by default the change should be reverted completely

summary: "Remember Focus" does not play well with unity launcher so shouldn't be
- default enabled
+ default enabled or better yet the rev should be reverted
Revision history for this message
Doug McMahon (mc3man) wrote : Re: "Remember Focus" does not play well with unity launcher so shouldn't be default enabled or better yet the rev should be reverted

Please note that the above comment's issue *may* only be when using rotate (orig. issue occurs with both wall & rotate)

summary: - "Remember Focus" does not play well with unity launcher so shouldn't be
- default enabled or better yet the rev should be reverted
+ [regression] "Remember Focus" does not play well with unity launcher so
+ shouldn't be default enabled or better yet the rev should be reverted
Changed in compiz (Ubuntu):
importance: Undecided → Critical
status: Confirmed → In Progress
Changed in compiz:
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in compiz (Ubuntu):
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in compiz:
importance: Critical → High
Changed in compiz (Ubuntu):
importance: Critical → High
Changed in compiz:
status: In Progress → Fix Committed
Changed in compiz (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Doug McMahon (mc3man) wrote :

I see the commit that caused this was a bug fix for https://bugs.launchpad.net/compiz/0.9.11/+bug/1125442
It's probably better when doing something like this to note the bug in the changelog rather than generic entry -

[ Dariusz Gadomski ]
  * CompScreen: Save focused window id before changing viewport.

I see a new proposed commit which seems to fix the ^ but not too sure it may not cause issues with rotate users
(- if that's a concern, (rotate),, then may be good to give a reasonable test before releasing

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.12.0+15.04.20141210.2-0ubuntu1

---------------
compiz (1:0.9.12.0+15.04.20141210.2-0ubuntu1) vivid; urgency=medium

  [ James Jones ]
  * Added support for GL_EXT_x11_sync_object OpenGL extension for Nvidia
    based GPUs to avoid screen refresh issues. (LP: #269904)

  [ Kyle Brenneman ]
  * Added support for GL_EXT_x11_sync_object OpenGL extension for Nvidia
    based GPUs to avoid screen refresh issues. (LP: #269904)

  [ Viktor A. Danilov ]
  * Added support for GL_EXT_x11_sync_object OpenGL extension for Nvidia
    based GPUs to avoid screen refresh issues. (LP: #269904)

  [ Chris Townsend ]
  * Added support for GL_EXT_x11_sync_object OpenGL extension for Nvidia
    based GPUs to avoid screen refresh issues. (LP: #269904)

  [ Stephen M. Webb ]
  * Added support for GL_EXT_x11_sync_object OpenGL extension for Nvidia
    based GPUs to avoid screen refresh issues. (LP: #269904)
  * libdecoration/CMakeLists.txt: use correct variable for link
    directories (LP: #1392715)
  * Switcher Plugin: renamed a local variable so it does not hide a
    function parameter. (LP: #1101585)
  * added support for multi-arch installations (LP: #1395105, #959282)
  * libcompizconfig: reorder stat() and open() calls to eliminate a race
    condition (LP: #1101608)
  * dodge plugin: avoid potential null pointer dereferences (LP:
    #1101554)
  * PrivateScreen unit tests: added additional assertions to verify the
    tests are run in an expected state (LP: #1101413)

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Brandon Schaefer ]
  * Rev 3891 change caused 2 known regressions. (Could be more).
    Reverting. (LP: #1398512, #1393020)
 -- Ubuntu daily release <email address hidden> Wed, 10 Dec 2014 19:52:06 +0000

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
Changed in compiz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers