Rotate: window deco is lost during rotate

Bug #1392841 reported by Doug McMahon on 2014-11-14
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Compiz
Low
Unassigned
Unity
Triaged
Low
Unassigned
compiz (Ubuntu)
Low
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

Test Case on Intel Haswell:
Install compiz-plugins
Enable workspaces
Disable wall, enable cube & rotate

Open any window(s), rotate from current workspace to another ws, then rotate back
Window(s) on the landing ws will be without deco, deco comes back with 1/2 sec or so.

From rev. 3882

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: compiz-plugins 1:0.9.12.0+15.04.20141105-0ubuntu1
ProcVersionSignature: Ubuntu 3.16.0-24.32-generic 3.16.4
Uname: Linux 3.16.0-24-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.14.7-0ubuntu10
Architecture: amd64
CasperVersion: 1.346
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Fri Nov 14 19:04:39 2014
DistUpgraded: Fresh install
DistroCodename: vivid
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:3801]
 NVIDIA Corporation GK107M [GeForce GT 755M] [10de:0fcd] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:3801]
LiveMediaBuild: Ubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20141114)
MachineType: LENOVO 20217
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/username.seed boot=casper quiet splash --
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/18/2013
dmi.bios.vendor: LENOVO
dmi.bios.version: 74CN44WW(V3.05)
dmi.board.asset.tag: No Asset Tag
dmi.board.name: VIQY0Y1
dmi.board.vendor: LENOVO
dmi.board.version: 31900058STD
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Lenovo IdeaPad Y510P
dmi.modalias: dmi:bvnLENOVO:bvr74CN44WW(V3.05):bd09/18/2013:svnLENOVO:pn20217:pvrLenovoIdeaPadY510P:rvnLENOVO:rnVIQY0Y1:rvr31900058STD:cvnLENOVO:ct10:cvrLenovoIdeaPadY510P:
dmi.product.name: 20217
dmi.product.version: Lenovo IdeaPad Y510P
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.12.0+15.04.20141105-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.58-2
version.libgl1-mesa-dri: libgl1-mesa-dri 10.3.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.3.2-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.16.1.901-1ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.0-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.4.0-2ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.914-1~exp1ubuntu6
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu2
xserver.bootTime: Fri Nov 14 14:00:13 2014
xserver.configfile: default
xserver.errors:
 Failed to load module "nvidia" (module does not exist, 0)
 Failed to load module "nvidia" (module does not exist, 0)
 NOUVEAU(G0): [XvMC] Failed to initialize extension.
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 729
 vendor LGD
xserver.version: 2:1.16.1.901-1ubuntu1

Doug McMahon (mc3man) wrote :
description: updated
Doug McMahon (mc3man) on 2014-11-15
description: updated
Doug McMahon (mc3man) on 2014-11-15
tags: added: unity utopic
removed: amd64
Doug McMahon (mc3man) wrote :

Attached vid

description: updated
Stephen M. Webb (bregma) wrote :

I set this as "Low" priority because while it's definitely happening and is not correct functionality, the loss of window decorations for a fraction of a second does not really interfere with the correct functioning of the software and indeed I didn't even notice it until it was pointed out.

Changed in compiz (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Changed in unity:
status: New → Triaged
importance: Undecided → Low
Changed in compiz:
status: New → Triaged
importance: Undecided → Low
Changed in unity (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers