launching applications on fullscreen kill compiz

Bug #138424 reported by Nemes Ioan Sorin on 2007-09-09
2
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz

Gutsy tribe 5.

After installing tribe 5 (I wanna do a fresh install - instead internet upgrade - to see what's new with the new installer) everything work ok with compiz.

After I do regular updates and Install Emerald - all OK again but ..let say after 20 minutes when I launch ..let say Inkscape - compiz die and I got metacity again in all cases.

NO frezee, no nothing - fallback is OK.

But I must restart compiz each time with compiz --replace (untill next 20 minutes).
Sometime is enough to open a folder.

I think is not a big problem to solve.

Thank you for your bug report.
About compiz and Emerald : Did you install them from the officiel repositories ?

Nemes Ioan Sorin (nemes-sorin) wrote :

UPDATE

I do a little test to see what programs OR what else can broke Compiz so I restart Compiz with compiz --replace.

All OK but when I try to open a SVG file with Inkscape - my desktop do a short tremolo and compiz gone, metacity come.

This is the message from terminal :
Floating point exception (core dumped)

After that, I tried to see if Compiz crash launching other applications but I can't - Compiz behaviour was stable.
I only can crash Compiz doing a doubleclick on a svg file. Then Compiz crash and Inkscape don't open the file.

If I do this without Compiz started, Inkscape open the file without problems.

Trying to crash Compiz just launching Inkscape I obtained different results - sometime crash ..sometime not.

I'll attach the svg file here.

Nemes Ioan Sorin (nemes-sorin) wrote :

I forget to say Emerald was just installed but I don't use it at the testing moment. So, Emerald was no implied.

I don't use Trevino repo OR Amarath repo.

Only pure Gutsy repositories.

OUT OF TOPIC FOR 2 MINUTES => I need an indication about WHERE, or WHICH team I have to contact about the Compiz / Emerald tray launcher.

Last week I tried Fusion-Icon which was made until Tribe 5 release ( this mean that fusion-icon think compiz is not started by default ) so if someone try to put fusion-icon in tray - Gutsy at start will start Compiz - then Fusion-Icon will start Compiz again for the second time.
Gutsy by default don't install this window manager which is a loss.
Fusion-Icon is the perfect solution to set up Compiz and Emerald or to choose other window manager if U wanna play a game for example.

The only thing that keep me away from Fusion-Icon is he start compiz for the second time and I don't like all those flick's on my screen when GDM start (fusion-icon contain exec a command like compiz --replace & emerald --replace).

If this behaviour can be corrected Fusion-Icon MUST be included in original Compiz installation. It's a logical move to have this option at your click - not to search all time for Apperance->Desktop Effects->Normal Effects.

Travis Watkins (amaranth) wrote :

I am unable to reproduce this error. I can open that file with inkscape just fine. Does this open happen when you use emerald?

Changed in compiz:
status: New → Incomplete
Nemes Ioan Sorin (nemes-sorin) wrote :

Nope, I just don't use Emerald - Emerald was just a nice try - works OK - but for me Compiz + Metacity borders is enough.
I have a pretty nice UI (Clearlooks + NuoveXT + T'ish Lively.

Compiz work OK - almost no CPU usage (1 - 5 percents with all effects) - but sometime when a window is created by a program Compiz just stop working.

this is the message : Floating point exception (core dumped)

I have a lots of extra gnome libraries (I use Cinelerra and Kdenlive) maybe something is wrong there. Anyway the results is unpredictable today I had no problems with Inkscape but each time I launch gFTP - just stop working.

Will be helpful for me to find HOW TO trace this crash.

Also, maybe this bug has some replications - maybe you will find someone with the same problem and maybe linking those bugs we will find an approach. I just don't have enough time to search on the Compiz bugs stack, but I can try to catch this error is someone can tell me HOW TO.

Nemes Ioan Sorin (nemes-sorin) wrote :

FOUND SOME...

Well I've managed to reproduce this bug - in a "scientific manner".

I tested window behaviours when the Compiz crashed.
Is not about programs - I can stop Compiz using any aplication that can open a FULLSCREEN window.

For exmple Nautilus.

By default I "trained" my folders on the desktop to open their windows at 50% from desktop not full screen

Now I put a folder on fullscreen mode - I close that folder - and next time when I open this folder (Nautilus memorize last size and position of windows for each folder and for some applications) - Compiz gone.

Same things for other applications.
-> When in non fullscreen mode - ALL OK.
-> When any folder OR application was opened directly in fullscreen mode - Compiz die.

About bug behaviour
When I launch some programs - they wont open windows - they crash Compiz then stop.
After Compiz gone and Metacity come - Applications work normal ( open ..close ..etc ).

For the latest testing series - I used UNREDIRECT FULLSCREEN WINDOWS option from Advanced Desktop Effects Settings -> General Compiz Options -> General - but no better results.

I made I think 30 tests - with the same predictable (from now) behaviour.

I hope this will help

Nemes Ioan Sorin (nemes-sorin) wrote :

NOW THIS IS GREAT...

After last Compiz upgrade on 13 Sept. 2007

Checking for Xgl: not present.
Blacklisted 'ati' driver is in use
aborting and using fallback: /usr/bin/metacity

Well I don't use FGLRX at all indeed.
Blacklisted 'ati' driver was good enough yesterday. ...or, Gutsy put the fglrx driver by themself ? - let's check ..nope
the same hardware configuration but updated compiz wont work so I can't give other reports on this bug.

in general lines ---- this is not the expected behavior, after an upgrade - my suggestion is to prevent testing user community - hey we put something new inside that need XGL so install XGL first.
second big interior question is where I can obtain this blacklist ? maybe I'll buy other card to support Gutsy.

Back to the bug report -> Regarding my last post referring to FULLSCREEN WINDOWS - I do an experiment before Compiz upgrade.

I put XFCE Desktop.
Guess what ...
Compiz work perfect with XFCE - no problems - ans I was used exact the same themes from GNOME - ClearLooks and Nimbus.

Well from here I'm afraid I can't help more - I don't know If I can put my Compiz back without reinstall Gutsy - so I have to wait for next TRIBE.

Best wishes to all

Nemes Ioan Sorin (nemes-sorin) wrote :

OK, problem solved ..need to point now to Compiz Developers

The strange behavior for Fullscreen opened windows (Nautilus or other applications) was caused by a Compiz plugin named PLACE WINDOWS under WINDOWS MANAGEMENT SECTION.

This plugin has 4 possible states = 4 possible ways to put a window on desktop when this window is generated.

1 Centered
2 Smart
3 Maximize
4 Random

The subject of this bugreport is RANDOM mode.
When RANDOM mode is activated - this plugin try to calculate a random X and Y start points for the new generated window.
This is in oposition with the case when a window try to start in fullscreen mode.

I will try to note this to plugin owners - maybe this mode can be disabled for windows opened in fullscreen mode.

Changed in compiz:
status: Incomplete → Fix Released
assignee: nobody → nemes-sorin
Changed in compiz:
assignee: nemes-sorin → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments