Desktop Effects Crashes X at Random using fglrx/XGL

Bug #138421 reported by ShackJack on 2007-09-09
6
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Low
Basilio Kublik

Bug Description

Steps to reproduce:
1. Run GNOME session with Desktop Effects (xtra effects enabled) using repo's fglrx drivers and using autostarted XGL
2. X crashes out to GDM login at a seemingly random interval usually when clicking on something (links in a browser, starting new program)

Have tried turning on/off certain plugins, etc.. with no change. Xorg log does not indicate anything except that X was closed unexpectedly.

System is updated to latest packages, etc... Using fglrx 8.37.6; no "exotic" settings in Xorg.conf, running at 1680x1050 24-bit. Unstable since about beginning of August... gutsy updates since then of xorg, fglrx, linux kernel have not corrected the problem. Gutsy desktop with nvidia binary driver does not exhibit same behavior.

Basilio Kublik (sourcercito) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at [WWW] https://wiki.ubuntu.com/Bugs/FindRightPackage. I have classified this bug as a bug in compiz

ShackJack (shackjack) wrote :

Thanks, I wasn't quite sure what to put there, as I am not getting any feedback from either compiz or xorg.conf.

Compiz works just fine with nvidia setup, so my thoughts were this was a problem either with the fglrx driver or the XGL setup. Or at least with their interaction with compiz, as the system works fine when compiz is disabled.

I believe I've tried running compiz --replace > output.txt to see if any errors are reported when X crashes, but nothing turned up. Will try again to be sure - if you have any thoughts as to find out what is *actually* going on, they would be most appreciated. If you need any more specifics from me, I would be happy to provide them.

Basilio Kublik (sourcercito) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Changed in compiz:
assignee: nobody → sourcercito
importance: Undecided → Low
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

Closing this bug report as no further information has been provided. Please feel free to reopen this bug if you can provide the information asked for. Thanks!.

Changed in compiz:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers