Compiz shift-switcher should not scale icons for minimized windows

Bug #136336 reported by Dilomo on 2007-08-31
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: compiz-fusion-plugins-main

When I start Shift switcher in compiz-fusion and the window that have to be displayed is minimized a extremly large logo of the window is shown. See pictures for more info.

Dilomo (ankere) wrote :
Travis Watkins (amaranth) wrote :

This is by design. We can't get a thumbnail of the minimized window because when you minimize a window it completely goes away. Showing the window icon is better than nothing at all.

Changed in compiz-fusion-plugins-main:
status: New → Invalid

But it's ugly, isn't it?

> This is by design. We can't get a thumbnail of the minimized window
> because when you minimize a window it completely goes away. Showing the
> window icon is better than nothing at all.
>
> ** Changed in: compiz-fusion-plugins-main (Ubuntu)
> Status: New => Invalid
>

Now I think you should create something like lower the screenshot I attach because the user have no Idea what is going in and the space between the two other windows is empty. First I attach buggy window

Dilomo (ankere) wrote :

You may use smth like this:

Travis Watkins (amaranth) wrote :

Ok then, that seems very interesting. Probably won't happen for gutsy though.

Changed in compiz-fusion-plugins-main:
importance: Undecided → Wishlist
status: Invalid → Triaged
elyk (elyk53) wrote :

The old beryl had the options to show live previews of minimized windows - how did it do that? Did it just pretend to minimize the windows while leaving them running as if they were maximized?

Travis Watkins (amaranth) wrote :

It did something really hacky. Basically when you minimized a window the core would store a thumbnail of what the window looked like before it minimized. It was not live.

So, no issue for that problem?

positivek (anonyhole) wrote :

Re: Travis Watkins wrote on 2007-10-05

First, it seems that windows on desktops other than the current one *are* rendered, though not visible. This is especially apparent when using the Compiz "Cube" and spinning it around. I wonder why the minimized windows aren't also rendered. If saving computing resources were a real issue, then the Cube and Wall rendering would not render out-of-view. But they do. (And this seems to be the whole point of moving to composite rendering with Compiz/etc.)

Second, a major reason and use case for Alt+Tab-ing, Alt+Shift+Tab-ing, Super+Tab-ing, Super+Shift+Tab-ing is to easily browse the open windows in *some* fashion. For some this includes bringing each window to front as it's highlighted. For others it's less blunt. For me, one reason to use the Switchers is to access minimized windows. And when I have several of them (or even if I don't), a preview during this app-switching would allow me to make the choice to unminimize it more efficiently and accurately. While the icon is better than nothing (or just text), a preview or cached thumbnail would be best.

Therefore, I suggest that A) Compiz render all windows (or be able to), whether drawn/shown or not; B) Use whatever means is available to provide the user with a clue of what the minimized window looks/looked like, be it a cached thumbnail or a live rendering.

positivek (anonyhole) wrote :

Can someone improve the bug title? Am I allowed to do that?

Scott (rouge568) wrote :

I can accept that it's a lot of work/impossible to show a window preview, but can't we at least make the icons higher resolution? Right now, it's horribly pixelated and looks like a .gif from the 1990s. Coupled with shrinking the icon a bit, this would make it look a lot nicer.

If it's possible on Windows Vista, so it's possible on Ubuntu, doesn't it?

huiii (a00ps) wrote :

it is still ugly

Dilomo (ankere) wrote :

positive: how do you want me to change the title?

Dilomo (ankere) wrote :

positivec: how do you want me to change the title?

Scott (rouge568) wrote :

Something more descriptive. 'Compiz shift switcher should show thumbnails for minimized windows' might work.

I hope this gets fixed soon. It is really ugly...:(

Senor_Hypnotiq (will-robles) wrote :

I wanted to do something similar, so I found another way to get similar effects. I do two things:

1) Instead of minimizing the windows, just move them over to another workspace. I use the Emerld Theme Manager with a theme that gives me an available drop box on the top left corner of the window to move it to another workspace.

2) When you select your plugin in Compiz (in your case the 'Shift Switcher', use the option "Initiate Windows Picker for All Windows". Enabling the All Windows will display all windows in all workspaces.

That should give you very similar effects. Finding the easiest way to move a window to another workspace would be your best way to "minimize" your desktop clutter.

nyékhelyi gábor (n0gabor) wrote :

A temporary solution, could be implemented in little time by a compiz dev:

- Show the icons in their original size. It would look much better, then an ugly upscaled one.

Sam Illingworth (mazz0) wrote :

<bumps>

Agreed - while Live Previews would be nice, can't we at least have a none-stretched icon or a cached thumbnail of the minimized application in the meantime?

summary: - Compiz shift-switcher should show preview for minimized windows
+ Compiz shift-switcher should not scale icons for minimized windows
affects: compiz-fusion-plugins-main (Ubuntu) → compiz (Ubuntu)
Travis Watkins (amaranth) wrote :

Fixed in commit: http://cgit.compiz.org/fusion/plugins/shift/commit/?id=3e8a294a293ac04feed54c2ae3843bc4a285a60b

This doesn't completely disable the scaling as that looks pretty terrible too (tiny little icons) but it is a nice trade off between not scaling at all and scaling like we were before. Only one icon I can find (gwibber) looks bad with this setup but the correct fix at this point is to get apps to tell X about better icons.

Changed in compiz (Ubuntu):
status: Triaged → In Progress
Travis Watkins (amaranth) wrote :

compiz-fusion-plugins-main (0.8.3+git20091006-0ubuntu1) karmic; urgency=low

  [ Robert Ancell ]
  * Pre-Release of the upcomming 0.8.4 bugfix release: (LP: #446931)
    - compiz.real crashed with SIGSEGV in handleEvent() (LP: #430518)
    - Shift switcher (Super-Tab) shows wrong behaviour on 'escape' (LP: #154371)
    - Compiz shift-switcher should not scale icons for minimized windows
      (LP: #136336)

  [ Travis Watkins ]
  * debian/patches/03_default_options.patch:
    - disable ezoom fit_to_window key (LP: #220939)

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
Art (vand3lay) wrote :

"It did something really hacky. Basically when you minimized a window the core would store a thumbnail of what the window looked like before it minimized. It was not live."
That's not a bad idea, I think it's still better than showing just an icon.
You could also try having it remember which windows are minimized, then maximize all the windows, grab the thumbnails then minimize them again.

Travis Watkins (amaranth) wrote :

Actually that would be even worse because some windows take a _long_ time to draw again so you'd get a delay waiting for them to do so to get a thumbnail or you'd get icons then anywhere from right away to a second or two later the thumbnails would start to fill in.

What about adding a hook to the minimize event on windows, and grab a screenshot of it. You can later use that screenshot - you won't get a live preview, but it's waaaaaaay better than just the icon. AND windows does the same thing.

A simple hashmap could store the thumbnails in memory by windowID or something alike.

Deje (deje07) wrote :

My computer has a lot of memory compared to the tasks it is used most of the time. I could bear with some megabytes wasted because of storing screenshots of minimized windows.
If RAM is low, stop some apps or turn compiz off, which will significantly decrease memory usage.
I can't believe this feature has been removed from beryl/compiz. It would definitely worth that RAM, especially that it would finally give meaning to the Window Preview plugin.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers