Font hinting setting is not respected (e.g. slight vs. full)

Bug #1356987 reported by lebedev on 2014-08-14
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Low
Unassigned

Bug Description

After system boot some applications (for ex. Nautilus) have corrupted font hinting. They are also not affected on changing font settings (see attached screenshots).
If Nautilus is running as root - fonts are normal (screenshot). Sometimes browsers such as Google Chrome, Firefox etc. are also affected.
Appearance of this applications can be set to normal:

- after screen blink for several minutes of uptime (it is random);
- after closing user session and login back;
- after closing nautilus with "nautilus -q" for 1-2 times.

This problem occurs on Nouveau, Nvidia proprietary drivers (331.38).
/home folder is formatted before install, so no settings can not affect on appearance for this applications.

This problem is actual for Trusty and Utopic with the latest updates.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: compiz 1:0.9.11.2+14.04.20140714-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-34.60-generic 3.13.11.4
Uname: Linux 3.13.0-34-generic i686
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Это каталог: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86 Kernel Module 331.38 Wed Jan 8 18:44:57 PST 2014
 GCC version: gcc version 4.8.2 (Ubuntu 4.8.2-19ubuntu1)
.tmp.unity.support.test.0:

ApportVersion: 2.14.1-0ubuntu3.3
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Thu Aug 14 20:51:01 2014
DistUpgraded: Fresh install
DistroCodename: trusty
DistroVariant: ubuntu
DkmsStatus:
 bbswitch, 0.7, 3.13.0-34-generic, i686: installed
 nvidia-331, 331.38, 3.13.0-34-generic, i686: installed
GraphicsCard: NVIDIA Corporation GT200 [GeForce GTX 260] [10de:05e2] (rev a1) (prog-if 00 [VGA controller])
InstallationDate: Installed on 2014-08-14 (0 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release i386 (20140722.2)
MachineType: Gigabyte Technology Co., Ltd. GA-MA74GM-S2H
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=ru
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-34-generic root=UUID=572c042f-1bd3-44ca-8374-4adb480ba179 ro quiet splash
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/19/2009
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F4b
dmi.board.name: GA-MA74GM-S2H
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF4b:bd11/19/2009:svnGigabyteTechnologyCo.,Ltd.:pnGA-MA74GM-S2H:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-MA74GM-S2H:rvr:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-MA74GM-S2H
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.11.2+14.04.20140714-0ubuntu1
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.3-0ubuntu0.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.3-0ubuntu0.1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3.1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Thu Aug 14 20:50:22 2014
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Power Button KEYBOARD, id 7
 input HID-compliant Mouse HID-compliant Mouse MOUSE, id 8
 input AT Translated Set 2 keyboard KEYBOARD, id 9
 input A4TECH USB2.0 PC Camera KEYBOARD, id 10
xserver.errors: open /dev/fb0: No such file or directory
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.15.1-0ubuntu2

lebedev (lebedev-kam) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Stephen M. Webb (bregma) wrote :

Are you referring to the way the system font changes size in an apparently arbitrary way (sometimes much larger than expected)?

Changed in compiz (Ubuntu):
status: Confirmed → Incomplete
lebedev (lebedev-kam) wrote :

No, some windows (Nautilus, Google Chrome, Firefox etc.) have corrupted font. System settings are not applied for them (default, or customized). If the default Ubuntu settings is set their font are looking much different then other font in other windows. If I change the font settings (for clarity) this windows are not affected on this changes.

lebedev (lebedev-kam) on 2014-08-16
Changed in compiz (Ubuntu):
status: Incomplete → Confirmed
Adolfo Jayme (fitojb) on 2014-08-16
summary: - Appearance of some applications is corrupt
+ Font hinting setting is not respected (e.g. slight vs. full)
Changed in compiz (Ubuntu):
importance: Undecided → Low
delcin (delcin) wrote :

Dobogo of daypart! Ubuntu 14.10 went out, bag in it is! I enter a login and password after blinking of screen (25-30 secs. from a graphic load) and only so baga it is not! Though what that is work on a correction conducted baga?

lebedev (lebedev-kam) on 2016-06-23
tags: added: xenial
To post a comment you must log in.