Failed to execute child process "-x" (No such file or directory)

Bug #135484 reported by Alexey Balmashnov on 2007-08-29
10
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Medium
Michael Vogt

Bug Description

Gutsy (upgraded to Tribe5 from Feisty), latest updates.

I got an error like in the summary, when I tried to run "htop" via the system menu.

Further on, I tried to run it via Application Launcher (Alt+F2), which gave me the same error. If I try to launch application, which should be executed in terminal, as results I obtain two error dialogs:
* Could not run command 'file:///htop'
Failed to execute child process "-x" (No such file or directory)
* Could not open location 'file:///htop'
The location or file could not be found.

Sebastien Bacher (seb128) wrote :

Thank you for your bug. What terminal emulator did you configure to the preferred application dialog?

Ah, now I see were the problem is.

In fact, I did not configure anything. Probably, It was messed up during the update process. In preferred applications I had "Custom" selected without a command. It would have been nice, if Ubuntu could point me directly to the problem or suggest to check these settings.

Problem solved. Thanks a lot.

Sebastien Bacher (seb128) wrote :

the packaging system doesn't change user configurations, closing the bug. Feel free to reopen if you figure than something you are running is changing this setting though

Changed in gnome-control-center:
status: Incomplete → Invalid

Found a problem.

There is an inconsistency in handling settings for preferred terminal if one enables/disables 3D desktop (at least via System-Preferences-Appearance).

Steps to reproduce:
1. Disable settings for terminal without 3D. Disable settings for terminal with 3D (let's say put custom, without a command in both cases)
2. Enable your favorite terminal while 3D desktop is off.
3. Enable 3D desktop. I get here still "Custom" option without a command.
4. Disable 3D desktop. Now I get the same, Custom option without a command in my desktop without 3D.

It looks like option made active while 3D desktop was turned on propagates back to a normal desktop settings, while it does not work other way.

Changed in gnome-control-center:
status: Invalid → New
Sebastien Bacher (seb128) wrote :

reassigning to compiz, looks like its sync code is buggy

Changed in compiz:
assignee: desktop-bugs → nobody
importance: Low → Medium
Michael Vogt (mvo) wrote :

The only issue I can think of with the sync code is that the argument is not supported inside compiz.

Michael Vogt (mvo) wrote :

I removed the default from libcompizconfig and that default is now taken from the integration option.

Michael Vogt (mvo) wrote :

This hopefully fixes it.

Changed in compiz:
status: New → Fix Committed
Michael Vogt (mvo) wrote :

Please test "libcompizconfig_0.5.2+git20070919-0ubuntu1" and let me know if that fixes the issze.

Martin Pitt (pitti) wrote :

Michael, I tested that version, and the bug still happens.

Changed in compiz:
status: Fix Committed → In Progress

Yep, the bug is still there.

Michael Vogt (mvo) on 2007-10-05
Changed in compiz:
assignee: nobody → mvo
Michael Vogt (mvo) wrote :

compiz (1:0.6.0+git20071004-0ubuntu2) gutsy; urgency=low

  * debian/patches/027_default_to_gnome_terminal:
    - set default for command_terminal to gnome-terminal (LP: #135484)

 -- Michael Vogt <email address hidden> Fri, 05 Oct 2007 10:52:47 +0200

Changed in compiz:
status: In Progress → Fix Released

Tested latest fix. Works for me now.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers