Ubuntu

TVout is interfering with screen resolution on Intel graphics

Reported by Jose Lang on 2007-08-10
72
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
compiz (Ubuntu)
Undecided
Unassigned
Gutsy
Undecided
Unassigned
Hardy
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
High
Unassigned
Gutsy
Undecided
Bryce Harrington
Hardy
Undecided
Unassigned

Bug Description

Can't select correct resolution and refresh rate is not recognized in Gusty Tribe 4. This happens
 on a Santa Rosa laptop with Intel GM965.
This works OK with Feisty on the same machine.

Impact: Causes improper resolution, refresh rates, and other resolution issues for four intel graphics cards.

Solution: Applies several quirks from the new -intel driver that upstream is now carrying.

Patch: http://launchpadlibrarian.net/10316259/xserver-xorg-video-intel_2.1.1-0ubuntu10.debdiff

Steps to reproduce:
1. Use a Samsung Q35, Panasonic Toughbook CF-Y7, Lenovo X60, Dell Latitude X1, or AOpen 965GM mini pc.
2. Attempt changing to each available resolution via xrandr
3. Some or all resolutions will fail to work correctly, showing an issue as described in Impact

Regression Potential: Low. Changes only affect specific, identified hardware, and applies quirks that have been thoroughly tested by upstream.

Bryce Harrington (bryce) wrote :

Not sure what you mean by "can't select", but this is probably fixed with today's changes. Test a current iso daily cd and reopen with more descriptive details if the problem still exists.

Changed in xorg:
status: New → Fix Released
Jose Lang (jose-lang) wrote :

I have attached two screenshots of the desktop.
Screenshot1.png shows the desktop (booted from live CD daily build 29/09/07) in 1024x768 resolution on a 1280x800 native resolution screen.
Screenshot2.png shows the same desktop after reconfiguring xserver-xorg with added 1280x800 resolution.
Please let me know how I can help.

Jose Lang (jose-lang) wrote :
Jose Lang (jose-lang) wrote :

Problem still persists in release from 28/09/07. Submitted more details (screenshot) and I will be happy to assist with furhter diagnostic.

Changed in xorg:
status: Fix Released → New
Steven Wagner (stevenwagner) wrote :

I can verify this to. Gutsy beta clean install on a Insprion 1420. Prefs -> Screen Resolution works fine. But if I dare go to Admin -> Screens and Graphics, my computers gets permanantly thrown down to VESA mode. And the size of the control panel applets in vesa mode are so big that I cant see the apply button at the bottom of the screen.

David Fokkema (dfokkema) wrote :

I've marked two duplicates for this bug. The thing is that 'screens and graphics' with a 'plug 'n play' screen incorrectly writes the xorg.conf. I'll attach the xorg.conf of a clean gutsy beta live cd boot, and the xorg.conf after using screens and graphics to set the resolution to 1280x800. I'll try the new displayconfig-gtk from the upgrade of today 10/2. Weird thing is that sometimes 'screens and graphics' really sets the 1280x800 resolution so as long as you don't log out, you think everything is ok.

David Fokkema (dfokkema) wrote :
David Fokkema (dfokkema) wrote :

I think two separate bugs are filed here: the OP has strange screenshots, whereas the comments (and the duplicates I designated) mention the 'thrown back to 640x480' bug. I've reset the duplicates. Please follow bug #145896 for the 640x480 issue. Sorry for the mix-up.

Adrian D (grosem) wrote :

I can verify this too with the Samsung Q45.

stoumpos (stoumpos) wrote :

Have the same problem with gutsy on a Toshiba U300 laptop. Found the
following solution at http://www.thinkwiki.org/wiki/Instal...a_ThinkPad_R61

Modify /etc/X11/xorg.conf so that a new monitor is added for
the tv-out, marked as disabled. Specify on the device section
the name of the dummy tv-out.

add:

Section "Monitor"
Identifier "TVOutput"
Option "Disable" "true"
EndSection

find Section "Device" and add:

Option "monitor-TV" "TVOutput"

Adrian D (grosem) wrote :

stumpous solution didn't work for me. :-(

unggnu (unggnu) wrote :

This seems to be a general Xorg Intel driver problem. Since the new driver is used Gutsy Live CD always starts with 1024x768 while it is no problem to switch to my native resolution of 1366x768 with Screen Resolution. Resolution was recognized correctly with i810 driver except that it always uses 1368x768 (2 pixel virtual) because of an i810 bug (xrandr lists 1368x768 too which isn't correct).
It seems that xorg configuration doesn't use the highest possible resolution with new Intel driver like with i810.
 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)

unggnu (unggnu) wrote :

Btw. the displaced output only happens if you use activated LFP and external or maybe tv at once in clone mode afaik. At least for me.
Posting the output of xrandr would help I guess.

schilcgn (christian-initcrash) wrote :

this is a problem with xserver 1.3
it detects a TV output, and configures it with 1024x768, even if there is no TV out on the machine at all.
this can be fixed at runtime with:

xrandr --output TV --off

or permanently by using a xorg.conf similar to the attached one.

unggnu (unggnu) wrote :

Maybe we should change the topic. The cause with the tv output makes sense since the same happens if an external monitor is connected to an laptop and clone mode (which is the default) is activated.
Isn't it possible to activate only one monitor (the bigger one) at once or using desktop extension instead of clone mode per default with xrandr?

Btw. the resolution recognition problem has been fixed since Gutsy RC.

unggnu (unggnu) wrote :

It seems to be a compiz issue since full screen apps use the whole screen if compiz isn't enabled. Even in clone mode.

Travis Watkins (amaranth) wrote :

The driver and/or xorg is not properly reporting the display sizes and positions so compiz seems to do the wrong thing.

Changed in compiz:
status: New → Invalid
raid517 (raid517-ukonline) wrote :

This bug is still evident in the latest ISO which I downloaded today.

markyc (mark-tupple) wrote :

I've the same problem, and I'm getting it with Fedora 7 too. Currently I just have a launcher on my desktop which runs the "xrandr --output TV --off" command each time I log on... is there a way to add that as a script at the end of the boot sequence?

(sorry, I originally wrote this in the duplicated bug report)
I believe this is related - I'm running a Dell D640 laptop with Radeon Mobility video, which does not support the new appearance features. (does that mean Compiz is off? ) The screen geometry issue persists here. I have full use of the entire 1440x900 area of my emachines widescreen monitor, however the panels, the "fullscreen" screensaver, etc. all confine themselves to the upper left quadrant of the screen as shown, mapping to a 1024 x 768 area, I believe. This picture shows the screensaver in Preview mode where it thinks it's taking up the full screen.

david_ri (david-d-cox) wrote :

Correction - Dell C640, not D, but the Radeon Mobility M7 video is correct. It is using the ati - ATI Mach8, Mach32, Mach64, and Radeon driver in Gutsy (auto detected).

Bryce Harrington (bryce) on 2007-10-20
Changed in xserver-xorg-video-intel:
importance: Undecided → High
status: New → Confirmed
Aaron Whitehouse (luna-tick) wrote :

My bug ( Bug #148027 ) is fixed in Gutsy Final.

Bryce Harrington (bryce) wrote :

Upstream has been dealing with a variety of TV output confusions with -intel. I've identified a number of TV-out related patches from current git head at:

  https://wiki.ubuntu.com/X/Patches.

Also, Kyle McMartin posted a deb with some TV out fixes here:

  http://ppa.launchpad.net/kyle/ubuntu/pool/main/x/xserver-xorg-video-intel/

Can you guys test Kyle's deb and let us know if it resolves the issue or not? If it does, I can investigate SRUing it. If not, we can also try some of the additional TV quirks on the X/Patches page.

Hello -

It looks like the problem for what I was experiencing was not TV-output
related after all. See bug 156550 - an xandr command to turn off an
unintended display seemed to work as a patch.

However, thank you very much for following up.

-David

Bryce Harrington wrote:
> Upstream has been dealing with a variety of TV output confusions with
> -intel. I've identified a number of TV-out related patches from current
> git head at:
>
> https://wiki.ubuntu.com/X/Patches.
>
> Also, Kyle McMartin posted a deb with some TV out fixes here:
>
> http://ppa.launchpad.net/kyle/ubuntu/pool/main/x/xserver-xorg-video-
> intel/
>
> Can you guys test Kyle's deb and let us know if it resolves the issue or
> not? If it does, I can investigate SRUing it. If not, we can also try
> some of the additional TV quirks on the X/Patches page.
>
> ** Summary changed:
>
> - only a part of the desktop is useable with native screen resolution and Intel graphic
> + TVout is interfering with screen resolution on Intel graphics
>
>

Tried the .deb, commented out the "TV out/dummy TV out" sections from
xorg.conf and the original problem returned.

On Wed, 2007-10-24 at 23:10 +0000, Bryce Harrington wrote:
> Upstream has been dealing with a variety of TV output confusions with
> -intel. I've identified a number of TV-out related patches from current
> git head at:
>
> https://wiki.ubuntu.com/X/Patches.
>
> Also, Kyle McMartin posted a deb with some TV out fixes here:
>
> http://ppa.launchpad.net/kyle/ubuntu/pool/main/x/xserver-xorg-video-
> intel/
>
> Can you guys test Kyle's deb and let us know if it resolves the issue or
> not? If it does, I can investigate SRUing it. If not, we can also try
> some of the additional TV quirks on the X/Patches page.
>
> ** Summary changed:
>
> - only a part of the desktop is useable with native screen resolution and Intel graphic
> + TVout is interfering with screen resolution on Intel graphics
>

Bryce Harrington (bryce) wrote :
Changed in xserver-xorg-video-intel:
milestone: none → gutsy-updates
status: Confirmed → Fix Released
Bryce Harrington (bryce) on 2007-11-09
description: updated
Bryce Harrington (bryce) wrote :

Subscribing ubuntu-sru.

Changed in xserver-xorg-video-intel:
status: Fix Released → Fix Committed
Martin Pitt (pitti) wrote :

The patch looks appropriate for SRU (completing the review of the debdiff). However, please get this fixed in Hardy as soon as possible and collect some feedback. You are welcome to upload to gutsy-proposed already and get it tested there. Thanks!

Changed in compiz:
status: New → Invalid
Changed in xserver-xorg-video-intel:
assignee: nobody → bryceharrington
status: New → In Progress
Timo Aaltonen (tjaalton) wrote :

All the patches (04, 06, 08) have been merged upstream and shipping with hardy. Note that 04 is not enabled in this diff.

Changed in xserver-xorg-video-intel:
status: Fix Committed → Fix Released
Bryce Harrington (bryce) wrote :

04 was enabled in an earlier version; this patch simply updates the patch to fix the issue that was found.

Like Timo said, the fixes have been well tested in Hardy and gutsy-proposed for a few weeks without issue. I only marked it down to fix committed so it'd be visible to SRU folks; I didn't know how to do release tasks (but is obvious enough now that I see).

Mika Fischer (zoop) wrote :

I've tested the package by Kyle McMartin that was mentioned above, but it did not fix the problem for me.

For the people searching for a workaround, what I did is to put the following into the file /etc/gdm/Init/Default near the top (just below "OLD_IFS=$IFS":

xrandr --output TV --off

Martin Pitt (pitti) wrote :

Bryce, if this is still an issue, can you please upload -intel to gutsy-proposed? What about the last comment, there seems to be a problem with it still?

Changed in xserver-xorg-video-intel:
status: In Progress → Incomplete
Martin Pitt (pitti) wrote :

Sponsored and accepted into gutsy-proposed, please test.

Bryce, this has been stalled for a long time. In case there are misunderstandings, the SRU proposer (you) is responsible for getting the upload done, as per SRU policy.

Changed in xserver-xorg-video-intel:
status: Incomplete → Fix Committed

Unfortunately, one of the entries in the quirk table (i830_quirks.c) is incorrect:

++ /* Dell Latitude X1 */
++ { PCI_CHIP_I945_GM, 0x1028, 0x01a3, quirk_ignore_tv },

This should be PCI_CHIP_I915_GM.

Please have a look at bug 134365.

The patch is as follows:

http://gitweb.freedesktop.org/?p=xorg/driver/xf86-video-intel.git;a=commit;h=cd6f83519c69f72f146fea59afbd6a3542da783a

Martin Pitt (pitti) wrote :

Bryce, can you please provide a fixed version? Thank you!

Changed in xserver-xorg-video-intel:
status: Fix Committed → Triaged
Mika Fischer (zoop) wrote :

FYI, I still have this problem on my Samsung Q45 with current Hardy.

Any info I can provide?

Agostino Russo (ago) wrote :

I can confirm the issue is still present in Hardy (24-1-2008 build). I am also using a Samsung Q45 with intel graphics (https://wiki.ubuntu.com/LaptopTestingTeam/SamsungQ45).

Timo Aaltonen (tjaalton) wrote :

What a coincidence, I just uploaded a new version which should have a fix for this (from upstream):

From: Andreas Stawinoga <email address hidden>
Date: Thu, 24 Jan 2008 00:51:09 +0000 (+0800)
Subject: Samsung Q45 has no TV output
X-Git-Url: http://gitweb.freedesktop.org/?p=xorg/driver/xf86-video-intel.git;a=commitdiff;h=db0a7c569e383436a2725e1e74f35fb426da1196

Samsung Q45 has no TV output
---

--- a/src/i830_quirks.c
+++ b/src/i830_quirks.c
@@ -91,6 +91,8 @@ static i830_quirk i830_quirk_list[] = {

     /* Samsung Q35 has no TV output */
     { PCI_CHIP_I945_GM, 0x144d, 0xc504, quirk_ignore_tv },
+ /* Samsung Q45 has no TV output */
+ { PCI_CHIP_I965_GM, 0x144d, 0xc510, quirk_ignore_tv },

     /* Dell Inspiron 510m needs pipe A force quirk */
     { PCI_CHIP_I855_GM, 0x1028, 0x0164, quirk_pipea_force },

--

closing as fixed, reopen if not!

Changed in xserver-xorg-video-intel:
status: Triaged → Fix Released
Timo Aaltonen (tjaalton) wrote :

Hmm sorry about the noise. This bug was for Gutsy, so reopening.

Changed in xserver-xorg-video-intel:
status: Fix Released → Triaged

Unfortunately, this package has now been released with the buggy Dell X1 quirk in place. Let's hope that this error does not have any side effects for i945 users )-:

Please have a look at the trivial patch included with my earlier comment.

tuxo (beat-fasel) wrote :
Download full text (3.7 KiB)

Unfortunately, this bug is still there in Ubuntu Hardy Heron Alpha 5. Both the login screen (gdm) and the desktop panels do not show up correctly. Regarding the latter, see the attached screenshot.

My laptop contains the Santa Rosa Platform with the intel i965 graphics chipset. The problem seems to be the interfering TV output as can seen by the output of xrandr:

 ubuntu@ubuntu:~$ xrandr
Screen 0: minimum 320 x 200, current 1280 x 800, maximum 1280 x 1280
VGA disconnected (normal left inverted right x axis y axis)
LVDS connected 1280x800+0+0 (normal left inverted right x axis y axis) 286mm x 179mm
   1280x800 59.9*+ 60.0
   1280x768 60.0
   1024x768 60.0
   800x600 60.3
   640x480 59.9
TV connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768 30.0*
   800x600 30.0
   848x480 30.0
   640x480 30.0
ubuntu@ubuntu:~$

As can be seen, the native resolution of the screen is 1280x800 while the TV ouput is at 1024x768. As can be seen on the screenshot, the panels are confined to the latter resolution, while the wallpaper spans the native resolution. The funny thing is that this laptop does not even have a TV output.

Here is the ouput of lspci:

ubuntu@ubuntu:~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Contoller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
01:00.0 Ethernet controller: Marvell Technology Group Ltd...

Read more...

tuxo (beat-fasel) wrote :

This bug is still present in Ubuntu Hardy Heron Alpha 6.

Martin Pitt (pitti) wrote :

I don't think anyone cares about Gutsy at this point, and there is no proposed SRU for Gutsy. If you want to work on Gutsy, please resubscribe ubuntu-sru and do an upload.

Changed in xserver-xorg-video-intel:
status: Triaged → Won't Fix
tuxo (beat-fasel) wrote :

Due to a harddrive failure, I had to reinstall from scratch my Kubuntu/Ubuntu Hardy Heron installation. As of 8.04.1, this bug does not exist anymore for me.

Hardware: Littlebit Sepia X35 (Asus Z37E), Core2 Duo T7300, Intel Santa Rosa, i965 graphics chipset

Bryce Harrington (bryce) wrote :

Thanks, marking fixed as per comment #44

Changed in xserver-xorg-video-intel:
status: New → Fix Released
Changed in compiz:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.