Compiz crashes without reason when open the dash

Bug #1312944 reported by Renan Araujo Rischiotto on 2014-04-25
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Mesa
New
Undecided
Unassigned
Unity
New
Undecided
Unassigned
compiz (Ubuntu)
Low
Unassigned

Bug Description

I was only with the open Google Chrome browser and when clicking on the Dash to open, the system crashes and after some time stopped, appeared compiz error.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: compiz 1:0.9.11+14.04.20140409-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] É um diretório: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 331.38 Wed Jan 8 19:32:30 PST 2014
 GCC version: gcc version 4.8.2 (Ubuntu 4.8.2-19ubuntu1)
.tmp.unity.support.test.0:

ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Fri Apr 25 18:35:54 2014
DistUpgraded: Fresh install
DistroCodename: trusty
DistroVariant: ubuntu
DkmsStatus:
 bbswitch, 0.7, 3.13.0-24-generic, x86_64: installed
 nvidia-331, 331.38, 3.13.0-24-generic, x86_64: installed
GraphicsCard:
 NVIDIA Corporation GT218 [GeForce 8400 GS Rev. 3] [10de:10c3] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: Point of View BV Device [1acc:85d3]
InstallationDate: Installed on 2014-04-24 (1 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-24-generic root=UUID=c1aa0036-0fb4-42b3-bdd9-ba4dbc914a46 ro quiet splash
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/01/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.20
dmi.board.name: G41C-GS
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.20:bd06/01/2012:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnG41C-GS:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.
version.compiz: compiz 1:0.9.11+14.04.20140409-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.0-4ubuntu5
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.0-4ubuntu5
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Fri Apr 25 17:23:33 2014
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Power Button KEYBOARD, id 7
 input SIGMACHIP Usb Mouse MOUSE, id 8
 input AT Translated Set 2 keyboard KEYBOARD, id 9
xserver.errors: open /dev/fb0: No such file or directory
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.15.1-0ubuntu2

Sergio Benjamim (sergio-br2) wrote :

I had 2 crash when trying to search something in dash, just after opened it, i reported in Bug #1311882, but i don't know if it is related to this, since i was running in a VM, and apport get unity instead of compiz to report the bug.

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, your crash report is either missing or challenging to deal with as a ".crash" file. Please follow these instructions to have apport report a new bug about your crash that can be dealt with by the automatic retracer.

If you are running the Ubuntu Stable Release you might need to enable apport in /etc/default/apport and restart.

Now open your file manager, navigate to your /var/crash directory and open the crash report you wish to submit.
If this fails you will have to open a terminal and file your report with 'ubuntu-bug /var/crash/_my_crash_report.crash' where _my_crash_report.crash is the crash you would like to report. If you get an error that you aren't allowed to access this report you will have to file it with 'sudo ubuntu-bug /var/crash/_my_crash_report.crash'.

I'm closing this bug report since the process outlined above will automatically open a new bug report which can then dealt with more efficiently. Thanks in advance for your cooperation and understanding.

Changed in compiz (Ubuntu):
importance: Undecided → Low
status: New → Invalid
Allard Pruim (allardpruim) wrote :

I have the same problem. When I boot up my Ubuntu systems and open the Dash and scroll through my applications sometimes the Dash will hang and eventually crash. As a result a messages pops up with Ubuntu having a internal error and can see that Compiz has crashed. I'm really disappointed that Ubuntu still uses this buggy piece of shit which is called Compiz. I'm planning to install a different DE or Linux distribution if this is not being fixed at all.

Also I don't think it's hardware related since I have this issue on multiple systems with different hardware installed, exactly the same issue.

Stephen M. Webb (bregma) wrote :

I'm suspecting this is a dup of #1300612 since the attached log shows a segfault in Freetype, and that other bug appears to be a segfault when rendering a Freetype glyph. The abundance of segfaults coming from rendering Freetype glyphs is suspicious.

Allard Pruim (allardpruim) wrote :

I'm getting randomly segfaults from compiz, such as:

Sep 16 13:58:18 ubuntu-pc-allard kernel: [ 376.237996] traps: compiz[2330] general protection ip:7fdd0a9b8767 sp:7fffe630d580 error:0 in libc-2.19.so[7fdd0a938000+1bb000]

and:

Jun 17 18:23:17 ubuntu-laptop-allard kernel: [ 281.369735] pool[2606]: segfault at 0 ip 00007fd06ffc09ac sp 00007fd044fe5570 error 4 in libfreetype.so.6.11.1[7fd06ff6a000+9d000]

and more.

Changed in compiz (Ubuntu):
status: Invalid → Confirmed
Allard Pruim (allardpruim) wrote :

Just booted up my laptop and guess what, compiz shits himself again. Only this time I have a different error in my logs but the problem is the same:

Sep 16 18:42:20 ubuntu-laptop-allard gnome-session[2065]: WARNING: Application 'compiz.desktop' killed by signal 6
Sep 16 18:42:20 ubuntu-laptop-allard gnome-session[2065]: WARNING: App 'compiz.desktop' respawning too quickly
Sep 16 18:42:20 ubuntu-laptop-allard gnome-session[2065]: CRITICAL: We failed, but the fail whale is dead. Sorry....
Sep 16 18:40:47 ubuntu-laptop-allard whoopsie[1271]: online
Sep 16 18:42:52 ubuntu-laptop-allard whoopsie[1271]: Parsing /var/crash/_usr_bin_compiz.1000.crash.
Sep 16 18:42:52 ubuntu-laptop-allard whoopsie[1271]: Uploading /var/crash/_usr_bin_compiz.1000.crash.
Sep 16 18:42:53 ubuntu-laptop-allard whoopsie[1271]: Sent; server replied with: No error

Bruno (brunonova) wrote :

Hmm... Unity/Compiz used to crash a lot for me when using the Dash.
But it hasn't crashed for several weeks in Trusty.
It seems to be rock solid now. It only crashes after tweaking Compiz settings or after doing things I shouldn't be doing.
Anyone else with the same experience.

Allard Pruim (allardpruim) wrote :

I'm still using Ubuntu 14.04 as I did a year ago but my dash is not crashing anymore, apparently the problem got fixed in my case. Also when editing some settings in Compiz didn't affect it.

isync (o-zucker) wrote :

This bug affects me since doing a fresh install of 16.04. I tracked it down to the Unity Dash/Docker. Whenever I hover over the left side of the screen, click an app, and on the mouseout (when the docker animation starts to hide it again) compiz crashes, takes a second, and comes back with the "oops, something crashed" dialog or simply a flicker of my open windows.

My current workaround: I'm using Cairo-Dock (aka Glx-Dock, cairo-dock package) for the moment, using it's "Login with Cairo Dock" feature upon Ubuntu greeter asking me for login. No crashes of compiz since then.

[Long rant for the interested]
I had a hard time finding this one with many hours of reboots... doing a fresh install, assuming a hard drive failure, then faulty RAM, trying to circumvent compiz by running Ubuntu MATE first, then switching to gdm via Ubuntu GNOME. All until I found the root is actually the docker, not compiz! I assume that there's something wrong with the FX animation and my graphics card/driver. Or the combination of the Unity Dock + Compiz...
[/Long rant]

Hopefully relevant info:
$ lspci -nnk | grep -i VGA -A2
00:02.0 VGA compatible controller [0300]: Intel Corporation 82G965 Integrated Graphics Controller [8086:29a2] (rev 02)
Subsystem: ASUSTeK Computer Inc. 82G965 Integrated Graphics Controller [1043:81ea]
Kernel driver in use: i915

$ glxinfo | grep 'OpenGL version string'
OpenGL version string: 2.1 Mesa 17.2.4

$ head /var/crash/_usr_bin_compiz.1000.crash
ProblemType: Crash
Architecture: amd64
CrashCounter: 1
CurrentDesktop: Unity
Date: Sun Jan 7 15:00:44 2018
DistroRelease: Ubuntu 16.04
ExecutablePath: /usr/bin/compiz
ExecutableTimestamp: 1471968917
ProcCmdline: compiz
ProcCwd: /home/someuser
ProcEnviron:
 PATH=(custom, user)
 SHELL=/bin/bash
 LANG=en_EN.UTF-8
 LANGUAGE=en_EN
 XDG_RUNTIME_DIR=<set>
ProcMaps:
 00400000-00403000 r-xp 00000000 08:01 4980911 /usr/bin/compiz
 00602000-00603000 r--p 00002000 08:01 4980911 /usr/bin/compiz
 00603000-00604000 rw-p 00003000 08:01 4980911 /usr/bin/compiz
 01efe000-03778000 rw-p 00000000 00:00 0 [heap]
 7fc988000000-7fc988022000 rw-p 00000000 00:00 0
 7fc988022000-7fc98c000000 ---p 00000000 00:00 0
...

isync (o-zucker) wrote :

FIXED/ Works for me. Since

  $ sudo apt upgrade

today of these packages, the errors disappeared:

  libgles2-mesa:amd64 (17.2.4-0ubuntu1~16.04.2, 17.2.4-0ubuntu1~16.04.4),
  libglapi-mesa:amd64 (17.2.4-0ubuntu1~16.04.2, 17.2.4-0ubuntu1~16.04.4),
  mesa-common-dev:amd64 (17.2.4-0ubuntu1~16.04.2, 17.2.4-0ubuntu1~16.04.4),
  libxatracker2:amd64 (17.2.4-0ubuntu1~16.04.2, 17.2.4-0ubuntu1~16.04.4),
  libegl1-mesa:amd64 (17.2.4-0ubuntu1~16.04.2, 17.2.4-0ubuntu1~16.04.4),
  libgbm1:amd64 (17.2.4-0ubuntu1~16.04.2, 17.2.4-0ubuntu1~16.04.4),
  libwayland-egl1-mesa:amd64 (17.2.4-0ubuntu1~16.04.2, 17.2.4-0ubuntu1~16.04.4),
  distro-info-data:amd64 (0.28ubuntu0.6, 0.28ubuntu0.7),
  libgl1-mesa-dev:amd64 (17.2.4-0ubuntu1~16.04.2, 17.2.4-0ubuntu1~16.04.4),
  libgl1-mesa-dri:amd64 (17.2.4-0ubuntu1~16.04.2, 17.2.4-0ubuntu1~16.04.4),
  libgl1-mesa-glx:amd64 (17.2.4-0ubuntu1~16.04.2, 17.2.4-0ubuntu1~16.04.4),
  libpython2.7-minimal:amd64 (2.7.12-1ubuntu0~16.04.2, 2.7.12-1ubuntu0~16.04.3),
  mesa-vdpau-drivers:amd64 (17.2.4-0ubuntu1~16.04.2, 17.2.4-0ubuntu1~16.04.4),
  mesa-va-drivers:amd64 (17.2.4-0ubuntu1~16.04.2, 17.2.4-0ubuntu1~16.04.4)

I'm unable to find the Changelogs. I'm curious: Can someone point out what bug was fixed and fixed this one as well?

To post a comment you must log in.