compiz lower window:<Alt>Button5 stops working

Bug #1311788 reported by Eric on 2014-04-23
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Compiz
Medium
Christopher Townsend
0.9.11
Medium
Christopher Townsend
compiz (Ubuntu)
Medium
Christopher Townsend
Trusty
Undecided
Unassigned

Bug Description

[Impact]

Users who have the horizontal scroll buttons mapped with a modifier such as 'Alt' to other functions using CCSM no longer have working mapped functions. This breaks the user's workflow.

[Test case]

* Need a mouse with horizontal scrolling, ie, click the mouse wheel left and right.
* Open CCSM.
* Map a function to the horizontal scroll buttons, ie, buttons 6 & 7. For example:
  * Enable workspaces.
  * CCSM->Viewport Switcher->Desktop-based Viewport Switching
  * Set "Move Next" to Alt + button 6 and "Move Prev" to Alt + button 7.

[Regression potential]

None identified.

Original Description:

Since upgrading to 14.04, compiz Lower Window key binding as alt+button5 is no longer working completely. It used to nicely cycle through windows but now if a window surfaces that is scrollable, the 'lower window' command stops responding and the window content starts scrolling vertically even though the alt key is still pressed. Clicking the window and then triggering 'lower window' again causes it to temporarily start working again until another scrollable window surfaces.

This is configured under ccsm General Options->Key Bindings->Lower Window.

It worked previously in 13.10. I have since tried unity-reset and reverting all compiz settings.

Other settings:

Click To Focus: off
Raise On Click: on
Auto-Raise: off
Focus Prevention Level: Low

I tested a different plugin "Opacity, Brightness and Saturation" with the same key binding <Alt>Button5 and it does not demonstrate the same behavior; I can tune any window opacity whether the window is scrollable or not.

Setting the alternative Lower Window keyboard binding <Control>Down works without the same interference.

Related branches

Eric (eric-woodruff) on 2014-04-23
affects: gedit (Ubuntu) → compiz (Ubuntu)
Christopher Townsend (townsend) wrote :

Thanks for submitting this bug. This is probably an edge case when I was trying to work around a change in Gtk to allow events from getting hijacked by Compiz.

At any rate, I'll take a look and this and hopefully I can still come up with a solution that makes everyone happy:)

Christopher Townsend (townsend) wrote :

I only see this issue when the mouse is over a Gtk app that is scrollable and not in focus. Now to figure out why this happens...

Changed in compiz (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Christopher Townsend (townsend)
Changed in compiz:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Christopher Townsend (townsend)
milestone: none → 0.9.11.0
Eric (eric-woodruff) wrote :

I really appreciate the prompt attention. I'd be happy to test a ppa or apply a patch and build from source if necessary.

Changed in compiz:
status: Triaged → In Progress
Changed in compiz (Ubuntu):
status: Triaged → In Progress
Christopher Townsend (townsend) wrote :

Hi Eric,

It was my baby in the last cycle to get Compiz working properly with scrolling in Gtk apps due to a change in Gtk during the 13.10 cycle. This has been pretty tricky and I tried hard not to have any regressions, so when I see regressions, I want them fixed:)

At any rate, if you want to try my branch linked in this bug and let me know if it fixes it for you, then that would be great.

Thanks!

Eric (eric-woodruff) wrote :

Since it was just a one-liner it was easier to apply the change to apt-get source and build the .debs and install them. After a unity --replace it works like a charm!

Christopher Townsend (townsend) wrote :

Hi Eric,

Thanks for testing this out and confirming that it fixes it for you. I will try to get this in the 2nd Compiz SRU.

description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.11+14.10.20140606-0ubuntu1

---------------
compiz (1:0.9.11+14.10.20140606-0ubuntu1) utopic; urgency=low

  [ Chris Townsend ]
  * Only ungrab the Mod2Mask modifier on buttons 4-7 to allow scrolling
    in unfocused Gtk windows while still allowing keybinding modifiers
    to other scroll wheel actions. (LP: #1311788)
  * Fix issue where window decorations would be placed under the Panel
    when opening a new window from an already open window. This is due
    to the already open window being taller or just as tall without be
    maximized than the workspace. (LP: #1303462)
  * Only constrain the non-modifier scrolling to the vertical scrolling
    buttons - buttons 4 & 5. (LP: #1311303)
  * Fix issue where maximized windows would get moved to different
    workspaces when disconnecting/connecting an external monitor.
    Windows should stay in the same workspace they are in when the
    monitor event occurs. (LP: #1304531)
  * Fix issue where custom keyboard shortcuts would get reset to
    defaults when rebooting or restarting Compiz. (LP: #1063617)
  * Fixes issue in the Expo plugin where a gap is shown in the place
    where the Launcher and Panel should be when windows are maximized.
    This was originally removed in rev. 3481. (LP: #1087090)
  * Fix issue where horizontal and vertical keyboard resizing could not
    happen at the same time. (LP: #347390)

  [ Marco Trevisan (Treviño) ]
  * Scale: use XShape extension to exclude dnd input in the screen-parts
    outside workArea This will work property also in multi-monitor,
    without requiring multiple X windows for each output device. Also
    don't terminate the scale unless a drag-n-drop action is not really
    over. Add a spinner that shows up over a window, during the DnD
    timeout. Plus, make sure we terminate the scale without focusing the
    selected icon when cancelling it and some code cleanup (LP: #607796)
  * Event: set the screen grabbed also when we get a NotifyWhileGrabbed
    Focus{In,Out} event (LP: #1305586)
 -- Ubuntu daily release <email address hidden> Fri, 06 Jun 2014 09:43:06 +0000

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
Changed in compiz:
milestone: 0.9.11.0 → 0.9.12.0
status: In Progress → Fix Committed
Christopher Townsend (townsend) wrote :

The fix for this has caused a small regression, so it can't be included in the pending Compiz SRU and has to be reverted. The good news is that a proper fix has been identified, so we'll work on getting that into Utopic and then into the Trusty Compiz SRU after this one.

On Tue, Jun 17, 2014 at 08:14:53PM -0000, Christopher Townsend wrote:
> The fix for this has caused a small regression, so it can't be included
> in the pending Compiz SRU and has to be reverted. The good news is that
> a proper fix has been identified, so we'll work on getting that into
> Utopic and then into the Trusty Compiz SRU after this one.
>
> ** Branch unlinked: lp:~townsend/compiz/0.9.11.1

Yay, thanks!

--
Kind regards,
Loong Jin

Stephen M. Webb (bregma) on 2014-11-06
Changed in compiz:
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) wrote :

Attaching debdiff between source in trusty-updates archive and proposed SRU fix.

Hello Eric, or anyone else affected,

Accepted compiz into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/compiz/1:0.9.11.3+14.04.20141104-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in compiz (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Eric (eric-woodruff) wrote :

I installed the proposed update at it fixes the problem for me.

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for compiz has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.11.3+14.04.20141104-0ubuntu1

---------------
compiz (1:0.9.11.3+14.04.20141104-0ubuntu1) trusty; urgency=medium

  [ Chris Townsend ]
  * Add NumLock and CapsLock button ungrab keymasks, so unfocused Gtk
    window scrolling will work when NumLock is off and CapsLock is on
    and any combination thereof. (LP: #1311788)
  * Fixes issue in the Expo plugin where a gap is shown in the place
    where the Launcher and Panel should be when windows are maximized.
    This was originally removed in rev. 3481. (LP: #1087090)
  * Bump version to 0.9.11.3.
 -- Ubuntu daily release <email address hidden> Tue, 04 Nov 2014 19:42:46 +0000

Changed in compiz (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers